Live Update Bugs 06/21/17

Discussion in 'Test Update Notes and Bug Roundup' started by EQ Dev, Jun 21, 2017.

  1. Xyroff-cazic. Augur

    I got update from this:

    06/23/17 03:19:24 AM You have slain a goblin janitor!
  2. Omegga Lorekeeper

    Coldain Ring 6 in Eastern Wastes: Icefang gets buffed by Korigan and starts to run from the hut and then disappears and respawns and repeats.
  3. Omegga Lorekeeper

    Icefang continues to try to run out after Korigan despawned during game day.
  4. Velisaris_MS Elder

    An update to the anchor issue (for me, at least):

    This is all on Drinal.

    I managed to get all of the anchors (primary/secondary/guild) on all of my toons working but two of them. I got the anchors working on those characters by deleting the layout files, picking up the anchors and putting them back down, then deleting the layout files again. So far, they all still work, even if new layout files are created.

    The two toons that still have non-working anchors are the primary toons on each of my two accounts. Coincidently, they are also the only toons I have that bought real estate plots. And their anchors are non-functional ONLY in the guildhall (palatial guild hall). One of my other toons is listed as a co-owner of a house, but that toon never actually purchased any real estate.

    The anchors of these two toons function normally (with or without layout files):
    - in houses/yards that I already owned prior to this last patch
    - in houses/yards that I bought after the patch
    - in the yard of the guild hall

    The ONLY place they will not function is the guildhall; I still get the "no anchor was found" message. All of my other toons have working anchors in the guildhall. At first, I thought the working anchors of the other toons might have something to do with the fact they they have nothing else in the guildhall other than the anchors. I bought a few items on other toons, threw that stuff down, and the anchors still work.

    Like I said, it may just be a coincidence that the only toons that have anchors that won't work in the guildhall are the only toons I have that bought real estate plots (someone else in the guild owns the guildhall and its plot), but it just seems odd.
  5. Ngreth Thergn Developer

    This should be fixed in the July patch.
    The 70 purity on the raid chest items is also fixed for the July patch to 75.
    I'm looking into other issues like the type5 for 2 handers, and stats on the raid items.

    I addressed the spam issue in a progression server thread.
    As for this... it looks like the events and bits made it in the patch, but not the achievement data itself. Basically, I ran out of time and stopped development partway. Since the bits are in, people will get credit when the achievements make it in in July.
    Fanra likes this.
  6. Manditik New Member

    I just posted this in a different thread but I think I should have put it here.

    Conqueror of The Halls of Honor appear to be bugged. My guildmate did them when the server came up and I just did them and hailed on Bert and all Three do not show complete. I also verified with seer.
  7. Hludwolf Developer

    Thanks for the report. I will investigate this further.

    If anyone else can chime in as well as to if this is NOT the case for you, please let me know.
  8. Khat_Nip Augur

    This is the first time I encountered the anchor issue. Somehow I wasn't affected by it when it was brought up by others.

    Yesterday I tried to use my Primary Anchor Transport Device (in palatial guild hall) and it failed with message:
    Your transport to anchor spell failed because no placed anchor of the required type was found.
    I put the anchor in inventory, logged out, logged back in, replaced the anchor in the Hall, logged out, logged back in, and received the same message when trying again after cooldown was over.

    I then tried to use my Secondary Anchor Transport Device which is sitting outside on the plot of one of my houses and it worked normally. I then picked that up and put it next to my failing Primary Anchor in the Hall and checked both after cooldowns and get the fail message on both.
    GoldenFrog likes this.
  9. Grig-zek New Member

    Beastlord 'Feral Swipe' attack is still broken.

    You have a roughly 1/3 chance of it missing, 1/3 chance of it hitting at less than max dmg, and 1/3 chance it will hit max dmg or above. Prior to when it was broken (and before the initial attempt to fix) it missed maybe 3-5% of the time. This is a 9-second refresh attack, it shouldn't be missing a third of the time. If that's what was intended all of the sudden, why such a big nerf to the class?
  10. Kirkisx Augur

    icefang on luclin for coldain ring quest.. just keeps spawning and despawning can't complete that arc of the quest idk if zone just needs repopped or its a bug
  11. Malbro Augur

    I have 3 characters that have non functioning anchors when IN the neighborhood guild hall. Two of them have plots and 1 doesn't.

    The anchors are now placed on the plot just outside of the hall and they work there. Heroes guild on Luclin.
  12. CatsPaws Augur

    Try this: either put the anchor in inventory or have another char mail it to you - then open your guild manage screen - click plot layout - delete ALL files with your character name. Close the screen, recover your anchor from where ever it is and put it back down. I zoned in between when I did this just cause I wanted to make sure it was fixed. Some of my alts I did not zone and it worked also. Players have found this MIGHT be a solution to the anchor issue. It works on halls, plots, houses, primary anchor, secondary anchors and subscription accounts and free accounts. Only person I know of that it did not work for was a port class who had the spell giving an error also.

    Disclaimer: this probably wont work on AB or Cazic Thule server since they are weird.
  13. Ngreth Thergn Developer

    This is on the list for a fix.
  14. Kirkisx Augur

    Ngreth can ya repop eastern wastes for me on luclin seems to be bugged with icefang
  15. Prathun Developer



    Verified. Looking into a fix. Repopping will not fix the problem.
  16. adetia Augur

  17. Prathun Developer

  18. adetia Augur

    i'd like it but my like button is still on vacation! Thanks for checking into it!
    Schadenfreude and Prathun like this.
  19. Prathun Developer

    Happy to fix it! This was the weirdest bug I've seen in awhile and relies on some obscure old EQ functionality that I didn't even know existed.

    And... we get the report button back but now the like button is gone? The forums gods giveth and then taketh away.
    Schadenfreude and Sindaiann like this.
  20. Horyuken Augur

    Do you ever find old code and A. wonder what that developer was thinking, or B. This guy was a genius that he was able to make this work!

    I can only imagine the stuff you all stumble upon with code that is 2 decades old ;)

Share This Page