Enabling GPU Particles Causes Random CTD

Discussion in 'Player Support' started by BetaGuru, Jul 21, 2013.

  1. BetaGuru

    So I've noticed that by enabling GPU particles (on any setting, I've experienced this problem jmost recently on Low) I run the risk of randomly CTDing. I was wondering if we could isolate what is causing this issue and stop it, because I feel my system should be more than adequate to run with them enabled.

    Here are some relevant specs:

    Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.120503-2030)
    Language: English (Regional Setting: English)
    System Manufacturer: System manufacturer
    System Model: System Product Name
    BIOS: BIOS Date: 02/05/10 19:13:52 Ver: 08.00.10
    Processor: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz (8 CPUs), ~3.4GHz
    Memory: 16384MB RAM
    Available OS Memory: 16360MB RAM
    Page File: 6502MB used, 26217MB available
    Windows Dir: C:\Windows
    DirectX Version: DirectX 11
    DX Setup Parameters: Not found
    User DPI Setting: Using System DPI
    System DPI Setting: 96 DPI (100 percent)
    DWM DPI Scaling: Disabled
    DxDiag Version: 6.01.7601.17514 32bit Unicode

    Card name: NVIDIA GeForce GTX 580
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 580
    DAC type: Integrated RAMDAC
    Device Key: Enum\PCI\VEN_10DE&DEV_1080&SUBSYS_15823842&REV_A1
    Display Memory: 4063 MB
    Dedicated Memory: 1503 MB
    Shared Memory: 2559 MB
    Current Mode: 1920 x 1080 (32 bit) (59Hz)
    Monitor Name: Generic PnP Monitor
    Monitor Model: VW246
    Monitor Id: ACI24F2
    Native Mode: 1920 x 1080(p) (60.000Hz)
    Output Type: DVI
    Driver Name: nvd3dumx.dll,nvwgf2umx.dll,nvwgf2umx.dll,nvd3dum,nvwgf2um,nvwgf2um
    Driver File Version: 8.17.0012.8566 (English)
    Driver Version:
    DDI Version: 11
    Driver Model: WDDM 1.1
    Driver Attributes: Final Retail
    • Up x 1
  2. PhysicsMan

    Indeed, I have this problem too so I just disabled GPU particle PhysX until they come up with a fix (and my system is more than adequate to run GPU particles at high).
  3. BlackDove

    PhysX was working for about one GU. It's been broken again for a while. Just play Borderlands 2 or Orcs Must Die 2 if you want to see PhysX that works.
  4. BetaGuru

    Am I to understand by your replies that there is no fix to this? Can someone please explain what the source of the problem is, even if it cannot be solved on my end? Telling me to play a different game is less than entirely helpful.
  5. Ealhdun

    Essentially physx in this game is still very experimental. I personally see it as being in a beta testing phase.

    That being said, personally I have had 0 crashes during this GU with the slider set to medium using 320.49 WHQL drivers and modifying nvidia control panel setting for power to maximum performance (had to do that since my computer doesn't like adaptive and shuts down my gpu the moment I log in to windows 8 when it is set to that)
  6. BetaGuru

    That's all well and good and it's nice to hear that you're not having an issue, but I'm not sure how this helps me resolve my issue with random CTD?

    Why would I be experiencing these CTDs whereas other people are not?
  7. fumz

    Perhaps the answer lies in the fact you're using drivers from 2011? 285.66's are old. If the rest of the system is as up to date driver wise as your video drivers are, I'd get started updating.
  8. BetaGuru

    From 2011? That's... odd. I've definitely updated since then. Hell, the computer is only a year old and I've upgraded since...

    I'll give it a shot and update this thread with result.
  9. travibaby

    I have all the updated drivers for my ATI 7770 yet the problem is still extremely prevalent. Its not physx, my game has had the physx option greyed out from the get go and i dont even have an nvidia card so i find it hard to believe that its the physx, especially since everyone is saying that its in dormancy right now anyway.
  10. fumz

    If you have an amd card you will not get the option to enable gpu physx; that's an nvidia only thing. I don't know when exactly nvidia started letting amd use physx, but it was a while back. If amd users want to use physx it has to be in the game and it will run off your cpu... which is a bad option in this cpu intense game.
  11. Caspartine

    Still, I'd like to test it, at least, Borderlands 2 let me enable the physics, even when it means a huge fps loss due to the CPU processing all that particles. I'd really love to see the option for AMD users as well, at least some of those effects.
  12. Ealhdun

    I gave you a setup that works on another system, since you obviously haven't tried that combo yet it is worth trying a similar one by using similar drivers and settings. It is no assurance it will work obviously but it is entirely possible some of the crash issues were solved by a newer physX driver.

    PS. make sure you remove every trace of nvidia drivers and physx before installing a new version, updates can cause weird problems.
  13. BetaGuru

    Alright, so I updated my drivers to the most current version.

    I continue to experience the same issues as before with no change in the "pattern". I continue to suffer randon CTDs with particles turned on.

    I am open to additional ideas for why I may be experiencing this problem.
  14. BetaGuru

    If it helps, I've noted that sometimes the CTD triggers when I'm spawning in a new location. Only very rarely have I crashed while in the middle of gameplay. However, that, too, has happened.

    Is it perhaps because I have it set to "low"? Or can it be unconnected with my driver version?
  15. BetaGuru

    No responses!

    Well, in that case I'm going to try a number of different possible fixes and document my efforts here. I might as well, in case someone else has a similar issue. I'm a little disappointed at the silence from SOE on this one. You'd think they could toss me a pointer or two. Wouldn't go amiss, for sure.
  16. fumz

    I'm not. Even though I've only been here a little while I can already tell that their first instinct is to deny that problems exist, at least problems on their end; however, they are quick to place blame on the user.

    If you manage to find something that works, then please do post about it, just don't get your hopes up. Most guys have learned, no matter how badass the rig, that it's broken and will likely stay that way for most users.
  17. OrrwrenX


    I had encountered massive CTD problems for a long whiles, forcing my hand in disabling the Physx GPU settings. (A damn shame too, I very much enjoy the visual appearance of the lifts.... which looks absolutely fancy)

    For about a month, I was still unable to enable GPU Physx, even after the developers changed the setting. (The setting use to be a simple "On" or "Off", now its "Low", "Medium" "High".)

    However, recently I found a fix that has solidly worked (for me) since put into effect two weeks ago.
    I have Ultra textures and GPU set to "High", however I run the game on either Windowed or Windowed Fullscreen.

    I found that when running on Fullscreen, the game would constantly and frequently crash to desktop, but after changing to the other screen options, I experience perhaps 1-2 random crashes a week as opposed to 2 per hour.

    I hope this helps another person until the developers can fix it for everyone. (Also: My computer is running Nvidia version 314.22, which I understand is outdated but I was forced to revert back to 314.22 from the newest one because support discovered that the newest drivers were causing massive crashes. Everything works perfectly so I haven't felt the need to update it... and frankly, I've been scared to)
  18. BetaGuru

    Man... thanks for the response, but you're breaking my heart. I was so excited, until I heard your solution. Why?

    I've been playing on windowed fullscreen the entire time. :(

    I'll maybe try fullscreen. Perhaps I live in Opposite world, and that'll fix it for me. We'll see!
  19. OrrwrenX

    Aw bummer! :(

    I'm sorry to get your hopes up Mr. Beta. If all else fails, try using driver version 314.22.
  20. ReTiCuLe


    Try this PhysX driver, http://www.guru3d.com/files_details/physx_system_software_9_13_0325_download.html

    Yes this Physx driver is OLDER 9.13.0325 than the current one.

    Uninstall your current Physx drivers first. If they're 9.13.0604 especially (they will cause problems for physx games) like crashing and more. There's a few other versions that did too, I don't remember the exact #'s I only remember and know the one above works. I myself have it installed and I change drivers like condoms :p

    Try to use driver-sweeper if you do install the one i linked and still experience issues.

    Also, for best results (no I haven't read through the whole thread) DONOT install over your current Nvidia drivers when-ever installing them. You're better off this way for a clear conscience they are installed properly.

    This is what I do when installing beta / offical drivers. I install everything I from the nvidia driver installer that I want, under CUSTOM install excluding Physx driver X.XX.XXX which I install http://www.nvidia.com/object/physx-9.12.1031-legacy-driver.html then the latest Physx, in this case (9.13.0325) after the drivers / rebooting.

    Note: the legacy driver is a one time install (9.12.1031-legacy-driver.html) it's different from the latest Physx installers bundled with drivers or available from nvidia.

    If you want to find more specifics on why and how this doesn't crash, please go to the guru3d forums and look around.

    - ReT