Info Needed Call of the Veteran - RNG

Discussion in 'Bug Reports' started by Wulfgyr, Feb 14, 2020.

  1. Tagg Member

    Skyfire: around 9pm Central on 11/16/2020 , character: Terek tried to call Ixopia to Eastern wastes near Kael from A Teir 3 Freeport guild hall. Player Ixopia tried to use his own call from the GH to me in EW. It also failed. Tried to call Ixopia while he was in EW as well and it failed again. Another guildy also tried to call to me in EW from our GH and his failed as well.

    No one in combat, no one on transports
  2. Bunji Developer

    Hey Tagg, just to verify, are you getting the confirmation window on the zoning character, and nothing is happening once they click "yes"? I turned on some more zone logging for Skyfire. If you're able, please try and repro it once more.
    Breanna likes this.
  3. Juraiya Well-Known Member

    Had it happen to me recently on Maj'Dul a couple of times. Unfortunately, I didn't think to note the time in either case. Once was when I was trying to CoV a Good into FP to help someone make a guild; we figured that probably you just can't CoV someone from the opposite alignment into a city. (Although you used to be able to do that in the past, so people could do the Newsies updates.) The other time I was trying to CoV a friend's low level character to EJ in order to fight the puppet there.

    Both times it stuck on "teleport pending" with no further information. As someone suggested earlier, if it also reported to both players the reason that it failed, that would give us more information that we could report to you. Even if it is programming code, we could still report the error verbatim, and then you guys might know what to do with it.
  4. Sigrdrifa EQ2 Wiki Author

    The code has to be checking conditions before it decides it can do the port. For each condition being checked, just send a brief, unique note to the chat window and logfile saying why the port failed.

    *This is kinda how I used to debug code I was revising that was often 15 years and 10 programmers old... I'd have different decision trees drop a message in a log somewhere. (Untangling other people's spaghetti code was a big part of my decision to slide into technical writing!)
    Juraiya likes this.
  5. Tagg Member

    correct. they click yes and nothing happens. You then have to wait for the cool down to happen before you can try again. Which it again failed that night.

    I will try and do some more testing with it as well as asking other guild mates to note the time, location and character names as we have had it fail for multiple people quite often recently
    Breanna likes this.
  6. Tagg Member



    Happened again tonight 11/20/2020

    8:39 pm CST
    Character: Merefein. Teleporting to: Euology.
    Zone: new tunare to jarsath

    8:58 PM CST
    Characters: Nualah and Yolsen
    Zones: Blinding teleport to jarsath
    CoV failed both ways on this attempt
  7. Tagg Member

    Happend 11/22/2020 5:37pm CST

    Character: Alarick called to Sompsin
    Zone: T3 FP guild hall to Eastern Wastes
    Moorefallen likes this.
  8. Bunji Developer

    Thanks for the info, I'm in the process of adding more logging for this process.
    Breanna, Juraiya, Tagg and 2 others like this.
  9. Beee Well-Known Member

    A CoV for a character (without signature and own CoV) to to SW sometimes works and sometimes not. This is a little bit anoying.

    SW is not full, no difference if SW2 or more, no difference if it's from guildhall or Midst
    WhysperWynde likes this.
  10. Hilarie New Member

    We've tried not doing all of those things, it doesn't make a difference, it messes up trying to go to eachothers house sometimes etc, it isn't just fighting or flying or whatever.

    We'll talk to one another, not in a fight, not flying, not running around, still a crapshoot.
  11. Ratalthor Developer

    Can anyone private message me your character names, your server, and at what time you had this issue happen?
    Uwkete-of-Crushbone likes this.
  12. Ratalthor Developer

    Bumping for info. If you are affected by this issue, please PM me your character, server, and at what time the issue happened.