QA In Progress Call of the Veteran - RNG

Discussion in 'Bug Reports' started by Wulfgyr, Feb 14, 2020.

  1. Raff Well-Known Member

    Its been buggy for years. I just take it in stride any more when it doesn't work and use call of the tinker .
    Laaw and Breanna like this.
  2. Whilhelmina Well-Known Member

    Just failed right now. I was trying to teleport from a Qeynos house to a char in Moors. Summoning doesn't work either. I moved both chars before trying, no dice.
    Breanna likes this.
  3. Observing Active Member

    Call only works about 10% of the time for me within The Blinding (both starting and ending point are in this zone), yet conjuror's Call of the Hero works 100% of the time under the exact same circumstances.
    Feldon, Juraiya and Rosyposy like this.
  4. Whilhelmina Well-Known Member

    As usual, when I tried to call my char from Antonica to Commonlands for the Tinkerfest PQ, the call failed (I wasn't in fight). Every single time I try to call another char to me for those PQ it fails (tinkerfest and Erollisi). Even if PQ isn't up.
    Feldon and Rosyposy like this.
  5. Observing Active Member

    I am getting pretty tired of this item.
    Has about a 0% success rate porting from Greig's spire into the Shiknar caves in the Blinding
    Feldon likes this.
  6. Zolar New Member

    This is crazy that they have not been able to reproduce this bug, it's been happening since the item was created many many years ago and everyone knows about it and experiences it. I two box and have this happen to be almost daily. Standing still after some movement doesn't always help. One thing I have noticed is that I have more trouble porting into populated zones. I've had multiple times where I couldn't port into Everfrost with different characters, but as soon as I was in Scion of Ice it worked fine. Once I noticed this about a week ago, I've been trying to port to instances only and I've not had an issue since- knock on wood.
    Feldon likes this.
  7. Laaw Well-Known Member

    it
    's been an been an intermitted problem since release
    Feldon likes this.
  8. iceverything Master of Respawning

    I have noticed a pattern. It will work for about 2 weeks with little to no issues. Then BAM it is pending. This seems to last for at least a month. And the change is ALWAYS after a freaking maintenance day. I really dread Tuesdays anymore.
    More than 60% of the time it fails. It is not based on ANYTHING the player is doing. It is the GAME. I think we know how to use COV so tired of some blaming the player.
    Giving us a reward that is busted is not giving us a thing but headaches. If you cant fix it then replace it but to leave it as it is is not how to do it.
    Juraiya likes this.
  9. Roadkillusa Active Member

    see the issue is that it is random. I have had this happen many times while in different zones and instances. one time it works fine and then the next it fails under the same circumstances. In my opinion the code should be totally rewritten
    Feldon likes this.
  10. Flatline Well-Known Member

    So anecdotally it doesnt work when either person :
    Standing on an uneven surface/rock/boulder the like
    Standing in a puddle (The game considers you to be swimming i guess?)
    Standing on an elevator or the like
    Trying to cov any instance with entrance requirements, weather you meet them or NOT.

    One fix COULD be to not apply the cooldown of the item, till the teleport effect goes through, ie not applying it on use
    (Not sure this have been suggested and havent read it all, my bad :)
    Juraiya and Whilhelmina like this.
  11. Whilhelmina Well-Known Member

    That one isn't always true. I tend to CoV one of my char on the other when doing overland named in Luclin and I typically CoV a char to the other when standing next to Cluster (named elemental near Recuso Tor). I do so while standing on the very uneven low part between the high where Cluster is and the cliff behind it. CoV only failed once (out of dozens of time) and I had to bring my mystic to the Blinding and CoH her.
    Feldon and Breanna like this.
  12. Chris Thompson Active Member

    Still broke. Seems to fail much more often when summoning than when travelling.
    Feldon and Uwkete-of-Crushbone like this.
  13. Uwkete-of-Crushbone Well-Known Member

    I.e., Calling someone rather than being on the receiving end?

    Uwk
    Chris Thompson and Breanna like this.
  14. Chris Thompson Active Member

    Um. The more general way to say it would be, Bringing someone to you. I don't think I've ever had a problem when the person using CoV is traveling to another player.
    Uwkete-of-Crushbone likes this.
  15. Feldon Well-Known Member

    Call of the Veteran worked almost perfectly when it first went in.

    Then people tried to CoV to zones they didn't have access to, had a different lockout for, or countless other reasons why they couldn't travel. The person simply received an error message and the CoV portal evaporated.

    Apparently this was deemed bad, or maybe someone figured out how to use CoV to shortcut things they shouldn't have been able to get to, sooooooo the devs started adding hundreds of preconditions which must all be confirmed to be True before CoV can be attempted. And it's been broken every since.

    It can fail for a hundred different absurd reasons and more conditions are added all the time. Countless fixes have been attempted, but the core issue is rather than constantly trying to add more and more smarts to it, just make it dumb! CoV should just open a portal, and if you can't go, it should just fail. Devs trying to comb through 10 million lines of code trying to find all the possible conditions to check for FIRST before allowing you to even try it is never going to work.

    TL;DR: Roll it back to how it was at launch and leave it alone!
  16. Bunji Developer

    I'm adding more logging to try and find the cause of this issue. If you've had this issue recently, please reply with the time, server, character names, and if you were summoning or zoning to a character. Thanks.
  17. Ixian Active Member

    One of the most common reasons for CoV failing was a creature having any kind of hate on you. The way EQ2 works, a creature maintains a hate list, but your player entity also knows what hates you, and if anything exists on that "stuff that hates me" list, CoV will fail -- regardless of whether or not you're in combat. In fact, the thing that hates you might not even be alive anymore, but if it wasn't cleaned up properly, you might still think it hates you. I believe there was a fix put in to occasionally check what's on your hate list and verify it still exists in the game world, but I suspect there are also scenarios where something hates you, is still alive, but you're not interacting with it in anyway and it still exists on your "things that hate me" list for whatever reason. (I'd guess this rule also applies to characters on both ends of the CoV but I don't remember for sure. :p)
    Uwkete-of-Crushbone likes this.
  18. Beee Well-Known Member

    On Thurgadin i have a reproducable bug: in Frostfang a lv 110 Char tries to teleport a lv1 char in the same zone => lv1 char gets no popup, teleport always pending. Porting the lv 110 -> Lv1 works always
    Uwkete-of-Crushbone likes this.
  19. Svenone Well-Known Member

    The Call item might be better if it told both the caller and the callee the reason for the failure when it fails. Even better would be if it didn't start the used cooldown timer until it actually transports a character! Actually, both would be awesome and useful changes.

    Example: CoV failed because %T is <reason>.
    Reasons: is flying, is in combat, is on an elevator,...whatever other reason for failure is present.
  20. Ratalthor Developer

    Reminder to stay on topic in these bug threads.

    Has had this issue recently? Please reply with the time, server, character names, and if you were summoning or zoning to a character. Thanks.
    Uwkete-of-Crushbone likes this.