Launcher broken suddenly on all 3 PCs

Discussion in 'Player Support' started by Sam Hyde, Nov 29, 2023.

  1. Sam Hyde I'm a monster but not an NPC

    Suddenly, the launcher will not open, and the change was definitely not on my end. When I attempt to run the launcher I get the error:
    The procedure entry point GetSystemTimePreciseAsFileTime could not be located in the dynamic link library KERNEL32.dll

    I can only assume this is due to an update to the launcher. I have two PCs for playing EQ, one for me and one for the family. I have a laptop that occasionally gets used for EQ. The launcher gives the same error on all 3 machines. I was just playing last night, and suddenly this morning the launcher is broken all around. What did they change?
    I suspect I'll soon be re-downloading EQ since I can't patch the patcher without the patcher.
    Sheebea likes this.
  2. Sheebea Augur

    Same problem here. win7 OS. Tried re-booting pc and router and still no go. Clicked launch exe. Clicked EQ .exe. FAIL. Worked fine up to late last nite.
  3. Soulbanshee Augur

    Setup.exe only installs LaunchPad.exe that then downloads all the game files from the server. LaunchPad hasnt had any files changed since 2017.

    Looks like you are running Windows 7. Is this on test server? Did you install the manual patch listed on the DX11 announcement?

    You might have to download and reinstall all the Visual C++ versions, or at least the 2015-2022 version.
  4. Sam Hyde I'm a monster but not an NPC

    Also Win 7 (the best version!).
    I actually have a new PC with win 11 I already have EQ on, that I was about to move my drives over to and use as my main. I will hook that one up and report back.
  5. Sam Hyde I'm a monster but not an NPC

    Yes Win 7
    No test server
    No manual patch

    Google seems to say Windows 7 does not have the feature in KERNEL32 that the launcher is now calling for.
  6. Tyranthraxus Grognard

    Same Windows 7 64 bit, I loaded in with no issues before the test server reopened this afternoon.

    Windows 10 PC is loading launcher with no issues. Definitely a Windows 7 issue, and definitely new
  7. Soulbanshee Augur

    There's been no patch to the live client. Try reinstalling Visual C++.
  8. Sam Hyde I'm a monster but not an NPC

    KERNEL32.dll is a core windows component, not visual C
    Edit: further google search says you cannot update KERNEL32.dll in such a way as to add this function.
  9. Sam Hyde I'm a monster but not an NPC

    Update: All is working on windows 11.
    It's a windows 7 problem caused by bad coding in whatever change was made to the launcher. Someone put in a dll call that can only occur on windows 10 and 11. It's happening to multiple people starting this morning, thus, there was a change to the launcher.
  10. CatsPaws No response to your post cause your on ignore

    Moved response to bug report post
  11. madeye New Member

    Win 7 on two computers both say procedure entry point "GetSystemTimePreciseAsFileTime could not be located in dynamic link library KERNE32.dll
    was on game on both computers this morning and it worked fine
  12. Sam Hyde I'm a monster but not an NPC

  13. CatsPaws No response to your post cause your on ignore

    We should stick to the post in the bug forum about this for clarity
  14. Sam Hyde I'm a monster but not an NPC

    Well I, at least, linked it here
  15. Nekk Augur

    Gonna ask the same question - did you try bypassing the patcher?
  16. niente Developer

    This has been explained a couple times but just in case this helps:

    Create a file named StartEQ.bat or whatever you like.

    Put the following in the file, replace accountName with your account name.
    Code:
    cd "C:\Users\Public\Daybreak Game Company\Installed Games\EverQuest"
     
    start eqgame.exe patchme /login:accountName
    You can also start with just eqgame.exe patchme.

    If your EQ install is not in C:\Users\Public\Daybreak Game Company\Installed Games\EverQuest, you'll need to replace that with the correct path as well.

    Double click StartEQ.bat and the old login client will start. You can log in without LaunchPad in this way.
  17. Sam Hyde I'm a monster but not an NPC

    Thanks for describing why this issue is occurring and not being smarmy.
  18. Sam Hyde I'm a monster but not an NPC

    To anyone with this problem: The forums are going to be your only outlet.
    This issue is not fixable.
    Because to fix the launcher, you'd have to run the launcher...
    The only solution to this will be to re-download the base files once they remove the offending code. For reasons I cannot explain, I get the same error with launchers from backup folders dating back to 2019 and 2017.
  19. Holdover New Member

    I wish the solution niente posted worked.

    I keep getting the message:

    Windows cannot find 'eqgame.exe'. Make sure you typed the name correctly, and then try again.

    I typed:

    cd "E:\Program Files\Sony Online Entertainment\AltEverquest"

    start eqgame.exe patchme /login:MyAccount

    (yes, I have been running from the same directory over a number of computers over twenty five years, so I use a fairly old path).

    If I go into that directory, it does indeed have a file called eqgame.exe, but trying to run that directly gets me a message to run Launchpad.exe.

    Trying to make the batch file directly from the directory referencing eqgame.exe goes back to claiming it cannot be found.

    If I replace the first line with:

    cd "E:\Program Files\Sony Online Entertainment\AltEverquest"

    start launchpad.exe

    It finds that and gives the new error message (or one of them; I alternately get two), which indicates the path is working.

    I wish I could figure out what is going on with this.
  20. Sappas Journeyman

    The message on the main forum page sounds like they plan to fix this. I think I will hold off though on buying the new expansion until I know for sure. No point in buying it if I won't be able to play. Even if the patcher bypass works for me it will only work until they do the next patch... right? My game will be out of date after that I'm assuming and won't run anymore.