Re-downloaded this game. Whisky Tango Foxtrot?

Discussion in 'PlanetSide 2 Gameplay Discussion' started by The Crimson Overlord, Feb 9, 2020.

  1. The Crimson Overlord

    So. Its been a few years. Last I remember playing P2 was in 2017. Maybe earlier. Anyway.

    Short version: My game runs like complete crap despite having a dare I say "good" computer, what can I do to improve performance? (Specs below.)

    Long version: I've disabled hyperthreading, set the priority in task manager to High, lowered settings all the way from Ultra going down to Very Low with -NO- improvement at all, the game still stutters and chops along. I can be walking around open wasteland and go from 50 FPS to 20 for a solid 5 seconds before it randomly rises and dips again. Forget combat, if its 30+ people shooting with particle effects and smoke everywhere my game turns into a nice slide presentation. I don't get how years ago with a scrap heap laptop the game ran on High with acceptable performance yet now with a dedicated graphics card and leagues more upgrades over my old computer it runs like a hippo with 3 legs. POORLY AND WITH NO COORDINATION.

    Rant over. Specs below. Please help, I want to get back into this game. Thank you <3
    CPU: Intel Core i7-8750H @ 4.0 GHz, 6 cores, 12 processors
    Memory: 16 GB RAM
    GPU: NVIDIA GeForce GTX 1050 Ti with 4 GB VRAM ( yes I know its an older GPU but that doesn't mean "lole can't run game" so don't come at me with that )
  2. Skraggz

    -Drivers up to date?

    -Geforce experience Up to date?

    -What HDD do you have this on? Is it a HDD or SDD? If HDD are you spiking read/write when you dip of frames?
    If so I suggest hunting for a program running in background OR a windows option that is utilizing resources.

    -Shadowplay running?


    If you can lower settings and gain no benefit it sounds like the issue isn't so much the game, and no I am not calling your pc a potato. Just sounds to me like something is hogging your pc.
  3. Delfinovic

    Sorry to hear that, while I have no conclusive answer, some tips maybe helpful?

    I run GeForce GTX 1660 6GB, i7-9700 8-Core 3.0GHz, 32GB on Ultra (full HD) at 120 FPS, dips rarely below 90...

    Questions are; what resolution? what render distance? smoke enabled? You sure no other things are eating CPU/GPU/bandwith/HDD?

    In game you can turn on FPS counter (in game one Alt+F, it shows your current bottleneck too) and tweak options accordingly (mouse over for tips per setting, kinda helpfull).

    You can also try ini file tweaking with help of this http://www.kivikasvo.fi/iridar.net/iridar.net/planetside2/performance-guide/index.html
  4. csvfr

    I have more or less the same rig as you (i7-8700, identical graphics card) and the game runs just fine on ultra settings though setting "partcles" to high/medium avoids stuttering on rare occasions. Do you play on a laptop? it might be that the installed RAM is low quality for gaming causing a bottleneck. Note that the ram size isn't important but the speed, if it's anything less than DDR4-2666 it should be replaced.
  5. ObiVanuKenobi

    My guess is you're running the game on integrated graphics. You should be close to if not 60 fps on ultra.
    Open Nvidia control panel and make sure Planetsidex64.exe or something like that is set to "high performance GPU".
    • Up x 1
  6. OneShadowWarrior

    Just set everything to low and start from there.
  7. Maddens


    Your cpu has a build in Intel UHD620 GPU, seems about right it should make 50fps on lowest settings and stuttering would be an effect of sharing and utilising system RAM as video RAM. But....
    If you have your monitor connected to gtx1050 and NOT to motherboard (DVI/HDMI) , this shouldn't be a case.
  8. icufos

    Specs..
    i5 4670K
    RX 480 8GB
    16GB RAM
    W7
    Logitech Lightspeed G502 mouse+software
    I run this in 1600x900 at mostly 'high'. Prefer this cos I can see other stuff onscreen as well.
    Can run it at mostly high 1920x1080 with same settings..no difference in fact possbly better.
    In lobby about 140 fps. In heavy action never goes below 50.
    I'm running at the same time 'Amazon music player and Open harware.
    Since the update it's running ridiculously smoothly. Even Hossin is without clitching when I'm flying low and shooting butt.

    I'll post some pics here on my site of the FPS for you later.
    https://thenitwitts.enjin.com/forum/m/28206608/viewforum/5250476
    I've tried to get my fellow clan members interested in this great game and have failed. They still insist on playing TF2.:eek:


    I'm totally puzzled by your problem.
    I've got a brand new pc sitting next to me I'm about to set up for this game.
    i5 9600K OC 4.7ghz
    RX 590 8GB
    32MB RAM
    W10
    So I'm a little bit freaked out by your problem.

    Your chip is faster than my i5 4670K. Especially with the OC.
    Your gpu is slower. RX 480 is 43% faster.
    My GPU rarely turns on, I mean the fans. While playing this. So despite the DX upgrading it appears to still be using the single core alot.
    Obviously you have 'shadows' disabled?
    You haven't incresed the voice channels to an infinite number? That's a joke, btw.
  9. The Crimson Overlord

    Alright, I've read some of the replies here and I'm gonna try a few things right now. I will update my drivers, GeForce Experience, and make sure Shadowplay is off. I have Shadowplay off by default but maybe it somehow turned back on, will check. Will also make sure that Planetside isn't running on the integrated.

    I will also turn off smoke effects and lower the render distance - I've been told no players or vehicles render over a certain distance anyway, 800 meters I think? Regardless, will try and see what happens.
  10. The Crimson Overlord

    Yeah, uh...Nothing. I have tried everything, updating NIVIDIA, drivers, nothing is working. I have planetside set to run on the GPU and I still can not for the life of me run this game. I'm at my wits end. I can't get anything over 40 FPS and when I enter a gunfight everything freezes and turns into a slide show. This is essentially unplayable.
    • Up x 1
  11. Delfinovic

    That's weird, what's limiting you?
    What exactly are your settings?
    • Up x 1
  12. icufos

    Nah. it's not right at all.

    My son can play PS2 on this, no problems..
    i5 2500K
    ATI 6970 2 GB
    W7
    16GB RAM
    Considerably less powerful than yours....and it's 8 years old to boot.:eek:

    Get Malwarebytes and scan...it's free.
    A friend of my son's had problems with Minecraft....no one could solve it.
    I used MB as a last resort. Turned out it was malware. I was amazed that malware could stop the game working.
    You could get into minecraft but once in it would go wacky.
    Avast didn't get it and lots others didn't either.
    Worth a shot.

    Your virus scanner? I have Avast which seems ok with PS2.
    Are your ports open for PS2? Windows and your modem?
    What sound card you got? These can **** things up more than you'd think.

    I've been where you are with others games I desperately wanted to play so I feel your pain.
    I couldn't play 'No Man's Sky' on the 6970. Turned out AMD had removed some Opengl files from their drivers. Now NMS runs on Vulcan so can run on AMD cards now.. Took me ages to suss out.
  13. Lord_Mogul

    You could also try running an older driver.
    I have issues with every version after 419.35, but only in PS2
    Window, Fullscreen, raw input onn/off, low latency mode off/on/ultra, mouse polling on 125/250/500/1000, no matter what I do, input freaks out at random. (mostly in bigger fights) Almost as if I get conc'ed for like 1/10th of a sec, with 419.35 everything is fine.
    Another driver that ran great was 375.70, but that is so old by now, that more recent games will have issues.

Share This Page