BattlEye restarts PC

Discussion in 'Bug Reports' started by then00b, Nov 9, 2019.

  1. then00b

    Reinstalled drivers, updated windows, verified ps2 through both steam and the daybreak launcher. Also seems to happen when launching Ark Survival which also uses BattlEye apparently, other games unaffected don't think I play anything else with it at the moment. Computer just immediately restarts when trying to launch either game.
  2. then00b

    Might be an issue on my end, just can't test it now at work. Though I'm curious why it's very quick to crash my pc on these two games seemingly specifically. Got a bsod while playing planetside before this issue arose.
  3. ZenzotuskeN

    It is Almost Definitely an issue with your pc, physical maintenance of it is just as important as reinstalling windows and drivers..

    Air Dust the inside of the pc, reapply thermal paste on cpu if haven't already done so within the last six months, take the PC components use contact cleaner on contacts as well if your graphics card is old you may want to take it apart dust from the inside that and reapply thermal paste aswell.

    if any of this seems new or scary u may want to watch several videos on youtube about it.
  4. then00b

    I just built this pc, been fine for about 2 weeks, I would think maybe unstable overclock but reverting everything to stock still caused the same restart issue. In any case, I restored to some a backup point and am going to just completely reinstall both games to see what happens.
  5. then00b

    Well I managed to get them working, was a curious issue with both games, neither would BSoD, just flat out restart no error message or anything, event viewer only listed it as an unexpected shut down.
    Don't see how it could be an overheating issue or anything since it was immediate if I tried to launch either game so literally no time to build up heat under any load. Been running hardware tests, no reports of issues, tried each ram stick individually in different slots before. Same error each time. Hopefully its not a recent driver or windows update or some such.
  6. SipherIOM

    I'm not sure if this is any help to you but, if you have recently updated to the latest Windows 10 insider build, then there is a compatibility issue with BattleEye. Microsoft and BattlEye will issue a fix via updates when solved soon hopefully. My PC will not update to the latest version of the insider build as Microsoft has put a hold on the update if you have BattlEye installed. Is it possible that you have updated to, or installed the latest Windows 10 insider build and have then installed BattlEye or PS2 after that? If so it could be the latest build that is causing your issue. Only thing to do is either roll back to the previous windows version or wait for a fix to be issued via update or via BattlEye update. This has happened before on a few occasions with Windows updates and BattlEye.

    When I try to update to Windows 10 insider Preview 10.0.19013.1122 (vb release), I receive a 'This PC cannot be upgraded to Windows 10' message. There is a link on this message that takes you to a microsoft page that explains the issue. Here is the link - https://support.microsoft.com/en-gb...insider-preview-builds-on-devices-with-certai

    I think this is linked to your issue. I believe the incompatibility causes the PC to reboot as it has done in the past. I have had this exact same issue a few builds back and it appears to have returned for the latest Win 10 release.
  7. then00b

    Don't use the insider program, but my desktop is having issues with an update at present, not sure it's to do with BattlEye, and my games are working again so might not be related.
    I might do a complete wipe later tonight just because that update issue is making me suspicious of some sort of corrupt file somewhere that no system scan seems to be able to pick up. Each time I try to update and restart it goes to 7% then stops, restarts, and says it failed so it's undoing the changes. Error code in the update logger is 0x80070002 or some such, can't double check now, not at home. Already tried pretty much every troubleshooting step. Not really an issue that's causing any other errors, but kind of feel like doing a clean wipe just to be certain, unless it's a known issue with the latest update KB4524570 I believe.

Share This Page