Confirmed Pet tanks break Partisan quests in EW

Discussion in 'Bug Reports' started by Ternarissa, Dec 23, 2019.

  1. Ternarissa Journeyman

    After trying a couple dozen times, at least, to do the "The Last of the Storm Boars" and bugging out, I tried doing "You Can't Go Back Home" with my toons, all of them having pets, and it appears that if you're a pet class, you're SOL with partisan quests in EW (and probably other zones, but I haven't even gotten that far) and they bug, I.E. fail to update at various points in the quest.

    There's other posts in here about the Storm Boars, but it appears to affect more than just that one. Last night after capturing the cat "Orctooth" in the bag at the orc fort, no Restless Ry`Gorr spawned to continue the quest.
  2. Crystilla Augur

    Hi. My husband and I are in your same shoes (mage and cleric with tank merc). While we have the same issue you do on The Last of the Storm Boars, we were able to complete the Orctooth quest. He clicked but no orc spawned; I clicked and it did spawn. So possibly try a non mage doing the clicking.
  3. LesserArchi New Member

    For the you can’t go back home quest, I am all per class also.
    It worked for me last night. It took me a long time to kill the orcs due random rotation spawning of undead and orcs. Finally wore me out at 6/7 kill, waiting on spawn.... but realized I have seen them spawning somewhere else also.
    Go look at the front of giant building, located NW of quest building. It finish the quest for me.

    Don’t know about the other quest, I need to try that one out soon.
  4. Absor Augur

    What makes you think that your pets are causing the problem? How could I reproduce the it?
  5. Crystilla Augur

    There's the other main thread about The Last of the Storm Boars where folks have been indicating how they've "failed" the mission. One or two indicated that once they stopped using merc tanks or pets as tanks, they were able to succeed and we finally just beat it as well following that.

    https://forums.daybreakgames.com/eq...-last-of-the-storm-boars.261559/#post-3851835


    Right or wrong, we just succeeded on attempt #10 dropping the merc tank and both necro pet and mage pet (so going petless). That first step in the task was not updating at all with more than 40-50 different people's attempts, even those step 2 would be a hidden update (we got the emote but task wouldn't update step 1 ever).
  6. Rila Journeyman

    I tried last of the storm boars many times (at least 10) and I couldn't get the first step to update when I tanked the orc with a pet. But once I dropped the pet (or at least removed pet taunt) and tanked with a player, then first step updated. On the second step, I let the pet get aggro on the second of 3 orcs and as a result the quest bugged out and I could not get the bridge step to trigger. So, I restarted and made sure to not let pet have aggro at any time. Result: completed the quest without issue. Therefore, I am quite certain pet tanking is bugging this quest out.

    Side note: Quest also seems to have problems updating when you use advloot. I haven't tested and failed this enough to say for certain, but I believe that if you use advloot to loot the quest items, you can bug the quest out too. In my successful run, I made sure to leave everything on corpse and loot manually.

    As for the other quests in EW, I used a pet tank for all of them and had no issues finishing or getting bugged out at all. Storm boars is definitely bugged though.
  7. Ternarissa Journeyman

    To reproduce the problem (for the Boar quest for example), simply take a group of pet classes (I am using 2x BST and 1X ENC and 3X healer mercs until I get comfy with replacing 1 at a time with WIZ mercs), and try to get the steps to update when you A) try to trigger the first step. I've pulled with a DoT and got that to update, and even looted the Terse Note, but then when I try to "Head to the great bridge", the orcs spawn and I loot the ring, but I never got an update to "head to the great bridge".

    Task Steps:
    • Go to the giant fort and find where the Storm Boars are 0/1 (The Eastern Wastes)
    Will update sometimes but not always. If I pull with a pet, no update. If I pull and use Playing Possum to drop adds, usually no update. I think I've gotten it to work ONCE using pet class group, but had a Ranger in group with me who pulled.
    • Find a clue about where the Storm Boars have gone 0/1 (The Eastern Wastes)
    If I kill the orc in the giant fort and loot the Terse Note, sometimes it will update, and sometimes it won't. Most of the time I get the yellow pop-up text saying it updated, but the task didn't actually update. I can use the "give it to pet and he'll return it and update" trick, but can't even get the first step to update, so pointless to kill the orc at the giant fort.
    • Head to the great bridge 0/1 (The Eastern Wastes)
    If I manage to get the first 2 steps to update miraculously, when I head to the great bridge, the 3 orcs will spawn, but the task doesn't update. Killing the orcs is pointless since you haven't completed the previous "head the the great bridge" step.
    • Defeat the undead orcs 0/1 (The Eastern Wastes)
    Killing them anyway will get you the ring, but no actual task update. I've gotten the yellow text saying it updated, but the actual task didn't update.
    • Pick up the insignia ring as it surely indicates that the Storm Boars came this way 0/1 (The Eastern Wastes)
    Same as above, loot the ring, get yellow text flash, no actual update to the task.

    • Find the lost Storm Boars somewhere near the great bridge 0/1 (The Eastern Wastes)
    I've gotten to this step ONCE, when I was in a group had a "real tank", but the group was too slow getting there and bugged. Didn't know about the reset option at the time.
    • Defeat the undead dire wolves surrounding the Storm Boars 0/1 (The Eastern Wastes)
    Got to this step ONCE, group was too slow killing and giants despawned before we got to them.

    Everything below, no clue. After trying this task at least a dozen (probably closer to 2 dozen times), I gave up until y'all fix it..... It makes no sense that pet classes get these bugs repeatedly (and I haven't even tried with a merc tank) in partisan tasks. I tried to do the "Can't go home" task with my SHM/MAG/BST combo, and that got stuck after clicking on the cat to get it into the bag, the orc never spawned for the next step.
    • Defeat the Storm Boars and gather proof that you found them 0/1 (The Eastern Wastes)More Info
    • Deliver 1 Terse Note to Yealdin 0/1 (The Eastern Wastes)More Info
    • Deliver 2 Insignia of the Storm Boar to Yealdin 0/2 (The Eastern Wastes)More Info
    • Tell Yealdin what happened to his soldiers 0/1 (The Eastern Wastes)More Info
  8. Absor Augur

    Oooh... Ok, I think I see why.
    There's no chance this gets fixed before the holiday is over tho. Sorry.
  9. Crystilla Augur

Share This Page