How I got EQ to run on Linux with Playonlinux (PoN)

Discussion in 'Player Support' started by Cone head, Nov 5, 2012.

  1. Cone head Augur

    How I got EQ to run on Linux with Playonlinux (PoN)

    System: Laptop.
    Toshiba A505-S6985
    Core 2 duo
    Video: GeForce GT 230M

    The next 3 steps are not required, I just wanted to do this form a clean Linux Install.

    Format HDD so no OS is on it.
    Install Ubuntu 12.04 64 bit LTS from USB flash drive (Or ISO from CD).
    Update Linux.

    Now for getting EQ to work on Linux. All the below are free to the public.

    Install Playonlinux (PoN)

    PoN takes a lot of the work out of installing and configuring Wine.

    Go out to Playonlinux web site and download ubuntu update.
    Open PoN again and it will prompt to install MS Fonts.
    Next will not respond for 1 min, wait to click Next and agree to ELUA.
    Next, and wait about 1 min and click next again.

    Now to install Wine from PoN.

    Tools/Manage Wine Versions.
    I installed the latest offers, 1.5.14.
    Select and click arrow to add to list.
    Prompt will come up, click next and wait.
    Close Wine list when done.

    Now to add a virtual windows drive.

    In PoN click Configure
    Click new.
    Next and highlight your wine ver and next.
    Name the drive. I called mine Games, next.
    Click Install for mono. Dot next stuff.

    Now highlight your virtual drive and click on Install packages tab.
    Install dxfullsetup.
    Install dx11

    Download the eq client from SoE

    in PoN click Install Program
    At bottom click install a non listed program and click ok.
    Click next, edit or update an existing application, next.
    Check show virtual drive, highlight Games and click next.
    Click next again, don't check any option.
    Browse to the location of the EQ Install client.
    Highlight and open.
    Accept default location.
    Don t install the DX client, we already did that.
    Wait and wait some more.
    You should now see the EQ log in screen, don't log in yet.
    Close out and you will be prompted to create short cuts.

    Highlight the Launch pad and follow the prompts, give it a name.
    You can do the same with Everquest.exe

    Two options at this point.

    Log in and patch
    or Copy the install from a windows client over.
    (I would only copy over the zone files but that's up to you)

    Once done log in.

    If you don't see your toon then do the following.
    Edit your eqclient.ini and change your VertexShader. Its either a True/False or 1/0.

    I had to change mine from True to 0

    The first two times I logged in took a bit of time, after that its going good.

    Running two accounts off the same install works just like in windows.
    But the first time you start the second client you may need to close out, wait a few sec and start it again.

    As of 11-05-2012 Running 2 accounts at the same time with out issue. Tabbing is fast.
    Updates to Linux and EQ are no issue.
  2. Mellifleur Augur

    Great Write up, I am sure alot of people were curious on how to do this. Thank you.
  3. TSR-AlexS Customer Service

    Thank you very much for sharing this info!
    Gyurika Godofwar likes this.
  4. Aliza New Member

    I'm trying to run Everquest on linux x64
    with wine 1.5.23 ( I installed with wine 1.4.1)
    and the install went flawlessly.
    So far as I can tell after having logged into the game for only a few minutes, Almost everything works..BUT there are no character models. even on the character creation screen, no models are visible. I've checked the winehq application database,faqs and forum.
    Using a patched copy of d3dx9_30.dll is the suggested fix, but I cant find the referenced code string to make the needed changes, and the patched dll download links I can find are all dead. Does anyone know how I can fix this? As you can imagine, seeing no character models totally ruins the game.
  5. Cone head Augur

    Give the above a try.

    Side note,

    A patch was pushed down that gave my wireless adapter major issues to the point of making EQ unplayable on Linux.

    I have went back to Windows but plan to go back to Linux in the next month or so.

    The patch only affected the wireless connection and not EQ it self as if I used a network cable I had no issues.

    So in the mean time I went back to windows.

    I am kicking my self for not making a back up with Clonezilla…..

    Also, you may need to add VertexShader into your ini file and set it to 1 or 0.

    Im at work and don’t have the location were to add it, maybe someone can chime in as to what portion of the ini file its at.
  6. Aliza New Member

    thanks for the response.
    I've already changed the relevant entries in the eqclient.ini file.
    I don't like to mess with it too much, but I'll try setting the vertexshader to 1 first, and then 0
    if that doesnt help, after I save a copy of the file for back-up.

    Even to play my favorite games, I cant see switching to windows, so I want to get this fixed.
  7. Aliza New Member

    Setting VertexShader to zero fixed the problem.
    Now I can see players, and Npcs.
  8. Cone head Augur

    Glad to hear that worked!
  9. eq_fan New Member

  10. takoh New Member

    I just got EQ running Mint 15 (64 bit), on my old Compaq v6120 (1.6Ghz dual core, 2 gigs of ram, GeForce 6150 go). It took a bit of finangling with the DirectX, and I had to turn off vertex shaders to see character models, but I got it going.

    The problem is that it running at like 3 seconds per frame. That's right, Seconds Per Frame, not FPS. lol

    I don't think it's a problem with my setting, though I plan to turn those down. I can't even get the menus to respond unless I spam the button and hope I hit it just as the the frame refreshes, it will eventually hit.

    Anyone have an Idea where to start looking? I'm thinking maybe my video drivers. Any other ideas?
  11. Cone head Augur


    Thanks for posting, I am interested in what you had to do with the Direct X stuff. Any chance you can provide more info on that part?

    I would like to put together a better guide then what I originally wrote but just cant find the time yet.

    As for the fps,

    Drop your screen rez down to 800 X 600 and work your way up, turn off aa and pixel shaders, drop your fps down to like 30 in the UI. Forget the short cut.

    Log out to desktop then back in after the above..

    Also, are you using just Wine, or Play On Linux as well?

    Side note, Accounts were being ban that use virtualization. Don’t know if that’s still the case or not.
  12. Nomad New Member

    Trying this process on Mint and am having a problem at the eq setup load. Says i need 8gig of space and the virtual disk size is only 2. I can't find anywhere to change the vdisk size. any help would be appreciated
  13. Nomad New Member

    NVM I solved this myself. I really am that low on space on my / dev.
  14. Nomad New Member

    Thanks for this info.
    I'm not overly technical but would be happy to answer any questions to the best of my ability.

    I got mine working under Ubuntu 13.04
    PoN 4.1.1
    Wine 1.7.2
    AMD 6300
    Radeon 7800 series
    created 2 separate PoN areas (Eq1 and Eq2) 1 is 32 bit 2 is 64 bit.

    The only thing I had to do that isn't covered in these instructions was to load Radeon's drivers rather than use the Ubuntu generic. This may have been because the 7800 series graphics accel is not fully supported by Ubuntu yet or may be a general Radeon thing. I just know that in my error log the eq install did not recognize the generic driver ubuntu was using for my card.

    If you have vid problems and a Radeon this link was all I needed to load the drivers.

    So far pretty much everything works quite sweetly.
    Entire system freezes when you copy a UI. I don't use a custom so have not tried to load a ui since I wouldn't be able to distinguish between UI problems and my system probs. Haven't really played with copying a ui as I'm quite happy to do it at a file level.

    Going from windowed to fullscreen works fine. Going back to windowed does not. This was attempted with only 1 session running at a time.
    Under 32 bit the system froze completely.
    Under 64 bit it goes back to windowed but is highly pixelated. Window is still active and I was able to /ex to end the session but screen was otherwise unuseable.

    And the most minor but also most irritating problem. There seems to be a problem with mouse tracking. If you use your mouse to move the character the mouse seems limited to approx 180 degree rotation. (i.e. turning your character or view locks at about 90 deg each way from your starting point. Letting go of right click and starting again gets you another 90 as you keep turning. This doesn't sound bad until you think of running up the towers in PoK library or trying to run through SolB.
    This problem is only on windowed. Fullscreen works just fine.

    Any thoughts on ways i might try to fix the mouse problem would be welcome.

    I am able to use both the 32 bit and 64 bit installations simultaneously and have used them to 2 box with no problems. Responses on both logins are clean, login is automatic and there didn't seem to be any impact lag wise between Login 1 and 2, as there shouldn't be given they are totally separate installs.

    Again thanks for the great instructions.
    Gyurika Godofwar likes this.
  15. Critton New Member

    This was the best info I found on the web.

    I installed Linux Mint 17 on my computer, and there were a few changes I had to make so I will post them here.

    Computer: HP Pavilion HPE h9-1120t Phoenix
    OS: Linux Mint 17 Cinnamon 64 bit
    Processer: Intel Core i7-2600
    Memory: 10 GB
    Hard drive: 3 TB
    Graphics card: Geforce GT 545 3 GB

    The nice thing about Mint 17 is that it has a software manager that will download, and update PON and Wine when requested.

    There are a number of wine versions, and I used 1.6.
    I didn't install for Mono. I am not quite sure what that was. Maybe it is auto now.
    All the rest was the same, and worked as stated.

    If you can I would make sure to copy over all your files from windows, or you will lose alot of your character data, and have alot of Hot bars and such to redo. My Windows 7 was wiped by the Linux install, but that is another issue.

    Lastly it took me a number of times to get logged in. First I got locked op in the Sever select screen a couple of times, and then in the Character Select. Then in the Character login, but finally I logged into the GL. As of now I am still in the GL, because all my Hot bars were wiped, and chat, and other windows were wild. The one thing I found out is that my right shift key does not work while logged in. (Now there is an odd one) So far everthing else is working fine
    Cone head and Gyurika Godofwar like this.

Share This Page