Hero's Journey Blocked - Cannot Complete

Discussion in 'The Veterans' Lounge' started by Arcos, Sep 1, 2017.

  1. Arcos New Member

    Bored enough waiting for new content to work on the Hero's Journey and discovered that atm it can not be completed. There is a broken task in Dragonscale Hills and like the horseshoe nail without it you can not go any further.

    Task is called "The Rescue" and it looks like it has been broken for a while. Issue tracker has it with item number 1467 at https://dgcissuetracker.com/browse/EQ-1467

    Maybe a dev seeking a break from wrestling with new content could take a look at it.

    Arcos
  2. Catty Journeyman

    While this does suck - Hero's Journey has 1,000 tasks, quests, and more to work on.

    So this specific item is probably far from the last one for most people.
  3. Qbert Augur

    Are you able to track? Perhaps you are high enough level that they simply aren't charging you when they spawn.

    Alternatively, perhaps try to shroud to a more appropriate level to do the hail to see if that does the trick?
  4. Bobbybick Augur

    I seem to recall someone saying invis and mounts break the hails in this particular task very easily.
  5. CatsPaws Augur

    This is an older quest and as some of the older ones do it works differently.
    First off you cannot use the "hail" with the "H" key - you have to /say hail in small letters.
    What does Kaerra con to you? Although you can get the task earlier you cannot complete it unless you con kindly to ladies of the light. I had to do a lot of faction work to get to that point.
    Drop invis as others have said.
    I just ran though it on an alt and worked fine.
    Yinla likes this.
  6. Arcos New Member

    Pretty certain there is a script issue -- you get all the correct emotes and responses but the mobs do not ever appear. Track says they do not exists anywhere and I can pretty much see the entire zone. Am ally faction with ladies and do not have trouble talking to her. Done without invis or mounts, even tried it shrouded to see if there was a level issue. Everything seems perfect until the mobs do not appear and task can not be finished. And as I said it is not just a problem for me -- it has been on the issue tracker for a while now.

    Arcos
  7. Questoften32 Augur

    Has anyone ever actually completed hero's journey that anyone has heard about?
  8. Qbert Augur

    I'm sure plenty of people have. I finished it years ago.
  9. Aurastrider Augur

    I did it earlier this year on 5 toons. there are suggestions on zam in comment section.
  10. roguerunner Augur

    I did it years ago
  11. CatsPaws Augur

    You mean for this quest? (Yes many and recently) or for the entire line of hero's journey achievements? (maybe 1 or 2 on my server? Never thought to ask anyone)
  12. Questoften32 Augur

    Yeah I meant all 1000 quests. No way anyone could do it while leveling, unless was perm time locked at 85.
  13. Qbert Augur

    It wasn't that hard; the hardest parts for some people were probably some of the old raid-involved quests, if they hadn't done them when they were current. For me, the "hardest" thing was drudging through all of the LDoNs.
  14. Sokki Augur

    Yes it has been completed, I know one of my guild mates who is an illusion junky has the final illusion reward. He did complete it a while ago so not sure if this is a new problem.
  15. Prathun Developer

    Verified and fixed.
    Hail type task elements bypass the NPC's normal hail dialogue, so the script on the NPC's dialogue that spawned the guards was never triggered. And due to the logic on the dialogue, it couldn't trip once you were on the 3rd task element that required killing the guards.
    Sorry for the inconvenience. This fix will go out in the September update.

Share This Page