Anchors are broken again

Discussion in 'Player Support' started by Imortus, Aug 16, 2017.

  1. Imortus New Member

    Just wanted to make the devs aware that for all of the characters on my accounts, the anchors are not working even after re-placing them several times.

    Thanks
  2. Warpeace Augur

    Why must you break them over and over?
  3. Drusi Augur

    This would be hilarious, if not for the fact that I had finally started using anchors again..:(
  4. Sissruukk Augur

    Do you just pick them up and then drop them again?
    What I normally do when mine break is pick them up, zone out of the zone they were in, fully camp out (i.e. /camp desk), then log back in, zone back into the zone I want my anchors in, and drop them again. This has usually fixed any problems I have had with broken anchors.
    Yeah, its a pita, but until they fix it, its the only fix that seems to work for me.
  5. CatsPaws Augur

    Easiest way to fix is simply pick it up, delete your plot layout files with your name, put anchor back down. Should be good. May need to throw in a zone out/in after you pick it up but that way appeared to work for 98% of the folks last few times.
  6. Sissruukk Augur

    CatsPaws,
    Would this work if my anchors are in the GGH?
  7. CatsPaws Augur

    It does not matter where your anchor is - I have done this on my free accounts which are not allowed to put anchors in guild halls and pay accounts which are allowed to put anchors there - just pick it up then delete any plot layout files with your name on them - I suggest zoning out then back in and placing it again. It seems to help if you zone into your house or guild hall or do something like that so it rebuilds that plot file. I have had primary and secondary anchors stop working even when on just the housing plot but this has worked to fix it every time. The only ones it does not appear to work for are the anchor transport spells but I think that guy wasn't deleting the plot layouts o_O
  8. Sissruukk Augur

    Interesting. The method I posted has worked for me so far, but I will give yours a try next time to see how that works. Thanks for the info.
  9. CatsPaws Augur

    Yeah I had tried the original way, to remove everything from guild hall (OMG that was a waste and it did not make sense since the anchor were disappearing on free accounts which cannot put anything in a guild hall let alone place an anchor in one) which failed and also the camping one you do which only worked for one time then next patch it broke again. The someone posted about deleting the layout files from plot screen and it has worked ok ever since.
  10. Imortus New Member

    I have never had any issues with layouts before, but I followed your advice: I picked up both my anchors and then deleted all of the layouts that were in my name and then zoned out. I came back inside the GGH and placed my anchors again, and still getting "Your transport to anchor spelled failed because no placed anchor of the required type was found." even though I am standing right next to the anchors I just placed.
  11. CatsPaws Augur

    Sorry it didn't work for you - are you a caster type who has the spells for anchor transport? but if you get a chance try putting your anchors back in inventory, zoneing out and then back into your guild hall or house, check that the new layout file is there in your name before you place the anchors back.
  12. Imortus New Member

    I have tried this a few times and the thing I am noticing is that it is not creating a new layout file for my character, even though the anchors are going down on the ground successfully. Oh and to answer your question I am a Warrior.
  13. CatsPaws Augur

    Ok try putting something else down or even click on save layout so it makes the file.
  14. Imortus New Member

    Thanks for your patience with me, I have tried this method on the 2 characters I have that are still not working with both of their anchors, to no avail. Still gives the error message about no anchor of the required type blah blah. I saved layouts and even put down a different item and it is still not working for those 2 characters, a warrior and a rogue.
  15. CatsPaws Augur

    Wish it would have worked. :( I guess the only thing to do at this point is file a petition and mention it in bug report forum above this. Did you try Sissruukk's way of logging all the way out?
  16. Imortus New Member

    Yeah I tried logging all the way out and it still doesn't work. I have a guildie who had this issue for months before someone finally fixed it for him. Hopefully he can point me in the right direction when he gets on later. Thanks again for your help today!
  17. Roxxlyy Community Relations

    Anchors breaking is a longstanding issue that the team is aware of. At this very moment, trying out the workarounds is your best option (not ideal, I know). Removing all of your items from all plots/guild halls you have items on may fix the issue for you. Another workaround is to place the anchor outside of your real estate/guild hall. Neither of these have a 100% success rate, but they're the best we've found so far.

    The good news is that we'll be replacing some parts of the system that is related to this problem in the next update - that means that you should start seeing a lot less of this happening!
    Caell likes this.
  18. Imortus New Member

    So I was able to fix this by doing the following: I picked up all my items in the GGH, inside and out, and then deleted the layout. I then zoned in and out a few times and placed just the anchors(and picked them back up if it failed) until it made the auto layout file successfully. I zoned again and I was able to use both anchors normally. Hopefully this will help the devs fix this. Thanks again for those that helped!
    Roxxlyy likes this.
  19. Niskin Augur

    Thanks for the update, I don't think we've heard much from the devs on this until now. It's just nice to hear acknowledgement of the issue sometimes.

    FYI for those with Anchor issues. When you put your anchors back down it creates a new layout. I always delete that layout immediately after placing the anchors. This seems to help it break less often. Mine used to break every patch. The other thing that really helped was putting the anchors in the yard outside the guild hall. Yes, it's annoying, but since doing that mine have only broken once. With that said, I haven't logged in since the patch so mine might be broken again like everybody else's. I'll try to check that tonight.
    Roxxlyy likes this.
  20. Yinla Augur

    Will this update also stop items in guild halls and houses vanishing on AB as soon as they are returned?
    Our Guild hall has spent more time empty this month than it has with any items in it.

Share This Page