20th Anniversary Cake Achievement - Help required

Discussion in 'The Veterans' Lounge' started by Yinla, Mar 16, 2019.

  1. Ragbert Elder

    Sadly you can't finish it without access to Empyr.
  2. treehugger Journeyman

    I bought a banner pack on 2 chars and did not get the book that way... just wanted you to know
  3. svann Augur

    Whats the reward for this epic cake walk?
  4. Sobmre Augur

    its a bit much, for no reward.......
    Yinla likes this.
  5. Diani Augur

    No book with the banners, oh and needing access to empyr suxors
  6. Lianeb Augur

    2 Large Cakes
    3 Small Cakes
    2 Hickory Bow Staves
    2 Plain Dining Plates
    1 Frosting
    Moege and Ssdar like this.
  7. Diani Augur

    And on another note... from all this cake eating my wizard got so fat she now creates an impact crater whenever she is porting somewhere
    Gyurika Godofwar and OldCa61 like this.
  8. treehugger Journeyman

    Thank you, I had this but in wrong TS thing
  9. Moege Augur

    Airdrop incoming !

    Boom goes the bossmob /nod
  10. Ngreth Thergn Developer

    oops! The rounds were not supposed to click! that's a bug!
    Or yard :)

    And...

    http://www.eqtraders.com/items/show_item.php?item=57758&menustr=035000000000
  11. Ngreth Thergn Developer

    That was a misspeak. You can get the cake in the store, or the book with instruction on that vendor.
    treehugger likes this.
  12. ~Mills~ Augur

    So no unique augment for primary slot or cool clicky from completing 20th anniversary task or completing it a specific way?
  13. smash Augur

    Any got the locations for the click?

    Tried to do the thing in PoI, but the click spot seems to be very tiny, tried around, 0,1100. which is where the allakazam thing says it is, but ....

    Any hints on getting the 100% location, i always end at 0.029 , 1100.04 or something like it.
  14. Cragzop Cranky Wizard


    A guildee just reported trying the center of the room. Alla info comes from players … which … well … sometimes are reading challenged.
  15. ottsca New Member

    Hi Folks,

    I've asked in chat and in my guild and everyone replies "just place the cake in your house" to get more slices. I try placing the cake and get an error "platinum anniversary cake cannot be dropped, traded, or sold because it is No Trade." I can place it into my closet or storage using Shift+I to open real estate inventory window. Any ideas before I bug it?

    Thanks,

    Spatters
  16. ottsca New Member

    Ahhhhhh so the problem may have been two-fold. Have to click off the auras via the aura window and not the song window (/bonk) OR the cake doesn't work in specialty houses like the Bixie Hive. I went to another plot with a standard house and it worked. Crazy.

Share This Page