Shades of Drinal: Skies of Red[COE]

Discussion in 'General Discussion' started by Balbasur, Mar 16, 2013.

  1. Balbasur Active Member


    Inorder to complete this quest one must complete the quest line given by Gulthga it starts with the quest called "Fear Itself". I am unable to get any quest from Gulthga, I believe this is because I have completed the quest line by Alzilius and have gotten the update for Yulsluu and hence unable to get any quest from Gulthga. I have checked my journal as well as completed quests the quest "Fear Itself" is not in it and has not been completed.

    Any idea when this will be adressed, and no I'm not deleting the quest due to reports in the TSR forums of it being unable to update the Yulsluu part.

  2. Gideon Member

    are you sure you did the quests leading up to gulthga? i just did this line 3 days ago start to finish on my illy and it worked.
  3. Balbasur Active Member

  4. Balbasur Active Member

    I am unable to get the quest Fear Itself
  5. Rotherian Well-Known Member

    Can you give us the conversation that passes between you and Gulthga when you hail it? It's a longshot, but maybe something in the text might give us an idea.
  6. Klops New Member

    I have the same problem.
    First time i did signature I got all quests, now doing that on alt, I dont get even first quest from Gulthga "fear itself". I did all quests for signature time line so far. I completed all quests from Yulsluu but not getting Gulthgas quests....
  7. Wingrider01 Well-Known Member

    Where you sent up to him after talking to Drinal's steward at Ashen Towers? Check your quest line in Shades of Drinal: Great and Small and make sure you did not miss anything. I literally finished on my Inquisitor Saturday morning on the line in elidon Jungle
  8. Balbasur Active Member

  9. Balbasur Active Member

    HI, I am working on Shades of Drinal:Skies of red . I have completed the assisting Yulsluu part, and am not able to get the quest lines from Gulthga. Is it possible for some one to give me the quest Fear Itself which is needed to progress the questline and get an update for Shades of Drinal: Skies of red. Thanks.

    This is GM XYZ, and I've gone ahead and added "Fear Itself" to your quest journal, so you should be able to continue your signature questline now. The reason you couldn't pick it up is due to a known issue with the quest, which should be fixed as soon as possible. I don't have an ETA on that, but please keep an eye on the official forums ( as well as the patch notes ( for further information as it becomes available.

    I'm glad I was able to give you the quest in the meantime, and I hope you have a great rest of your weekend!

    me:Thank you very much, moving the do you want a response to No, I don't need this question answered now. You may close the ticket!

    Just a fyi for those who are bugged and looked via google or w/e
  10. The_Cheeseman Well-Known Member

    I bug reported this issue a week or so ago when I ran into it on an alt. The problem appears to be the fact that Gulthga's dialogue that leads to him offering "Fear Itself" only triggers before he updates "Skies of Red", so if you break the conversation after getting the initial "find Gulthga" update, he won't talk to you anymore. You can fix it by deleting "Skies of Red" from your quest journal and re-starting it. Don't worry, you won't lose any progress from Yulsluu.

Share This Page