Repeated CTD since 12/29 maintenance, multiple PCs

Discussion in 'Players Supporting Players' started by Guurzak, Jan 2, 2020.

  1. Guurzak Active Member

    Both my and my wife's computers are repeatedly crashing out of EQ2 after 5 to 30 minutes of play with a Direct3d error. No software/OS changes on our side, no problems prior to the 29th downtime. Anyone else experiencing this, and if so are there any workarounds? Daybreak support has been useless, going through completely generic client troubleshooting like update drivers and reinstall the game, ignoring the fact that if the same problem occurs at the same time on different PCs then it's not a client-local issue. Their latest suggestion is to try running through Steam instead, as if to say that Daybreak can't adequately support their own version of the client.
    Everquest II has detected an unrecoverable error and must shutdown.

    drivepath:\eq2\framework\core\devices\DirectX9RenderDevice.cpp
    Uwkete-of-Crushbone likes this.
  2. Breanna Well-Known Member

    That sounds to me like you guys both need DirectX9 even if you have a newer version of directX EQ2 requires DirectX9 it will install and be happy with your version of directX. I forget how you go about getting it but if you search on the forums there is a zillion posts on this one of them should tell you where to get it.

    And if anyone replies I'm actually going to write it down this time so I can tell the next person LOL
  3. Ceyarrecks Wunnfirr Well-Known Member

    since having the appropriate Dx9 DLLs in the /EverQuest II/ directory are soooo helpful,... one wonders why those are not just placed there by the LaunchPad as recognized missing files,...
  4. Sigrdrifa Well-Known Member

  5. Assesino New Member

    I'm getting the same error, and the DirectX 9 Files inside the directory does not help. Our guild hall seems to be the issue. Every Character that is inside the Guild Hall crashes with the error you describe. I've submitted a ticket but they have not responded. I'm starting to get a little frustrated.
    Uwkete-of-Crushbone likes this.
  6. Sigrdrifa Well-Known Member

    Submit a new ticket and make sure that the category is "Stuck Character". They will move you to the Commonlands or Antonica, depending on alignment.

    Meanwhile, your guild should consider moving stuff away from the front door and/or reducing item count in the guild hall. When the guild hall keeps crashing like this, it's usually because it is overwhelming your memory.
    Uwkete-of-Crushbone and Breanna like this.
  7. Mazser New Member

    I'm also seeing a lot of CTDs lately. In our Guildhall, I sometimes have 4 error boxes that pop up with the same error, but moving them over to another monitor lets me keep playing. Most of the time, it's straight to desktop though.

    "EverQuest II has detected an unrecoverable error and must shutdown.

    <verify>
    G:\Live\eq2\framework\core\devices\DirectX9RenderDevice.cpp (15776):
    0
    0160de1a"
    Uwkete-of-Crushbone likes this.
  8. Uwkete-of-Crushbone Well-Known Member

    Guurzak, what sort of machines are you running? There was a time when I was still on WinXP when I didn't have a prayer in hell of getting into my own house, let alone into a "packed" guild hall...and this was way before we had the split of Building Blocks and ordinary House Items. :-/

    The DirectX9 everyone talks about is actually DirectX9.0c; make sure you get the right one. :-/

    Nowadays on Win7.0 (still!), I don't have any issues getting into even really packed places. :)

    Uwk
    Breanna and Rosyposy like this.

Share This Page