Range auto attack getting stuck

Discussion in 'Bug Reports' started by Teld, Dec 16, 2020.

  1. Teld New Member

    On my ranger when i turn on forced ranged my ranged auto attack stays on after the npc is dead. If i switch to melee it works fine.

    Quite a few issues result when your auto attack is stuck on. Even if nothing is targeted.
    Tyger likes this.
  2. Ratalthor Developer

    Is this issue happening to anybody else?
  3. Sigrdrifa EQ2 Wiki Author

    Yes. It's been a problem for forever.

    On my warlock, casting a blue AOE that one-shots everything in the vicinity causes the toon to be stuck in combat unless you directly target one of the mobs before casting that spell.

    You can hit F1 and ESC a couple of times to get out of combat, but people regularly don't pay attention, at least in a number of raids I have been in, then their [expletive deleted] autoattack "pre-pulls" the raid name before we're ready.

    It would be nice if it detected that no living things are aggro to you and took you out of combat when that was true.
    Tyger likes this.
  4. Teld New Member

    Sorry, didnt see a response.

    Still a issue and sig elaborates on it further. I didnt know what caused it, but that helps me out sig.
  5. Zylara Well-Known Member

    This has been happening for quite awhile now and doesnt matter if on forced ranged or automatic, if as you killed mob you were on ranged at the time then that a fair few times will keep you locked in ranged combat even after mob dead
  6. Bunji Developer

    I made some updates to ranged auto-attack internally to behave more closely to melee auto-attack as far as when it's on / off. Will try to get those changes to Test in the near future.

Share This Page