Hold of Rime: The Fortress Spire

Discussion in 'Zones and Population' started by ARCHIVED-Detor, Mar 12, 2011.

  1. ARCHIVED-Detor Guest

    How do you get past the arena in The Hold of Rime: The Fortress Spire? Tried talking to Sleetsaber Gnonlin, who gave us a potion to put in the mug of one of the fighters (which we did, got a red message about it fizzling in the drink as it dissolved), then we talked to Abelbrow the Bookie:
    Abelbrow the Bookie says 'Allo there! Would you like to placea wager on this next battle between the unbeaten Kreegar Krikneck and Quanth Coldblade? You never know Quanth might get lucky or sumthin...'
    Select the only option: 'I sure do! Put a platinum piece down on Quanth to win!'
    Abelbrow the Bookie says 'Excellent! The odds are 20 to 1! So at 1 platinum put in you could win... Let's see... Carry the 4...Divided by 42....18 platinum pieces! Taking into account for my fee obviously!'
    Select the only option: 'I have no interest in giving away any of my platinum.'

    That's where we got stuck. We killed all the sparring mobs down there, ran around a few times, tried talking to sleetsaber gnonlin again, nothing happened. The doors to the next room were locked, and the only mob left attackable was Krickneck who is a 4x and hit like you'd expect a 4x to hit. Where do you go from here?
  2. ARCHIVED-Linarie Guest

    We ran into a different problem.
    I think the encounter started after we wagered a plat. A script begins, which may have bugged for you, then we fought the fight just like all the other strats say, keeping them apart, keeping them close in health, killing at close to same time, yadda yadda yadda. We win! Yay!!
    Well, now the door is still locked. We can't move any further on. The dude who gave us the powder keeps telling us to go put the powder in the giant's drink. The elevator that I thought might lead us somewhere else in the central circular room which branches to both the arena and the docks isn't clickable. Whenever we go over there to try, one to two party members experience the 'explosive death out of nowhere' that a lot of folks experienced back on the ramp leading up to Theer in SF. I think we got bugged because we had to leave zone and came back to the same instance the next day. We still had our illusions and were using them but don't know if that would've had anything to do with it... Not sure what we were doing wrong unless there was a bug somewhere. Any hints?

Share This Page