[BUG] When opening the launcher, all I see now is a black screen with the DayBreak logo in the middle

Discussion in 'PlanetSide 2 Gameplay Discussion' started by rawdev, Jun 29, 2017.

  1. rawdev

    Starting today, whenever I open the launcher, I now just see a black screen with the DayBreak logo in the middle. So I'm completely unable to play since there are no buttons there to do anything.

    Any ideas on how to fix this?

    This is what I see after opening the launcher: [IMG]
  2. Demigan

    No maniacs laughing on the background? That's dissapointing...



    More seriously, I think you should try to update your assets, or perhaps reinstall the game.
  3. Liewec123

    i see that logo too (since update), and then after a moment the normal launcher pops up,
    have you tried waiting awhile? it might just be slow :)
  4. rawdev

    Is there some way to validate the files?

    I'm getting this error repeatedly in GameLauncherEngine.log file:
    2017-06-2915:52:11149876592427444296454183Window is hung (hasn't processed messages for over (5) seconds.

    That's where it is stuck at. It shows that line over and over every second (and thus, is constantly increasing the file size of GameLauncherEngine.log).
  5. Kdog559

    Illuminati!!!
  6. rawdev

    When attempting to uninstall I get this message (and so I'm unable to uninstall the game also):

    "There was a problem with the uninstall (-1)."
  7. rawdev

    I fixed this my unchecking "Run this program in compatibility mode for: Windows XP" in details for the launcher .exe. For some reason that was checked even though I did a brand new install on the launcher. Not sure why the launcher would automatically set itself into compatibility mode on my machine (Windows 10) all of the sudden (since I have about 40 days of playing time and not once before had issues with the launcher).
    • Up x 1
  8. Eternaloptimist

    On the left of the log-in screen is a spanner symbol. Click on it then from the menu run "validate game assets". Fixed a different launcher problem for me a couple of days ago.

    I also got the Eye of DBGSauron screen briefly last night but then the game launched normally (I'm running Windows 10 and loading through the Steam client)
  9. Towie

    I see it for a fraction of a second before the normal launcher window overlays it (Windows 7, o/c 2500k, SSD) - literally just flashes up then gone.

Share This Page