Voice chat not working

Discussion in 'Player Support' started by Jack the Smack, Nov 21, 2012.

  1. LordAelfryc

    What John just said here. I'm the same. It works... almost. It's just so choppy that I can't make out what anyone is saying or them understand me either. I don't think port forwarding will help here, but I could be mistaken.
  2. Leonard McCoy

    I've got the exact same issue. Sometimes voice com are working, but often they don't (can't hear anything other players are saying). I'll try to forward that VOIP port of PlanetSide 2 (UDP-5062), and see how that goes.
  3. JimDiGritz

    Ditto. Beta was perfect, very clear and reliable. Haven't heard ***anyone*** since launch. Might also explain why there are now only a handful of lightly populated Squads on a Very High Population server... why bother joining a squad if you can't talk...
  4. Rottendog

    ^This. My voice worked perfect in Beta. Ever since launch, its hit or miss if I EVER hear anyone. And usually no one can hear me.
  5. Chancellor Gowron

    This is exactly what's happening to me now. During a game session earlier it was working fine for a couple hours and then it stopped working even though i still saw my name as transmitting when i held down one of the hotkeys. After restarting the game nothing happens at all when i hold any of the voice hotkeys.

    If i run the mic test it works normally but I can't transmit.

    UPDATE: I checked to see if proximity chat would work on a character on a different server and it did.
    When i switched back to my main server it was working again.
  6. Hoki

    same problem here, testing works, says mic not set as default input
  7. Treach

    I had a couple of very frustrating days with Voice not working. I went out and bought a G35 and it pretty much broke my computer, which annoyed me a bit. the software was utter wank. In the end I took the G35 back 'cos one of the cones was broken anyway, took a new one home and did a fresh install of the headphone software, and it was still rubbish in-game. Next thing I did was to do a restore point back a couple of weeks (Win7) and that un-installed PS2!!(#$%^!) So I re-downloaded the whole game, used ZSoft uninstaller to clean my HD of Logitech software, re-istalled the game, re-installed the Logitech stuff and now it all works 100% perfect!


    I have no idea.

    I have no comprehension about computers and, as far as I can make out, they are only there to waste my valuable time.

    Great game btw....:)
  8. TehWreck

    I'm also experiencing this problem, sometimes when people talk it's fine but other times I just get silence.

    Considering this is a teamplay game it's pretty detrimental to teamplay!

    Any news on fixes?
  9. MacroKiller

    I CANNOT hear anyone talking. When i do the test, my mic is recognized but when I playback I cannot hear anything
  10. Jorticle

    Mate I've found the same thing, chat worked fine before. Now I seem to be able to chat for a brief period then it reverts to occasionally NumPad 4 working for local chat but that's it. It only happened after the Server maintenance last week. It makes it really hard to command a squad, follow a platoon or find out who needs the Platoon lead.

Share This Page