Voice Chat Broken

Discussion in 'Player Support' started by Piepants, Dec 23, 2012.

  1. Piepants

    First of all, at some point in time in the past voice chat DID work for PS2, but now it does not anymore. I did not notice when this change happened as I had just been lone wolfing it since launch, but now I would like to join an outfit and I find the voice chat is not working.

    Summary:
    • The voice chat test does not work. The little bar moves up and down as I talk, but I rarely hear myself in the playback.
    • If I do the 10 second record while checking and unchecking the 'enable voice' box, I will hear myself for brief spurts during the playback.
    • This is not a volume issue. When I hear myself doing what I said in the bullet above, I'm perfectly loud and clear. It's all or nothing.
    • This is not a microphone issue. My mic works just fine in Steam, Mumble, and every other multiplayer game I've been playing lately (Borderlands 2 mostly). It works fine in Windows tests.
    Has anybody else encountered this?
    FWIW I am using Realtek HD Audiio on my motherboard.
    • Up x 1
  2. Cedj

    It's been going on and off for me since the launch, same as the /re chat.
    Sometimes it works perfectly, sometimes voices are really distorted and annoying and sometimes it just does nothing.
  3. DailyFrankPeter

  4. Mike1973

    For me it was fixed the day before yesterday.
    But after the little update yesterday afternoon (utc time).
    Nothing anymore.
    So back to the lonewolf operations again.
  5. Disinclined

    Firstly, any outfit worth their beans will be using vent or something similar, so I wouldn't let this snafu hold you back.

    Secondly there are several threads on this, but I'm not aware of any SOE response yet.
    I have the same problem with both a USB logitech headset/mic combo, and a stand alone mic. Sound card wise I have an Asus xonar and onboard. I can flip the mic & headsets between any combination of the two and they work fine in everything outside of Planetside 2.

    I imagine they are using some 3rd party voice chat system, but however they implemented it into Planetside 2, they dun goofed good.

    Essentially if you go to voice settings and disable voice, and logout/exit the game and come back in, the recording/playback test should work. Obviously you won't be able to hear anybody else though since voice is disabled. Unfortunately when you re-enable voice the record/test feature will no longer work, and although I get my green bars like it's sending, it appears nobody can hear.

    TLDR:
    1: Join an outfit.
    2: Use vent
    3: Profit
  6. Titan6

    My issue is I cannot hear anyone talk. I see their name pop-up at the bottom and I can adjust the volume, but I cannot hear them..
  7. Ash11

    Thats exactly what happends for me.
  8. Ash11


    After much banging my head into a wall, reinstalling the audio driver works!!!!!!!!! :DDDDDDDDDDDDDDDDDDD


    i have same soundcard;

    http://download.driverscollection.c...tek_Audio_V51006235_Xp_V6016235_VistaWin7.zip

    those are the drivers for my mothercard (P8P67 PRO REV 3.1)
    i havn´t tried the realtek codecs, there was newer ones then i had, but i downloaded this driver and it fixed it.
  9. Ash11

    i´m sorry, i was wrong, im broken :(.. :(
  10. Ash11

    The Truth:
    Solution:

    From thread
    http://forums.station.sony.com/ps2/index.php?threads/bug-game-update-1-mic-problem.65682/page-5
  11. Ehsun

    I am getting the same issue, I can hear all in game sounds perfectly fine, except now when people try to talk to me in Platoon and Squad I cant hear anything. The strange thing is that I can hear proximity chat sometimes, and people can hear my voice all the time. Please reply to this forum I am seeing a number of issues related to this, I would like to know atleast that you guys are working on fixing this : )
  12. GaussianGamer

    The voice chat "tester" is broken, but the ingame voice works fine. At least for me.
  13. Quazar355

    I am also having this same issue. I'm assuming that it will be fixed in this new upcoming update. If not use Ventrilo, Mumble, or TeamSpeak 3 as Disinclined said.
  14. Shotcalla707

    Having the same issue.....the odd thing is it worked fine for my 1st week. i even subbed , i was having fun....

    This is ruining my experience