Upgraded router and modem - PS2 disconnects after 2-10 min

Discussion in 'Player Support' started by sagolsun, Jan 1, 2015.

  1. sagolsun

    Old modem/router (worked fine):
    Inventel DV4210

    New modem:

    New router:

    Connecting via cable.
    In-game ping is ~100ms, connection quality good.
    Latest firmware has been flashed on both devices.
    No other applications lose connectivity.

    I suspect a router/modem misconfiguration. All settings are currently at default. Issue only seems to occur in PS2.

    Any ideas where I should start looking for a fix?
  2. sagolsun

    Normally playing on Miller.

    Tested Connery, same results. Even though the game lost sync, I could still hear platoon chatter fine.

    Disabled modem firewall and QoS, no effect.
  3. sagolsun

    Anybody got an idea if I'll get another ban if I try to pcap this?
  4. sagolsun

    Suspected server might be choking on fragmented packets so I upped the MTU to maximum of 1492, did a ping -f -l 1464 (28 bytes for header) to verify, that's working fine, but no effect on disconnects.

    Still would like to know if SOE considers wireshark/winpcap to be a game hacking tool.
  5. sagolsun

    Time to disconnect seems to be proportional to the level of activity - it takes longer for a disconnect to happen on PTS than live.

    Still stumbling in the dark here, no idea what's causing it.
  6. sagolsun

    Solved! (kinda)

    There's a DMZ option in my router, I've set my machine IP to static, put it into the DMZ field and everything seems to work fine.
    There's probably a more elegant way to do it using forwarding. I'll try that next.
  7. Mogsy

    yes sounds like a firewall issue on your router -- you shouldn't need to open/port forward anything, but always a good idea to use reserved IP's for key devices like your game PC.

    I know the launcher uses HTTP/HTTPS (TCP 80/443), and game has been known to use UDP 20100-20199
  8. Sliced

    If DMZ works then it's the routers firewall / port forwarding.
    You will have to manually find the solution.
    Try port forwarding.
    You could also try to disable voice comms in game. Don't lower the voice, but instead disable it.
    It caused a lot of problems in the past. It may still be there.

    Voice is provided by a 3rd party. It has nothing to do with SoE. So uses a different connection, and different ports.
  9. Kirppu1

    This is the one of the biggest problems in the game, the voice is sometimes decides to give the middle-finger and disables itself which is bad