Unable to start the game

Discussion in 'Player Support' started by WS8SKILLZ, Jul 6, 2014.


    okay so I left my computer on all night downloading planetside 2 through steam

    the following morning I whent to my computer and left clicked play

    I was asked to log in to the game with my account so I did.

    after logging in the window closed without any explanation , every time I try to start up the game the same thing happens.

    Help me please
  2. Drullexx

    Same thing for me.

    Game opens, loads to 9%, crashes to desktop. No errors, no nothing.

    Running a 'validate game assets' check,

    This sucks.
  3. veselie

    Steam has an old version of planetside 2 but it should update automaticaly to the last version when you open the launchpad, it can even download the hole game again. But the best shot would be to download the game from the planetside2.com website
  4. YashaX

    Hi OP, I just went through the same issue. In the end I found on the forums that this has been an issue with the game for a while and that renaming the exe files so that your computer runs the 32 bit client fixed the issue for me. Here is the advice I followed:

    “First start planetside but DON'T press play
    Next Go to your c drive and get into the directory USER, my SOE is installed under Public. Get into the SOE directory where you can see launchpad, planetside2, planetside2_x64 and planetside2_x86.
    Rename planetside2_x64 to planetside2_x64xx
    then rename planetside2_x86 to planetside2_x64.
    Then go back and press play.

    Your game will run in 32 bit. I also have to do this every time I play because the 64 bit gives me an error. A total pain that SOE has had so many complaints and still has not fixed the problems with the 64 bit version.”

    Note: The file location will vary depending on where you installed the game.

    This is the thread I found the above fix in: https://forums.station.sony.com/ps2...run-the-game-again.184264/page-5#post-2787913

    Hope that works for you.
  5. Paulus

    It should be noted that the issue isn't if it's 32 or 64 bit, its more that Steam doesn't like PS2 and doesn't run it properly. Run the Exe file without running Steam and it's fine.
  6. drstrange2014

    Download the non steam client from the PS2 website and run that instead.

    I have tried downloading the non steam version butit still wont work whent he launcher comes up to download the files it quickly vanishes again like wtf
  8. YashaX

    Did you try the fix I wrote? It worked for me and several other people.