Unable to launch C:/Program Files/Sony Games/PlanetSide2.exe - 5: Access is denied.

Discussion in 'Player Support' started by Ranqed500, Nov 28, 2012.

  1. Ranqed500

    This error has made the SOE employees tremble at its sight for 3 days now.

    I can't get a fix for this. I've done everything they have told me to.
  2. Twist

    I tremble not. So, this error is pretty straightforward, and is telling you the Launchpad either a) doesn't have privileges to modify this file or b) something else has it locked/prevents the LaunchPad from writing to it.

    First thing to do is to make sure you have no residual Planetside copies in the background - ctrl-alt-delete, use Task Manager, find any instance of Planetside2.exe and kill it. While these are running the file can't be replaced.

    Second, if you have not already, after doing the above try running the LaunchPad once as administrator (right click the icon, select Run as Administrator). This should give it the ability to write to the file if it's a permission problem.

    If neither of those work, there is something locking the file, and overwhelmingly what we find is that is either Antivirus or Malware/Firewall software. If you are running any, fully exit it as a test, then try running as Administrator again. If it works, then you need to exempt Planetside2.exe from your AV software monitoring.

    If none of that works, try deleting Planetside2.exe yourself - this is safe to do as the LaunchPad will just replace it the next time you run. If that doesn't work you can't blame us any more! =) But we'll still see what we can do if you describe the error you get.
  3. Ranqed500

    None of this worked. All my defenses are down.
    WHAT DO?
  4. Twist

    And what happened when you deleted Planetside2.exe yourself, then ran the Launchpad as administrator?
  5. Ranqed500

    Same thing.
    I click Play and BAM
    Unable to launch C:/Program Files/Sony Games/PlanetSide2.exe - 5: Access is denied.
  6. Unidus

    Why does it seem like most of the people with this problem have moved the game folder from the default location. INstalling it into users/public avoids any permission issues. Have you ever had it installed in users/public/sony online entertainment/installed games/planetside 2? Copy or install it in the public folder.
  7. Twist

    So you were able to delete the file, with no errors?

    At this point the only thing left to try is moving your Planetside 2 install. I know you say you have turned off your AV software, but the behavior you describe is exactly what happens when AV software locks/quarantines an app. So, open \Program Files\Sony Games, and just move the entire Planetside 2 directory to either C:\Planetside2 or \Users\Public\Planetside2 if you prefer. The game supports moving the directory around just fine, after you've done that, open the directory up and run Launchpad.exe directly from that folder.

    If this works you can right click on the icon on your desktop and update the entries there for the new folder location.
  8. Unidus

    I beat you to it Twist :p
  9. Ranqed500

    It was in C:\Planetside2 or \Users\Public\Planetside.

    I reinstalled the Game into Programs in hope of it making a difference, but it did nothing.
    I have turned off every single firewall/anti-virus.

    There is nothing left.
  10. Twist

    Then you should ZIP up the contents of <planetside 2>\LaunchPad.Libs\Logs and post it somewhere I can get to it, or open a customer support ticket with it. If you have truly tried multiple locations including in \Users\Public, the logs might tell us what is interfering with the LaunchPad. All I can tell you is there is no rocket science in this step, the LaunchPad is grabbing a file from a web server, and writing it to your disk. And it's being told by Windows "you can't write there".
  11. LameFox

    I had something like this happen with a game once because when I got my computer from Alienware the default permission settings said that I (my account) did not own my hard drives. After a brief battle I managed to defeat the permission settings and reclaim them, and then everything magically began to work as normal.
  12. Ranqed500


    I've uploaded my Logs there. See if you can find anything.
  13. Twist

    SetGameInstallDirectory - path=C:/Planetside 2/PlanetSide 2

    This is likely to be your problem. Is that actually the directory in which the game is installed? It's perfectly valid if so, but seems more like the Launchpad is being pointed to the wrong directory.
  14. Ranqed500

    Yes that is where I just moved it.
  15. Ranqed500

    This game is a complete cluster. It is making me so frustrated to the point that my ***** is starting to tingle with fury.
  16. Twist

    What happens when you run Planetside2.exe directly, from that new directory? It should flash a splash screen very briefly and then exit.
  17. Ranqed500

    It says windows cannot access the specified device,path or file. You may not have the proper permissions to access the item.

    I have full administrative permissions on all users.
  18. Ranqed500

    It only works when I run it through the launchpad.
  19. Twist

    I understand that. I'm trying to diagnose the condition, so I need to understand if you can execute Planetside2.exe directly, even though that won't work. It should show no error, run and show a splash screen for just a second, then exit.

    The logs indicate the LaunchPad is just asking Windows to run this file, and immediately get back the Windows error condition there is no access to that file. By any chance is your local computer time set to the something unusual, for instance in the past?
  20. Ranqed500

    No, my computer time is where it should be.

Share This Page