Telstra 3G Broadband users with Router Model 3G21WB

Discussion in 'Player Support' started by Veratu, Nov 24, 2012.

  1. bieltanman

    well maby its something to do with aus 3g network
  2. Rockit

    Sounds like a similar issue with other routers where they have to turn off in-game voice chat and it allows people to play. Anyone try that?
  3. Zulsoke

    Tried that and to no avail.
  4. Rockit

    If you have UDP flood protection or an option similar to that in your router you may need to turn that off. Since PS2 streams UDP packets constantly to the same external host I have seen some routers interpret this as a DOS (denial of service) attack. So you've updated firmware and turned off voice chat, this is the last option I can think of. Also the game runs around 100K up and down but that is without in game voice, don't know what your speed limit it on that 3G connection but it may be an issue (the upload side in particular is usually the limiting factor). I believe though that the ingame voice uses a different server than the game. In fact, I think that Vivox service is hosted here in the US, globally. Not sure about that but maybe something SOE can look into.
  5. Diablo Vash

    I've tried it all, kinda at the breaking point..
  6. Veratu SOE

    Voice chat is indeed in a different location, and a completely different stream and data set when it comes to packets. PS2 uses a constant UDP stream.

    The game hasn't changed since beta with regard to this. This same kind of UDP stream is used for login as well, it's the same network function routine being called. You all can login just fine, but once in the game it fails.

    We've collected packet captures from some of the affected parties and are digging into them. The packets are making it to the users machine through this router. However in one sample the packets are corrupted/damaged, in another they are fine (which would imply the user has a software application blocking them on their machine, ie: Firewall/Anti-Virus or something else). This is why we wanted everyone to make sure they are using the latest firmware so we have a common ground of data samples

    The manufacturer of the device finally got back to me about an hour ago, and this is what they suggested trying for all of you:

    Go to Advanced Settings -> NAT -> Port Triggering

    Ensure that all of the game ports are open. UDP 20100 to 20199 are used for the game servers.

    The amount of people affected is very small, and we have over a dozen reports, and every single one is using this particular router, that's the only common thing between them all.

    Now, can any of you using this device check the following: Does the router have any kind of date/time setting in it? If so, please make sure that date/time setting is accurate, and then re-test.
  7. PancakeTransmission

    I have tested both these settings to no avail.

    For port triggering (I also enabled forwarding for the same ports), I set the Trigger to also be UDP 20100-20199. (So the trigger/open are both set the same)
    My router's time setting was indeed incorrect (wrong time zone set) but this did not fix the problem.

    You don't even need to wait 2 minutes. As soon as I log in, I try throwing grenades (it will let me throw unlimited but none will explode) or using the consoles (which won't work at all)
  8. Veratu SOE

    PancakeTransmisison, please check your PMs. Thanks
  9. Zulsoke

    Yeah, Due to whatever reason (Not receiving/sending packets properly) It basically has you phased out of the game (Invalid character name, infiinite grenades and no ability to interact with vehicles, consoles, deployment options etc.
  10. Hojirozame

    So were people actually able to successfully play PS2 during beta with this router? The 3g21WB is generally quite bad for online gaming so it came as no surprise to me that I had trouble playing.

    But yeah, I have the same issues as everyone else. Updated firmware, tried port forwarding/triggering, checked firewall/antivirus etc to no avail. As Pancake said, it may disconnect after 2 minutes, but from the get go you really can't do anything. When you try to pod into a location, you pretty much hit the ground but remain inside the pod.
  11. bieltanman

    yer it worked in the beta somehow they stuffed it up
  12. inna

    99% sure it's the Netgear CG3000 but I'll confirm with my housemate when she's home (only recently moved here).

    Damn I want to play this game.
  13. Rockit

    I believe this is one mentioned that requires the in-game voice chat to be turned off.
  14. Tassy

    well me and my big mouth about not having probs ...nothing but probs toaday with game
  15. Veratu SOE

    I'm continuing to work through this one personally. Pancake, please check your pms.

    I've got a meeting scheduled tomorrow with the network coders to review code changes since beta to ensure nothing on our end has changed.

    I'll keep you guys posted when I know more. We'll figure it out.
  16. Baelfour

    I appreciate both your and SOE's perseverance in this matter. I have sent you a PM with the settings I have tested, hopefully they will help in your meeting.
  17. Hojirozame

    Thank you for at least looking into this. Speaks volumes about the quality of service considering only a small faction of us are actually experiencing this problem, much appreciated!
  18. Veratu SOE

    Those of you with this device, if you have access to a computer that has a WiFi card (A laptop for example), would you do me a favor and attempt to play the game over the WiFi instead of the ethernet port on the device. (I know this sounds ridiculous) but I have one user who claims he is using this router no problem, but he plays over WiFi and all of you are playing over the ethernet ports.

    If it works over WiFi, there could be something going on with the internal switching logic of the device and that will give us more information to put this issue to bed.

    We're not ruling out anything at this point, but the more data we have the better we can work through it, and with the manufacturer.

    Thanks much
  19. Kemofarfar

    I don't know if my router is one of these, all i know is that i can stay online for about 20min, and then it like freezes, and tells me .exe is not responding. I really wanna play, so i hope that we can somehow get a solution, cause this is really ripping me apart, because i wanna play with all my friends and so. I guess you already know that, because quite many suffer by this issue. Anyways, please contact me, because i want some help! Thanks!
  20. LordCharlamane

    Telstra bloody Telstra. Bloody incompetant bunch of losers. Good luck getting anything done or fixed and you'll be overcharged for it too.

    My gawd. Never use Telstra. Ever.

Share This Page