Steam overlay ain't working, Steam or SOE problem?

Discussion in 'Player Support' started by WildCatNL, Nov 20, 2012.

  1. Supermop2000

    Ok, dont listen to me. Disabling UAC does not fix it. Noticed that when I launch PS2 from Steam, as soon as the launcher updater finishes updating and loads the launcher, Steam then thinks I've stopped playing, and the overlay doesnt work.

    This seems to be directly related to the launcher updater.

    Didnt happen in Beta, as there was no launcher updater.
  2. Doozie

    The people above who said to elevate steam to RUN AS ADMINISTRATOR had the right idea. As soon as I elevated it (and also PS2 launcher for good measure) the overlay is now working for me.

    Thanks!!! =D
    • Up x 2
  3. WolfStar76

    Glad that works as a workaround, but I'm hoping they'll fix the rights elevation without me having to brute force like that. :/
  4. InHumanTurtle

    Yeah, I would definately like to see this fixed properly.
  5. AcidBee

    This definitely appears to be an issue with the LaunchPad.exe's manifest not clearing something with UAC. I don't like elevating processes because I have to elevate EVERYTHING I need (mouse driver, teamspeak, etc.) and I don't like turning off UAC because it turns off file and registry virtualization. (Also I test some of the applications I develop on this Windows machine and they must pass UAC scrutiny)

    There is another workaround if you want to go through the effort. Augment the manifest until the team fixes it:

    1. Download and install the Microsoft Application Compatibility Toolkit (MS ACT).
    2. Run the 32-bit version.
    3. Select the "New Database" line from the tree on the left and press the big "Fix" button at the top.
    4. Fill out the first two line in the form and then, for the third line, browse to and select the LaunchPad.exe file from the Planetside 2 install directory. - For Steam, this is <Steam Install Directory>\steamapps\common\Planetside 2
    5. Hit "Next"
    6. On Compatibility Modes, select "RunAsInvoker" then hit "Next".
    7. On Compatibility Fixes, select "ForceAdminAccess", then hit "Next".
    8. On Matching Information, unselect things that will change with updates (like file size, version, and CRC).
    9. Hit "Finish".
    10. Press the "Save" button to save your configs. (You can load up and add to this file later if you have other fixes you need to add)
    11. Right-Click your newly named database in the tree on the left and select "Install". If all goes well, it should now show up under the "Installed Databases" tree item on the left.
    12. Run Planetside 2 from Steam, you should no longer get a UAC prompt.
  6. WildCatNL

    Running steam with elevated rights does indeed solve the problem, that ain't a fix for me its an unsafe workaround.
    I'm not running steam or any game for that matter with elevated rights.
  7. TSR-JoshuaM Customer Service

    Without running it with elevated rights, it wont even have permission to use system services or write to it's own folders in many situations.

    It is not a workaround, running as an admin is a required step with how UAC and Windows accounts work with Windows Vista, 7, and 8. You either have UAC enabled and are automatically prompted to elevate, or you have it disabled and have to elevate manually.
  8. WildCatNL

    I know what the elevated rights give access to.
    Beta didn't have need for this, nor did it prompt for elevated rights, the game ran perfectly fine, with the only exception you had to manually add planetside as a non-steam game in order to get the overlay.
    • Up x 1
  9. WildCatNL

    Just pulled in a 40MB patch and currently the launchpad that get started through steam no longer prompt UAC to grant elevated rights.
    The elevated rights flag on the execute seems to have been removed.

    Keeping my fingers crossed it stay's like this.
  10. Twist

    We believe we've addressed this, please mention in this thread if you still encounter it *after* this post was made.
    • Up x 1
  11. slogga

    Still encountering the same issue. Running Steam and Planetside 2/Launch Pad in Administrator mode did not give me the Steam overlay. I still only get the overlay if I enable UAC, and click NO on the prompt after running Planetside 2.

    Running Windows 8, x64 bit.
  12. Proxus

    Still encountering this issue as well, Win 8 x64
  13. WolfStar76

    Problem resolved for me.
  14. dawo5010

    I've been troubleshooting this issue for a bit and have been lucky to have found this thread. The problems with UAC are happening on my system as well, and I'm having to run Steam with administrator rights in order for it to work, even up to today. I've reinstalled Steam (and all my games) as well as checked if my Mumble overlay was the issue, when Running as admin was the solution. I'm on Windows 7 64-bit with UAC disabled.
  15. MrTwizzpops

    Sounds like the same issue I had with a few games on steam....Especially older ones.

    To fix it I disabled UAC and everything worked perfect after that! :)
  16. Amitabha

    If any of you followed some tweaking guides and did this following "Go to planetside2.exe , right click,properties, compatibility and 'ticked' disable desktop composition. Then you will lose the steam overlay. Also you will then not be able to use the steam wallet because the game and steam cannot interact anymore.

    So do not 'tick' disable desktop composition, if you want higher frames per second just disable aero from your desktop.

    Somehow the image is not working
  17. Mansen

    The aforenoted fix is not possible in Widnows 8 by the way. You cannot disable desktop composition. (It's a design choice, not a bug on Microsoft's side)
  18. Amitabha

    Yeah sorry I should have mentioned this was for windows 7.

    Also, people should not disable desktop composition anyways because that was in my case the cause of not being able to have the steam overlay in game.
  19. Enchman

    For me TS3 Overlay was killing Steam Overlay. Disabling TS3 Overlay fixed it for me.
  20. Salads

    Posting here a little late, but the Steam Overlay has been... erratic for me. Sometimes it works, but others it doesn't. I don't really see a clear pattern to it either. I am running with administrator privileges on a Win 7 x64 computer (I'm the only account on it). I've PM'd my dxdiag info

Share This Page