[Solved] Error 0xC000007B

Discussion in 'Player Support' started by Kafein, Aug 30, 2014.

  1. Kafein

    So I ran into this (major) issue: everytime I tried start the x64 client it would refuse to start due to error 0xC000007B. For a long while I played via the x86 executable using the swapping method, but with the latest patch the x86 client does not work anymore hence I had to fix this problem. I'm leaving this here in case someone stumbles across this problem, and also as a message to the dev team that perhaps something is wrong with the dependencies.

    Read the fix below

    It turns out that 0xC000007B can mean that there are missing or corrupted DLL files. I used the windows dependency walker: http://www.dependencywalker.com/ to find out which files were problematic for me. As it stands the game was looking for d3dx9_43.dll and could not find it. d3dx9_43 stands for DirectX 9, revision 43. The strange part is that I had checked for DirectX updates a million times before looking at exactly what I needed, and another update could not fix the problem. So I downloaded the end user runtimes http://www.microsoft.com/en-us/download/details.aspx?id=8109 (that's NOT the web installer) and searched for the exact revision I wanted (43). I extracted d3dx9_43.dll from the downloaded archive and copied it in my PS2 directory. It works now!

    Note that all 0xC000007B errors aren't the same, and you should use the dependency walker to troubleshoot them.