Discussion in 'Test Server: Discussion' started by codeForge, Nov 5, 2013.

  1. codeForge

    Please re-enable SLI/crossFire and let us know if you're having any issues. We believe we've fixed most, but not all, of the SLI issues out there. We may still be waiting on some fixes from nVidia, AMD, and perhaps a bug or two of our own, but getting more bodies in there to let us know how it's doing would be great.

    Thanks guys,

    • Up x 3
  2. SurgeonX

    Well it's definitely made a massive load of difference for me, in terms of raw frame rate at least.
    It feels a lot more stuttery though, and I think this is because the FPS is spiking a lot now.
    It can spike anywhere from around 150 FPS, or higher, down to 50 as you are running around, and in particular, turning/spinning.

    I have tried turning Smoothing on, and overall it was makes everything a lot smoother. Funny that ;)
    But I turned it back off as I haven't had it turned on previously, and I wanted the comparisons to be the same.

    I've got two sets of data from the Crown, one from today, the 5th and one from the 25th of October.
    Essentially giving two decent comparisons of before and after the SLI/Crossfire fix.

    Previously, I was getting the following on Indar at The Crown:

    Average - 47
    Maximum -94
    Minimum - 10

    Now, in the same location, I'm getting:

    Average - 118
    Maximum - 234
    Minimum - 37

    I'm going to test out Smoothing and V-Sync next, and see if they help improve the overall experience.

    I've got my data here if it helps:

    • Up x 1
  3. Zor

    Running a 6990 ATI on the PS2 test server. (single pcb gfx card, dual gpu embedded)
    16gb ram
    4ghz oc'd i5 intel
    Ingame = Ultra settings
    With Crossfire on:
    If I enable "fog shadows" in the graphics options, I lose a massive amount of fps. Over 50% frame rate loss. Drops it down to 20 frames. With very laggy mouse to screen movement.

    With fog shadows off: fps is 30 - 100.

    With Crossfire off:
    Much smoother mouse input, and I can also enable fog shadows without suffering a huge fps drop. Average about 40-50 fps.

    Please, bust a gut to fix Crossfire and SLI. We need these engine problems fixed for Everquest NEXT and Planetside 2.

    BOOOO HOOOO!!! :(:(:(
  4. codeForge

    Please try smoothing as well. Remember you will see LOWER frame rates with smoothing on, mostly, but it should "smooth" out the frame rate and "feel better".

    We'll be improving the effect of smoothing for PU02 as well, so we really need that feedback to continue.

    Oh and thanks for all this so far, good stuff!
  5. Serpent808


    i7 4960x @ 4.4 GHz (No Cores are parked).
    65.5 GB Ram @ 2133 Mhz (1066.6 Mhz).
    2x MSI RX9-290x in CrossfireX @ 1000 Mhz Core, 1250 Mhz Mem.
    AMD Catalyst Beta Driver 13.11 v8.0

    Settings in Catalyst:
    Only AFR-Friendly and MLAA Enabled.

    Settings in the PS2-PTS:
    High (only motion blur disabled).
    6000 m rendering distance.
    70 field of view.
    V-Sync Disabled.

    MSI Afterburner On Screen Display: Enabled.

    Without Smoothing:
    1. At Warp Gate, Ranges from 154 to 225 FPS.
    2. Flying (no other players in the area): 100 to 200 FPS roughly.
    3. @ Crossroads Watchtower (48 + versus 48 + TR and VS; 3 Mosi, 3 Sunderers, Prowlers): 50 to 100 FPS.

    With Smoothing:
    1. At Warp Gate: 60 FPS.
    2. Flying (no other players in the area): 55 to 60 fps.

    Zero Mouse input Lag in both cases.
    No Unusual Graphic Glitches, corruption, or anomalies.
  6. Wasdie

    I just logged into the PTS, took a mossy from the TR wargate to Alltum Biolab, running at 1080p at all ultra/high settings and render 100%. 2x GTX 570s in SLI. Something isn't working properly. I played a total of about 2 minutes. Framerate at the warpgate was locked at 60 (I have smoothing on) but often nosedived while moving around. Fell to the 40s just by walking around and looking around. Throughout the flight to the biolab I encountered no players but my FPS stayed under 60 the whole time. At the biolab there was a good sized battle going on. I kept getting CPU locked (i7 3770k @ 4.2 ghz) and my framerate was bouncing down to the 30s constantly.

    I checked MSI afterburner and found out that my GPUs never really went past 50% useage.


    Should add I'm running Nvidia's latest beta drivers on Windows 7 64bit.
  7. S7rudL

    The game seems to perma freeze if I use SLI enabled & SLI Rendering mode: Single GPU.

    Fog shadows on Ultra option seems to punish the SLI badly.

    SLI seems to have higher stuttering than SLI disabled, maybe its the source of hitching/stuttering.
    On the other hand, the SLI was always somewhat troublesome and by now I sort of a regret of buying an SLI setup.

    No Vsync, Nvidia Inspector limit frame 58, Smoothing 58, Max fps=58


    I messed up the last Ultra settings capture FRAPS so it only came out as 2min but the results would be similar to the low settings anyway. :(

    What you see above is that with SLI disabled the frame render times are much more solid resulting in less micro stuttering/stuttering/possible hitching or what ever.
  8. Serpent808

    Updating this.

    --At the Warp-gate, I was getting around 56 to 60 FPS with roughly 10 to 15 ppl in the area.
    --At Alltium Bio Lab, where the Devs were at--I think I lasher-killed Higs there aka HigbyPLS, I was getting 45 to 60 FPS with 48 to 48+ NC Vs VS. Smooth game play, smooth frame rates.

    I believe the GPU Loads at the time were 98% / 100%.
  9. SkattoNollFem

    I just went on now this morning and for me it has improved alot when using SLI. Last night it was a bit better as well, but not like this morning. The fps seems to stay closer togeather, not like before when it went from 20-80. I get the best result while using smoothing, wihtout it its a bit more choppy now and then. I still havnt had a chance to try it out in a big fight yet though.

    I do get better fps and a smoother game on the live server, but the test server has improved alot for me now while using SLI.

    The settings I use are: All high, with textures on ultra, no motion blur, max render distance.

    My specs are as follows:
    windows 8 64 bit
    8 GB ram
    GT 750M 2 GB GDDR5 x2
  10. Rogue1138

    Xfire has been working better on PTS for me for a while. Just tried it again this morning and I see 99% usage on one GPU and up to 70% usage on the second. 200 FPS in the warpgate and 100+ out running around at the Crown. Of course no one is on now so no big battle to check it on at he moment. Gameplay has been smooth and much improved for me though for a while on test. I don't use smoothing it makes everything really choppy for me. I keep everything on ultra.

    Set up
    i7 3770k @ 4.5
    16GB 1866mhz Ram
    256GB SSDs in RAID 0
    2 7970's in Xfire 13.11 beta V8 (I also enable AFR in my Xfire profile, helps a alot)
    I have 3 screens but am forced to play at 1920 x 1080 due to low FOV (please fix this and you can have all my money!) :)

    Keep up the good work!
  11. VanuZuma

    So I had been having really strange hangs while using SLI in PTS, but with the latest small patch it seems to have remedied most of the issues. Its definitely not prefect but its way more playable now. Before I was getting freezes and fps drop about every 30 seconds, and now that pretty much seems to be gone entirely. I will say its can get quite choppy at times even when it says im getting 75 FPS (my refresh rate 75hz) it will feel like im getting far less and not be smooth. I have not tried using the smoothing feature so that may make a big difference, but the SLI scaling seems to be working really well utilizing both of the cards at about 70%. There is one really strange thing happening that I dont understand. I force vsync in the nividia control panel, but the in game fps counter will say that im hitting upwards of 90fps when it should be capped at 75. Not sure how this is possible or if I should just ignore it, just find that weird. I run Live and PTS with this modified INI ive pasted below, also dont know how that could be effecting it. But hey keep up the optimization SOE, seems like everything is on the right track.


  12. Vandali

    Without smoothing xfire is extremely stuttery, with smoothing fps is at 60fps and smooth, but no benefit over a single card that i've noticed.

    asus p8z68-v pro/gen3
    2x 6850
  13. SniperCzar

    Quick impressions.

    SLI on, no smoothing - Much improved. 100+ FPS in WG with every setting maxed out and resolution at 2560x1440. Still some mild stutter, tested by sprinting back and forth, and repeatedly diving into a gravlift to see the character motions. The quick and dirty test for me - hand motions will be very clearly smooth or very obviously choppy.

    SLI on, smoothing on (40min 90max) - Butter smooth. GPU loads are always within 2% of each other, well within the margin of error for the dynamic turbo clocks on the cards.


    After spawning into a reaver and flying around I started having fairly serious frame dips as low as 1/3 my previous framerate, thought it was just textures loading in but my GPU usage was bouncing from 90/60 to 60/90 and all around having a very hard time load balancing. Not sure if smoothing might be compounding the issue. Upon suiciding the reaver, my post-respawn framerate started to become very choppy as well and was typically a 12-15% difference in GPU load between the two cards. Retested once, first life after joining is perfectly smooth, after my first death again I started to have serious issues with low framerate and poor balancing.

    Once you get that bit worked out (I know there were similar issues on live for a time) I'm going to be extremely pleased with the fantastic framerate.

    Full rig specs for reference (summary tab) -
  14. Badmagic362

    4th Generation Intel Core i7-4700MQ Processor (2.40GHz 1600MHz 6MB)
    Windows 8.1 64
    NVIDIA GeForce GT750M GDDR5 2GB x 2 (SLI)
    16.0GB PC3-12800 DDR3L SDRAM 1600 MHz

    1920 x 1080
    74 FoV
    High Settings, Medium Flora and Particles, Low Shadows
    Motions Blur On

    I am getting High Fraterate but the gameplay is very choppy. I have tried smoothing with helps a little but even with it on the gameplay isn't playable because it's not smooth or fluid at all. FPS says I'm getting 40-60 but it's hitching constantly.
  15. Serpent808

    Did you change the Max Cap for Smoothing in your ini file? It's capped max at 60 FPS. How did you get 90 Max with smoothing on, without changing the ini file?
  16. SniperCzar

    I was only using about 60-75% of my cards at the default smoothing options.
    I have a 1440p 120hz IPS monitor... so I edited the INI to run my cards about as hard as I want to in smaller fights (at least during testing) Didn't see any additional issues from running at higher fps with the smoothing option on.

    P.S. Nice cans... Beyerdynamics FTW! (770 pros here)
    • Up x 1
  17. codeForge

    Oh HUGE note on SLI!!! Do NOT force AFR 1 or 2 for these tests. Set it to defaults and let the driver do the work. We worked closely with nVidia to optimize the driver to run SLI a certain way (50 page explanation another day) and if you override that with AFR1 or AFR2 you will almost DEFINITELY get worse performance.

    Set it to defaults and test again, please. Hope that fixes you. And yes, SLI can be a bit of a pain, but they don't call it bleeding edge for nothing. =)
  18. UnrealGaz

    edited new drivers fixedthis issue
  19. Rogue1138

    THis only pertains to SLI and not Xfire? Right? Because Xfire works way better with AFR on.
  20. Serpent808

    Thank you!


    This only pertains to NVidia users. It's not AMD users. We only have AFR-Friendly and Optimized 1x1 AFR. :cool: