Planetside2.exe has stopped working

Discussion in 'Player Support' started by AngelSnypz, Nov 21, 2012.

  1. AngelSnypz

    Just as the title says. run the launcher fine. all files validate fine. as soon as i click play is launches then loads to around 48% then freezes and gives me "Planetside2.exe has stopped working"

    Im running Win 8 Pro 64bit, a Radeon 7690m XT gpu and a I7-2670Qm Cpu. so the game is well withing my withsystem specs to run. funny thing is that it ran perfect with the beta. and the full release is giving me more problems than the beta did?

    Any fixes? i have replaced the dxinput8.dll which aparently fixes win 8 problems but to to avail. i also have no controllers or anything plugged in except my Razer Mamba mouse.

  2. CalamityXI

    I am having a similar problem where as soon as I push play it pops up with "Planetside2.exe has stopped working". I'm running Windows 8 and have a Nvidia GTX 660m and an Intel i7-3610QM. I also installed it via steam if it matters. I had a controller plugged in and am currently re-installing it so as soon as it's done I'll see if not having it plugged in helps.
  3. Kober

    I'm having the same problem (press play, the splash screen pop up, and then "Planetside 2 has stopped working").
    No error code, not a single clue to what might be wrong.
    Tried to unplug my second monitor, install the latest nVidia beta drivers, run the exec in compatibility mode... Nothing.

    I'm using Windows 8 and running the game from Steam, if it is relevant.
  4. Redd

    Same issue, i7, Nvidia card, Windows 8. Not using steam.
  5. _Killasauras-rex

    Bump. Just a question what antivirus do you all have?

    I also played the beta. completely removed everything from my computer and re-installed the game. Still getting this error after re-installing 3 times.
  6. Codipherus

  7. Weirdo801

    Add another player with this issue. The funny thing is the very first time i played the game after installing it through steam it worked. Now i'm getting what you all are getting...

    Windows 8 Pro 64-bit
    Core i7 2600k
    8 GB RAM
    Nvidia GTX 660
  8. Sliph

    same issue still cant play
  9. AngelSnypz

    ive just got the default windows defender that comes packaged with win 8 (which in all reality is just Microsoft security essentials renamed) and i have added all the files needed to the exceptions in my AV and Firewall and still nothing. just got off live chat with a SOE techy and i was told that a clean install will fix my problem. currently downloading/reinstalling to see if that will fix the issue. However i see some of you have had no luck with that either. Wish there was a simple solution that wasn't just "Reinstall the game" and waste all your internet.
  10. Mike Hammer

    So I'm not the only one at least. I just installed the game from Steam, so need to "do a clean install" of the game. That's just Tier 1 support speak for "we tell everyone to try this so we can have time to we find the real answer."

    Looking at the Event logs I see this:
    Faulting application name: PlanetSide2.exe, version:, time stamp: 0x50ad1cd4
    Faulting module name: DINPUT8.dll, version: 6.2.9200.16384, time stamp: 0x5010a805
    Exception code: 0xc0000005
    Fault offset: 0x0000ff7f
    Faulting process id: 0x1ad8
    Faulting application start time: 0x01cdc87c8c69d71e
    Faulting application path: D:\games\Steam\steamapps\common\PlanetSide 2\PlanetSide2.exe
    Faulting module path: C:\Windows\SYSTEM32\DINPUT8.dll
    Report Id: cb2af2d3-346f-11e2-be6c-74f06de14928
    Faulting package full name:
    Faulting package-relative application ID: 
    Looks like they aren't working with DirectInput somehow.

    Sounds like we are all running Windows 8. I'm guessing they didn't spend a lot of time testing on the current Windows OS.

    If more information would be helpful, let me know.

    BTW, this was a clean install of Windows 8 Pro 64 bit, with the latest signed drivers.
  11. AngelSnypz

    huh thats funny, according to Tech Support they fixed the DINPUT8.dll problem with win 8. do you have a controller or anything plugged in? that causes a few problems with win 8 and Planetside 2. however i checked my Event Viewer and it told me the Fault Module was Planetside2.exe. Which is actually kind of worrying seeing the exe is throwing the errors and not some other process/dll in my case at least.
    • Up x 1
  12. Isindel

    Same error message. However, I get this error after a "disconnect" inside the game about 10minutes after playing- Aussie server.

    Problem signature:
    Problem Event Name: BEX
    Application Name: PlanetSide2.exe
    Application Version:
    Application Timestamp: 50ad1cd4
    Fault Module Name: StackHash_0a9e
    Fault Module Version:
    Fault Module Timestamp: 00000000
    Exception Offset: 7fffffff
    Exception Code: c0000005
    Exception Data: 00000008
    OS Version: 6.1.7601.
    Locale ID: 1033
    Additional Information 1: 0a9e
    Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
    Additional Information 3: 0a9e
    Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

    Windows 7 SP1
    Nvidia GTX 480
    8 GB Ram
    i7 930 @ 2.8GHZ
  13. Kober

    Made a clean reinstallation, without Steam, and i still have the same error.
    Don't know what else i could do.
  14. Akibo

    Same issue. GTX 580, 8 gigs of RAM, AMD Phenom II X4 965, Windows 8 64 bit. I'm running it off of Steam.
  15. Redd

    Apparrently Mumble can cause planetside to crash upon attempting to launch the game with mumble open. This probably has something to do with overlays and issues with windows 8. Workaround for this is to launch mumble after planetside.

    Eventviewer dump:

    Faulting application name: PlanetSide2.exe, version:, time stamp: 0x50ad1cd4
    Faulting module name: mumble_ol.dll, version:, time stamp: 0x4d6039c9
    Exception code: 0xc0000005
    Fault offset: 0x0000f527
    Faulting process id: 0x780
    Faulting application start time: 0x01cdc87c3b0191e8
    Faulting application path: C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    Faulting module path: C:\Program Files (x86)\Mumble\mumble_ol.dll
    Report Id: 7de30bfb-346f-11e2-be6c-00248c5a7137
    Faulting package full name:
    Faulting package-relative application ID:

    If you're having Planetside2.exe has stopped responding errors, you may want to check your application logs inside event viewer to see if you can isolate an offending program.
  16. AngelSnypz

    well i have seen that a few places before with planetside disagreeing with mumble.
    heres my Event viewer dump

    Faulting application name: PlanetSide2.exe, version:, time stamp: 0x50ad1cd4
    Faulting module name: PlanetSide2.exe, version:, time stamp: 0x50ad1cd4
    Exception code: 0xc0000005
    Fault offset: 0x01882b3b
    Faulting process ID: 0x16a4
    Faulting application start time: 0x01cdc85bbb75868a
    Faulting application path: C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    Faulting module path: C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    Report ID: fdd45608-344e-11e2-be75-9cb70d96b7c4
    Faulting package full name:
    Faulting package-relative application ID:

    soooo? planetside2.exe is the problem? and thats the main executable for the game? somethings wrong
  17. Akibo

    I managed to fix mine by simply unplugging my 360 controller. If anyone else who's having this problem has a 360 controller plugged in, try unplugging it.
  18. Mike Hammer

    Well blow me down. I was all set to say I only had a keyboard and mouse plugged in when I remembered that I had plugged in a joystick a couple of days ago. Unplugged it and the game started to actually launch. Then I got an Error code G37--- "The servers are down."

    Sure enough, they took the servers down just a bit ago for a hotfix. What luck. Maybe I will get in yet before I have to shuffle off to bed.

    Still, very sad that they have an issue with a Joystick plugged into the system. Seems they could detect that and disable it in their own software somehow.
  19. FrenziedSoldier

    I just managed to overcome this by finding my Logitech G27 wheel and separate pedals in device manager and disabling them. Although the field of view and menus when running with eyefinity isn't all that great even after turning up the field of view to its maximum
  20. Heeden

    just popping in to confirm unplugging my 360 pad fixed the problem.
    • Up x 1

Share This Page