Planetside 2 Won't Start - Help!

Discussion in 'Player Support' started by wafehling, Jul 7, 2014.

  1. wafehling

  2. Paulus

    Are you launching it through Steam? Steam doesn't like PS2. Best thing is to launch it without Steam.
  3. wafehling

    I am not, I'm launching in through the SOE launcher.
  4. Paulus

    This might sound silly, but what Graphics card is your Ypad using when you try to start PS2? I've heard of some instances where the power options defaulted to the on-board GPU (which is rather weak for gaming) rather than the dedicated GPU. Check in power options as this could affect the game launching if it doesn't detect a GPU which meets the minimum requirements.
  5. wafehling

    I have had similar issues before... Okay. I set every single .exe in planetside 2's folder to run on my higher graphics card, and got nothing. :c
  6. YashaX

    I had the same problem. In the end I found on the forums that this has been an issue with the game for a while and that renaming the exe files so that your computer runs the 32 bit client fixed the issue for me. Here is the advice I followed:

    “First start planetside but DON'T press play
    Next Go to your c drive and get into the directory USER, my SOE is installed under Public. Get into the SOE directory where you can see launchpad, planetside2, planetside2_x64 and planetside2_x86.
    Rename planetside2_x64 to planetside2_x64xx
    then rename planetside2_x86 to planetside2_x64.
    Then go back and press play.

    Your game will run in 32 bit. I also have to do this every time I play because the 64 bit gives me an error. A total pain that SOE has had so many complaints and still has not fixed the problems with the 64 bit version.”

    Note: The file location will vary depending on where you installed the game.

    This is the thread I found the above fix in:

    Hope that works for you.
  7. DatVanuMan

    Just a question. The game runs well for me, but I was wondering, could a game be CPU-based instead of GPU-based? And if so, which one would make the game run better?
  8. wafehling

    That did it! THANK YOU!
  9. YashaX

    NP- remember that you will have to rename the files every time you play - and make sure to first start the launcher and wait for it to update before changing the file names again.
  10. randallt3mpd

    Don't do this. It's a terrible pain in the *** workaround for this bug. No offense YashaX.

    The best thing to do and what worked for me is to go into the directory and delete the Planetside2_x64 file and reload the launcher. It will then re-download and install that file and should be fixed. I guess what happens is the x64 file becomes corrupted over time and you need a fresh one. This works well until it bugs out again for whatever reason.
    • Up x 1
  11. randallt3mpd

    also 32-bit runs like crap for me and alot of others. I get like 10-20 less fps with it.
  12. deliriousbos

    ok so I did The renaming thing and i had to change it to 64bit cuz my 32 would say:error 0xc000007b.And i changed it to 64 and i dont get that but like the guy at the start i get it on task manager and then it crashes
  13. Loagar

    This worked for me. Thanks for the tip
  14. YashaX

    Unfortunately this doesn't work for me, it would be interesting to see if it works for the OP.

    Note that the reason you have to rename the files everytime you play using the workaround is that the launcher redownloads the x86 and x64 files after you rename them. That is also why you have to start the launcher first and then rename them.
  15. FoxyAkademie

    Yasha I had the same problem but its an new verison of the game :(
    planetside2_x64 to planetside2_x64xx work but there is an file who names planetside2_x64_BE what I had to do?????
  16. dog8808

    im having the same problem.

    i know that i have played the game before on my computer and worked (a couple of months ago). recently i was wanting to log back in and could not play. i tried reinstalling the game from steam and from the official website. still wont start the game. when i click play the button darkens and says the game is running, but it is not. the only big difference that has changed on my computer since then is that i upgraded my windows 10 to the windows 10 anniversary. so that i could play halo 5 forge [pc]. not sure if that update caused some problems or not.
  17. Harindir

    Same, though a black screen appears for a few seconds before crashing, any new fixes?
  18. Axar

    Same problem.