Planetside 2 does not lauch

Discussion in 'Player Support' started by Bleak, Dec 27, 2014.

  1. Bleak

    Clicking Play in the game launcher opens a window that states "Game is starting, please wait"
    Both the window and the launcher close and nothing executes
    I have reinstalled the game and allowed Planetside 2 through the firewall
    Framework and directx are up to date
    It may have something to do with Optimus Technology | NVIDIA after a driver install using Display driver uninstaller.
    But I have no idea why the problem persists after a reinstall
    Hardware: Lenovo Y580 Laptop (IdeaPad)
    Windows 7 64bit
    GeForce Driver Version: 347.09 - WHQL Release Date Tue Dec 23, 2014
  2. Ninave

    Just to be sure, the newest DirectX the game checks for isn't enough, it needs the full legacy package from Microsofts own pages.

    You could try starting the LaunchPad as Administrator to see it's no insufficient rights issue.

    Also there have been hardware combinations that have problems with the 64bit version, so you could try if the 32bit starts for you. Start LaunchPad. Go to the games installation folder and rename PlanetSide2_x86.exe to PlanetSide2_x64.exe (rename or delete the latter original). Go back to LaunchPad and click PLAY. It'll now try to start the 32bit version of the game.
  3. Who Garou

    I have the same issue getting into the game.
    Up to the character launcher fine. Click "play" and the game freezes while the music plays for several minutes. Then the game closes.

    Oddly enough, I was playing fine on Dec 23rd. I had been running for several hours and was playing my 4th or 5th character - I have 6.
    Movement was fine, but other input didn't appear to be responding. There was no interaction with other players. After a while the game gave me the disconnect message and closed.
    I immediately tried to get back in and I've been seeing :: "Up to the character launcher fine. Click "play" and the game freezes while the music plays for several minutes. Then the game closes." Ever sense.

    Tech support is worthless.
    I see that you have already reinstalled the game and are still having the issue.

    Have you ever purchased anything through the in-game Market Place? (a weird question, but I haven't and I have the same issue you are experiencing)
  4. Bleak

    Thank you this worked and Planetside 2 successfully launched.
    The problem is that I have to repeat this process each time I run the LaunchPad.exe before pressing Play.
    The LaunchPad automatically checks PlanetSide2_x86-64.exe on launch and rewrites both files to default value.
    Thank you for your help
  5. Bleak

    Just saw that some one was having this problem so I am bumping the solution to the top.
    Please sticky or hotfix this problem multiple people are having with the exe's
  6. OhBamaBinBombin

    Just like you, I have the Y580 win7 64 and the game fails to load past the launcher window... I have found a fix that is totally not one bit what support is telling anyone!!! Use the original non-updated video drivers that ship with the laptop, then 64-bit will actually work! Crazy and totally weird, I still can't figure out any explanation for this.

    If you are like me, I have other games on my computer and newer drivers work better, so I sadly am stuck with 32-bit which a while back I had made a simple batch program to do all the file renaming stuff that you can check out at:

    What does suck now, is that the 32-bit will randomly crash that seems to be a well known and left unfixed problem... GRRRR!!!!!! I think I might end up doing a dual-boot with just PS2 and Win7 so I can play 64-bit again and no damn crashing from 32-bit pile of poo!

    I probably spent an easy 20+ hours messing around with PS2 with all their new 'optimizations' that left so many headaches. Support just tells you to update/reinstall/bla bla, at least I found a real fix! Maybe they will read this, probably not, but if they do they just might have a lead that they just maybe will be able to figure out what is wrong with the 32-bit... doubt it.
  7. OhBamaBinBombin

    Today I did a fresh-install of the 295.55 drivers and for the 3rd time now, the 64-bit works again with these drivers, and not the newest drivers.

    As a second test, I ran the 32-bit PS2 using the old drivers, and played just fine for almost 15 minutes. Before it would go for an hour or more before crashing, other times not even 5 minutes, so can't say for sure that this also fixed the 32-bit...

    Too bad my other games don't run as great with the old drivers, otherwise I would just leave them always installed. Nvidia support puts the blame on PS2 optimizations, based on the fact that I have several other games that work better with the newest drivers, I highly would have to agree with Nvidia on this, even tho SOE has put the blame on drivers as being the issue and to contact Nvidia. Easy to play the blame game, rather than looking further into the issue.