MSI Afterburner is being block by PS2 anticheat engine

Discussion in 'Bug Reports' started by HotPepperDelivery, Nov 25, 2019.

  1. HotPepperDelivery

    MSI Afterburner is being block by PS2 anticheat engine. MSI Afterburner will crash if I launch PS2 before Msi Afterburner, but MSI Afterburner will not crash after PS2 launch. In game hardware monitoring overlay no work before ps2 launch.
  2. FriendlyHuman

    It's not a "PS2 anticheat engine". It's a BattlEye (third-party program). And it often has problems with Windows 10 (especially with up-to-date versions).

    When starting my game with BattlEye enabled, random legitimate applications on my system are being terminated.
    Recently several Windows 10 users have started experiencing this issue without a change on our side. After investigating we have concluded that it is caused by NVIDIA’s new “(Ultra-)Low Latency Mode”. Until NVIDIA provides a fix please disable this feature by opening your NVIDIA Control Panel, selecting “Manage 3D settings” -> “Global Settings” -> “Low Latency Mode” and changing this setting to “Off”. Click “Apply” and potentially also reboot your system. Source.

    P.S. I don't have any problems with BE or MSI. Windows 7 SP1.
  3. BurnzzDK

    Since yesterday, i am experiencing a gamecrash issue w. NZXT Cam software, but i'll try to disable Low Latency Mode later to see if it fixes the issue.(fingers crossed)

    Thx, FriendlyHuman for posting...
  4. HotPepperDelivery

    How to fix this on AMD? It was working fine before Oct 30 patch. After Oct 30 patch, I have to close msi afterburner before planetside 2.

    This is annoying. I contacted Daybreak customer support about this, and they are useless because they can't solve crap beside telling me to go here to post my problem. I guess this is what we get from a company laying off a lot employees and no one cares anymore.
  5. FriendlyHuman

    Because they updated BE on 30th October. What files it blocks exactly?

    You can:
    1) Make a screenshot of what BE blocks, post it on reddit and ask how to solve this problem.
    2) Update MSI Afterburner and Rivatuner (26 October - 4.6.2 and 7.2.3.)
    3) Roll back Windows 10 updates.
    4) Or update Windows to the latest version.
    5) Wait till BE and Microsoft solve this problem (if it's not on your side).
  6. FriendlyHuman

    Possible solution for AMD users is to turn off Ultra Low Power State under AMD Compatability Properties.
  7. HotPepperDelivery

    I am running desktop not laptop.

    I don't know. MSI Afterburner crash immediately after I launch PS2. Msi Afterburner worked if I launch PS2 first then MSI Afterburner. I asked people on reddit and they said it BattleEye blocking MSI Afterburner from running.
  8. HotPepperDelivery

    I am on latest MSI Afterburner and Windows.
  9. FriendlyHuman

    Temporary solution until It's fixed: open Afterburner / Settings / General / Compatibility properties / Enable low-level hardware Access interface / Kernel mode

    P.S. Source if anyone is interested.

Share This Page