Mouse Lock Issue

Discussion in 'PlanetSide 2 Gameplay Discussion' started by soulseeker87, Aug 24, 2018.

  1. soulseeker87

    I recently came back to the game after taking a couple months off and for some reason when I aim down a sniper scope during big fights my mouse completely locks up and refuses to move. Anyone know what's going on?
  2. MyPS2

    Check your "Aimed mouse sensitivity" and/or "Scoped mouse sensitivity" of the general settings tab. If They are turned way down it could seem to be froze...?
  3. soulseeker87


    It's definitely not that. Durign regular or smaller fights I have no issue, but during big ones my mouse will go literally immovable when I ads. The system I have now I've played the game on for many hours and I originally played on a system far worse than my current one and still never encountered the issue.
  4. HippoCryties

    Try turning on reduce input lag in settings and also tick use raw mouse input . I tick mouse acceleration, try that
  5. Ratsle

    Are you sure you are moving your hand that is holding the mouse? I personally have not seen a mouse lock out there that would keep it from moving.
  6. OneShadowWarrior

    I get this issue with my mouse and keyboard with Planetside 2 where it locks or freezes in game and it only does it with this game. It happens a lot when I fly or I have to do rapid movements. It will happen 1-3 times in game, I usually have to unplug my USB and replug it back in to fix it.

    I even tried to disable sleep in USB under power options advanced settings and it did nothing. Now my mouse locks up so often, I have it connected to my monitor so I can reconnect the cable easier, it happens so much.
  7. breeje

    i have this same problem with the g700s, there is no deference with or without the usb cable
    but when i plug in my g403 there is no problem
    i tried other drivers for the g700s, cleaning the laser and some other stuff i found on the web and none worked.
    i know it's the mouse in combination with PS2 but it always worked until a couple of months ago.
    maybe its a driver problem from Logitech, maybe it's a update from PS2, i don't know
    the g700s worked fine in PS2 for over a year.
  8. DarkStarAnubis

    I have a Corsair mouse (M65) and very rarely it stops responding in-game. It started happening in the last month or the last couple of months, can't say for sure. Did not change a single option in the settings.
  9. OneShadowWarrior

    All my mouses from the Logitech G700 to my Steel Series Rival 600, I have seen this issue.

    I am now using a Logitech G702, I unchecked input lag and raw mouse output in settings to see what will happen.
  10. Vertigo102

    same issue I'm experiencing on a Razer Death adder 2018 Elite and 2012
  11. adamts01

    If you use Logitech, try using "automatic game detection" in Logitech's utility. For me, "on board memory" limits how many actions can be completed at once in Planetside 2. This is the only game where I've ever had this problem.

Share This Page