Low performance on Ultra Shadows

Discussion in 'PlanetSide 2 Gameplay Discussion' started by CanadianPawn, Feb 24, 2017.

  1. CanadianPawn

    My specs are
    GTX 1070 8GB
    I5 6660K OC 3.9GHZ
    16GB DDR4 2133MHZ
    PSU 850W

    Eveything is smooth on Ultra. BUT when i turn on my shaodws on Ultra it lags like hell?
    Now everyone is saying that it's a cpu Intensive game. Right, but would it make a difference if i upgraded to an i7 6700k?
  2. The Rogue Wolf

    I think the minimum recommended specs for running shadows on Ultra is Skynet 2.3 (or higher). :D

    (But seriously, shadows are extremely CPU-hungry in this game and even an i7 isn't guaranteed to be a cure. You're not missing out on too much if you keep them set to Low.)
    • Up x 2
  3. DeadlyOmen

    With i7 6700 (3.4), 1070 STRIX and 3440-1440 resolution (X34 monitor OC to 90 Hz) , I run full ultra with high shadows and get 40-60 FPS in huge battles, ~ 100 when nothing is going on.

    Computer is totally clean, and MB is set up to priority process PS2.
  4. JonnyBlue

    I have an i7 4790 , 8 GB ram , Zotac 980 amp .

    Best bet is to turn off shadows completely I followed a guide from the net and my game works perfect of 1600x900 res capped at 65 fps I have models on high and textures on low and the game still looks great.
  5. CaptCran

    Yup. Shadows still help out even if they are on low. Can't tell you how many times I've been in a triple stack and I see someones shadow on the floor when they're around the corner in front of a window.
  6. Gundem

    He... He talks normally?

    Who are you and what did you do with the real DeadlyOmen
  7. blackboemmel

    Your cpu is great, no need to get an i7 for PS2.
    Tip 1:
    Get a nice cooler for your cpu and overclock it.
    Tip 2:
    If ultra shadows still don't run nicely: Turn 'em to "LOW", do not turn them "OFF". Without shadows the game looks crappy, your system doesn't deserve that.
    Tip 3:
    Google "Planetside 2 real ultra settings" and make your game look really nice. (If you haven't done it already.)
  8. DeadlyOmen

    Under different names, I used to write huge posts and argue non-stop.

    Not worth it anymore. :)
  9. Voodoo4500

    Shadows should be set to LOW no matter what IMO. Anything higher just makes the shadow edges very slightly sharper but taxes your system greatly. Higher shadows does not make the game look any better at all.
  10. adamts01

    I saw a shadow once. It was right before my game crashed because I had the wrong settings.
  11. AtckAtck

    I suggest to turn off the shadows completely because the long range jittering bug hasn't been fixed for a long time and probably never will. You simply cannot snipe long ranges with jittering playermodels. Turn off shadows and the problem is gone.
  12. PlanetBound

    Probably the programmers are writing games with better hardware in mind than what is available at the time. Just a thought.
  13. AtckAtck

    No, they just don't know how to fix this crap...
    My guess is, it is because of limitations of the engine itself drawing far away shadows ends up bad.
    Really, shadows have been a problem from day one in Planetside, and that not only because of the cpu time they eat.