Loadouts not saving

Discussion in 'Bug Reports' started by Sumguy420, Nov 15, 2019.

  1. Sumguy420

    Whenever i log out of the game and come back my load-outs are not saved.
    It was like this for 2 years until i figured out an hour ago that the refund on 1.25 sights that were still equipped was what was causing it, so i purchased the sights for each weapon on my vehicles that had the bug and it is now fixed.
    Only issue i have now is, its still resetting 1 of my medic load-outs and 2 of my engineer load-outs!
    i went through every weapon i have for both classes and none of them have 1.25 sights bugged so i have no clue what could be causing it. Every time i log into the game my medic has a pulsar with just a forward grip on it.

    pls help
    • Up x 14
  2. Sumguy420

    someone told me that slott 1 loadout is bugged. but slot one is only bugged on my medic it seems. whereas slot 4 for my engi is bugged instead.
  3. FunkFest

    ASP by chance?
  4. BrbImAFK

    Nope. I'm not on ASP and I've got this bug.

    So far, it only seems to impact my Primary slot on the 3rd loadout slot for my Engineer. I've got my Eidolon (with 3.4x scope) on there and it just won't save. Keeps defaulting back to the basic Solstice. If I reset it at the start of a game session, it'll stay fixed for that session, but as soon as I log off and come back tomorrow it's gone back to the Solstice.
  5. Liewec123

    some weapons dont get saved for some reason, notably the first generation battlerifles.
    • Up x 3
  6. FunkFest

    Thanks I was curious.
    Helpful that you mentioned the Eidolon as it ties in with the Warden and others.
    It has been an issue for players for a while now.

    If we can get some votes on here it might be able to get some attention.

    Don't forget to click the like button on the original post.
    I've sent some reports to try and get the 3/maybe 4 posts merged together.
  7. 9019

    Yep, same here. Warden and equivalent Gen 1 Battle rifles swap back to the respective default carbines regardless of load out placement.
    The attachments are saved across all loadouts though.

    The same oddity happened during my time with the NSO as well. Although the infantry weapons and cert-line seem to work accordingly. The vehicles are suffering the swapping issue as well.


    Performed a brief test and found out that,

    Buying the 1.25 zoom for the Sunderer Basilisk on both front and gun mounts and then crossing to another continent or VR had no problems. No swapping or relocking. Everything as it was/should be.

    Upon logging off and logging back in. The two Sunderer basilisks are wiped of attachments from the load out. The zoom become locked again and repurchase is required to use them again, the full 1 cert. The magazine and ammo do not require repurchasing however. Just needs to be re-equipped.
    • Up x 3
  8. FriendlyHuman

    Did you use Trial or unlock attachments in VR before buying one of the bugged weapons?
  9. Humoreske

    Loadout of a set equipped with Warden is not saved.
    It was useless to remove all attachments, validate game assets and re-install.
    • Up x 2
  10. Sumguy420

    The refund on 1.25 sights patch is what causes this bug. To fix it you must go through all your weapons and check to make sure you don't have a sight equipped that isn't "purchased."
    I went through every weapon i had for both vehicles and infantry and i found several instances where i had the 1.25 sight still equipped but it was greyed out so i repurchased every one that had this error and it fixed it for me.

    For some reason when they refunded the sights, it didn't unequip them.

    Validating your install will have no effect on this bug as i have uninstalled and reinstalled the game 10+ times trying to fix this over the years until i found this fix that i posted.

    Also my medic and engi load outs are not bugged anymore. The fix that i used on them was the same one i used to fix my other class/vehicle load outs and those all worked right away but it took awhile for the engi/medic load outs to fix themselves.

    I dunno it was weird.
  11. OneShadowWarrior

    Yup I get the loadouts being messed up randomly on my classes all the time, usually with the default weapons. I paid monies for these extra loadouts too and services are not being rendered or corrected.
  12. Bertral

    Bump.
    This is still an issue.The AMR-66 and the Eidolon VE33 (haven't tried the Warden) won't stay in any loadout between sessions. It just resets to the default weapon on any class.
    • Up x 2
  13. krazykillerk

    I have the same problem, but not just with eidolon, also some scopes refuse to stay equipped
  14. MalloryKnocks

    I play as medic and got ASP - Battle Rifle Secondary.
    When I try equipping the Eidolon Secondary and either switch continent or relog, the Eidolon is replaced by a blank Beamer (no attachments). I tried renaming my loadouts equipping different attachments nothing worked and it's bugging me a lot! All other Battlerifles are not effected by that bug.

    Please DB for god sake fix it!
    • Up x 1
  15. FoulFoot

    This bug irritates the **** out of me. It's usually my first slot, and if I just grab a different class quickly without first switching to a "good" slot, I'm halfway to taking the Crown before realizing my medic has frag grenades and an auxiliary shield.

    This also tends to occur with vehicles. My slot-1-default Flash never has a primary weapon loaded.
  16. ncr100

    I have this problem on PS4 for my Flash, NixNax Genudine.

    For years it's forgotten my load out for each Continent.

    Frustration.
  17. ncr100

    I got it to remember my loadouts once.

    I equipped a different weapon on my two flash loadouts and then bounced over to the sanctuary, and then they still were there when I checked my loadouts!

    Unfortunately I turned my loadouts back to the way I like them, and went back to amarish, and they were empty again.
  18. ncr100

    Okay I think I got it to remember my flash loadouts. I've been able to switch between amorous and sanctuary multiple times and it remembers my weapons and other customizations.

    Like other posters on this thread, I had to change the optics attachment. I removed it and switched it to a separate one and then bounce between different levels, continents. And it seems to have saved it, and that fixed whatever is broken in my account.

    I think rogue planet should fix whatever is broken in their database where they've got like an empty field or something that's not quite empty, and it just breaks, it's like an invalid serialization in the structure for the flash. I've seen it before in my programming career.

    Hey how, what a pain in the rear. Reverse engineering somebody else's marshalling bug. Frustrating! But I wouldn't have done it without this game having been extremely fun for me so I guess mixed bag?
  19. Bertral

    None of the proposed fixes work for that original battle rifles, with and without ASP.
  20. Zsword

    Hey guys, I was just doing some testing today and verified my install and checked all my accessories on the Eidolon and anytime I hope worlds in any capacity (Sanctuary to VR and back) my Eidolon loadouts all reset to the class default as well, with the only thing equipped being like the vert grip maybe instead of the whole set up that even those normally have.