Launchpad won't start

Discussion in 'Player Support' started by Kaezer, Nov 20, 2012.

  1. Kaezer

    Hello guys,

    After installing, launchpad.exe won't start, even on administrator and using all compatibility modes. I had the beta and this never happened to me.
    It's neither running as a background process, as my Task Manager displays no launchpad.exe running.

    I have uninstalled and reinstalled multiple times with different methods, and still the same.

    Any ideas out there ?

    FIXED - Here is how I did it (Make sure you have the PS2_installer.exe released today):
    1) Open the Task Manager (ctrl+alt+suppr) and close any launchpad.exe processes
    2) Uninstall Planetside 2 through the Programs and Functionnality panel
    3) After that manually delete the Planetside 2 folder if there still are things left
    4) Execute PS2_setup.exe in admin mode
    5) Wait for the install to finish and check in your Task Manager if launchpad.exe is running
    6) If yes, do absolutely nothing for around 10 minutes, it will open the launchpad by itself. No reboot, no install suppression, no spamming Planetside 2.exe. If no, I can't help !
    • Up x 1
  2. sunkzero

    Same problem here, can't get it working yet... beta was fine as well!
  3. HubschrauBaer

    Same problem here !! As in the last days of the beta, the launchpad just crashes after clicking on it !!!


    Sry, dont know what to do here ... HELP
  4. Twist

    Hey guys - it is remotely possible that somehow you have either an old copy of the launcher, or an INI file from an old launcher. If you see the icon for launcher on your menu bar but the display doesn't appear, the problem is that it is trying to draw off screen (this should only happen in the above circumstances). If you start with the installer from the site that exists now, and make completely sure you are installing to a new directory or have completely erased all previous data, this should fix the problem.
  5. Kaezer

    After a new fresh install, I have noticed that right after the installation is finished, there are 2 launchpad.exe in the task manager. I'll try to let them run for a while see if they automatically launch, and I'll come back to you guys
  6. HubschrauBaer

    Nope, i have an clean and fresh installation path.
  7. Kaezer

    Twist, I am using the planetside installer that I downloaded on the website today. I completely erased the beta files (uninstall wouldn't work, so I shift+suppr'ed them as one of your team member suggested) and this happens with the newly released launchpad.

    I wouldn't even have bothered coming here without making sure I was using the right programs.

    Also, correct me if I'm wrong, but I don't believe it is trying to draw off screen, because no processes are launching when double clicking it.

    However, right after any fresh install, I do have a launchpad.exe that is not displayed.

    EDIT - FIXED : Just as I was writing this edit, the launchpad mysteriously popped up after a fresh install, after 15 minutes running in background, I'll update the OP
  8. Kur0ko

    Same here, I tried to install the game on my second computer (I never installed the beta on this one) and nothing happens. I downloaded the launcher today from the link in the forum but once it's installed the launchpad doesnt open, there'S not even a new processus that is created when I try to open it
  9. Kaezer

    Kuroko and Buscher, check my OP, I updated it with my fix.
  10. Kur0ko

    Tried Kaezer's solution, after 5 minutes I got an error message saying that the launcher stopped working
  11. Kaezer

    I hope you find a way to get it to work man !
  12. Fenrys

    Thanks Kaezer. I was having the same issue, and your process got it working.
  13. dirtYbird

    GO GO Myr!
  14. sunkzero

    Yup that did it for me, thanks :)
  15. Turnwide

    Good job, worked for me.
  16. Closcaj0

    I tried this and it didn't work. I'm starting to get really frustrated with all this.
  17. medafor

    You must install in a different directory other than the default. I installed to D:\Planetside 2\ rather than the weird default location and it worked finally.
  18. Sunwalk

    I had the same problem and I this is my solution:
    - uninstall/delete everything that belongs to Planetside 2 (I used Revo Uninstaller)
    - check your firewall and add all PS2-files to "trusted files", "safe files" or whatever it's called on your firewall
    - check your "blocked files" and remove the PS2-files (I have COMODO Firewall)
    - install PS2 and stay on your pc, just in case your firewall finds something that needs your attention

    I'm not saying this is the only way to do it, but it worked for me and it would be a shame if other people couldn't play this epic game because they aren't able to install it ;)


    See you ingame,
  19. BenYeeHua

    Ya, bad Firewall.:D
  20. Athnor

    Ok i hope this helps, i had the same problem with my launcher not starting. i suggest wiping all planet side data from ypur computer. then set you local account to an admin. then download this PS2_setup(2).exe .
    i hope this helped.

    see you out there

Share This Page