Launcher crashing

Discussion in 'Player Support' started by Stratavio, Jan 8, 2013.

  1. Stratavio

    I am trying to install this game and every time i try to run the launcher it crashes out right after i accept the eula. why?
  2. TSR-Jesse S Customer Service

    I would suggest making sure your current .Net Framework installation is completely up to date for the launcher to work correctly. You can download this update from the following link:

    You may also want to make sure that you have the appropriate DirectX files installed. Please follow the instructions located on the website below to download and install DirectX 9.0c (June 2010 version):

    1. To download, click on the Validate button on the main DirectX page.
    2. Once verification completes, you will be allowed to download Direct X. Choose the option to save the file to your Desktop.
    3. Double click on "dxwebsetup" on your desktop, then follow the instructions.

    Let me know if that helps.
  3. Stratavio

    Nope, it didn't solve the problem.
  4. TSR-Jesse S Customer Service

    There are a few different issues which may be causing this problem for you, so you may need to try a few things to get into the game:

    1. Please ensure that you have added an exception within your Firewall or Anti-Virus software for planetside2.exe, launchpad.exe, awesomiumprocess.exe, and ApplicationUpdaterService.exe.

    The location of these files can vary, but by default they should look like this:


    C:\Users\<your username>\AppData\Local\Sony Online Entertainment\ApplicationUpdater\ApplicationUpdaterService.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    Windows XP

    C:\Documents and Settings\<your username>\Application Data\ Sony Online Entertainment\ApplicationUpdater\ApplicationUpdaterService.exe
    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Program Files\\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    The AppData and Application Data folders are hidden in Windows by default so you may need to enable "View Hidden Files/Folders" before you are able to find these files.

    2. You may need to clear the cache settings for the launch pad by going to the launchpad.libs folder in your PlanetSide 2 directory and delete the launchpad.cache folder then try accessing the game once again.

    3. The launcher may have been corrupted and will need to be repaired before it will work correctly. You can repair the launcher with the launcher set up file from the following link:
  5. Stratavio

    Ok, so i don't have
    C:\Users\<your username>\AppData\Local\Sony Online Entertainment\ApplicationUpdater\ApplicationUpdaterService.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe

    beyond that, i cleared the cache and i repaired the launcher, neither of which worked. also i have my firewall completely off and my AV is off.
  6. HubschrauBaer

    i have the same problem: The launcher crashes permanently after starting. It is the same unsolved problem that i have at every new update for the game. I just want to remember the Devs that the problem didnt occur when the game was in Beta. Or are we still in Beta ? ..........................................................
  7. TSR-Jesse S Customer Service

    Regrettably this issue can be caused by a variety of different factors so it is hard to definitively say what could be triggering it. To provide you with a more concise answer my best suggestion would be to open a support ticket with us so we can check your system specs and provide you with some solid suggestions to get you back into the game. You can open a ticket with us at the following link:
  8. Kayko

    I had this problem and searched through countless threads for answers and not one thread told me to change the compatibility mode for the game. Try right clicking the launcher, go to properties and try running it in windows xp service pack 3, this is what i did and it works. It could work with other compatibility modes, this just happens to be the one i picked and it worked successfully.

Share This Page