Game unplayable since update due to invisible ground

Discussion in 'Player Support' started by Xiphos, Feb 2, 2013.

  1. Xiphos


    Restarting the client didn't fix it.
  2. sagolsun

    Ditto, ground is invisible.

    Tried to record video but the video files are corrupted. Not a hardware issue, writing to SSD.
  3. sagolsun

    Deleted user options
    Restarted with low graphics
    Restarted with high graphics
    Validated game files

    No effect. Ground is still invisible.
  4. FA_Q2

    How did you get in. As far as I can tell, the servers are still down...
  5. Raichu

    Ok seems the pacth is one big clutser **** of problems right now Im gonna wait a day and play tommrow haha
  6. sagolsun

    They are most definitely up, though I get the impression they'll be taking them down again shortly. It appears they screwed something up with the magrider, rolled back and installed an earlier dev build.
  7. GeneralShakes

    There seem to be a number of issues that I am noticing - devs, let me know if you would like specifics on anything

    1. the map shows people jumping all over the place and faster than game speed
    2. portions of the ground disappear and reappear
    3. players running forward blip back and forth as they run in a straight line
    4. as of the update, I can't keep the client running for more than 5-10 minutes

    I have tried various graphics settings, with no success (my machine is capable of playing the game at the highest resolutions, so I tested that as well).

  8. CyclesMcHurtz Code Monkey

    Invisible ground is a case where submitting an in-game ticket helps us a great deal. It gives us additional information about the game state and the location of the issue.
    • Up x 1
  9. Xiphos


    I sumbitted a ticket: 130202-001120
  10. sagolsun

    Ticket submitted. Ground does NOT DISAPPEAR, it's displayed about 4-5km below where it should be. Depending on graphic settings the heightmap tiles get culled and may not be displayed. However the ground is rendered, just not where it should be. Collisions work properly.

    Edit: Depth sorting is also wonky, I'm seeing a lot of flickering back and forth.

    Game also crashes when releasing LMB on medic tool fire.
    TR default burst pistol is silenced.
    Detonating C4 results in CTD.

    Seriously man, what happened?
    • Up x 1
  11. Xiphos

    Also in some places the strings are missing. ie. I see things like ##UI.ColorPreset instead of the text that's supposed to be in place.

    The SMGs aren't listed in the class certifications either, only in the shop.
  12. sagolsun

    And in graphic settings a mysterious entry above a slider titled simply "textField".
  13. CyclesMcHurtz Code Monkey

    If you are getting this problem, try exiting the game completely and when you re-start the launcher change the language used to some other language, and then change this back to your preferred language.
    • Up x 1
  14. sagolsun


    The terrain textures are in the right position but it's as if heightmaps were all zero-filled, that is the heightmap displacement is not applied to the textures.

    My 5km estimate was way off. Lowest points on a map (eg. Esamir trench, Indar crater) have the ground at the correct level - 0. However wherever the ground is raised the textures stay flat on 0, without the displacement. Then clipping issues come in and the texture tiles disappear.
  15. SGT Ace

    You guys in soe tested it on your test server??
  16. HappyWeapons

    Like all patches. This is your typical world of warcraft coding bought to you by blizzard: New patch = 30 bugfixes and the implementation of 60 new different bugs from which roughly 1/3 are a lot more severe than the issue that got originally fixed by the patch.

    Better get used to this kids.
    Patch day = no PS2 for at least 2 days
    • Up x 1
  17. sagolsun


    Although I get bizarre behavior and frequent crashes, I have no frame stutter.

    So it's either frame stutter or bizarre (threading??) issues, not both.

    If you're having disappearing ground or similar weird behavior, are you experiencing frame stutter as well (outside of the inifial few seconds after spawning)
  18. general_azure

    had steam redownload the client (followed by patching again, ofc)... this fixes nothing either. just in case someone else gets the idea =p
  19. general_azure

    my merc carbine also lost it's firing sound, I just noticed... there's some major ****up going on it appears 0o
  20. AndreyMusaty

    I would also like to report VS Manticore pistol missing firing sounds completely as well.