Game Shutting Down On Its Own

Discussion in 'Player Support' started by Nogitsune, Jun 23, 2013.

  1. Nogitsune

    Randomly, my game will shut down, kick me out and only give me a "A problem has occurred" window 1/3rd the time, the other times it just kicks me off without even acknowledging it. Happens mostly when I'm loading something. Either I'm swapping classes, making a vehicle, flying into a large fight, that kind of stuff. Now I'd understand if the frame-rate tanks a little while it loads, but it's like the game says, "F*** this s***" and turns itself off within a second. You know how frustrating that is when I'm trying really hard to tip the scales in a 50-50 massive assault? I'm considering removing the client all together and reloading it unless y'all have a better idea.
    Any help would be appreciated.

    I'm running a GTX 660ti and last I checked the drivers are up to date, but it's been doing this to me for months now, I've been quiet about it because I have other MMOs to play and sometimes I welcome the game kicking me off so I can get food or sleep.
  2. NaniteSystems

    It's not your software, it's the game itself. Ever since GU11, many players of Planetside 2 have been experiencing random events where the game just closes unexpectedly with no explanation, including me. I'm stuck on the forums because of it and there have been about 6 other posts on the same thing. Frankly, I'm starting to wonder if SOE pays attention to them, because this has been going on for quite a while now and ever hotfix they are coming out with isn't for this error. If they want to keep their players, they need to fix this.
  3. ProDogFighter

    Perhaps one of you 2 can try this, as the other person I was trying to help was too incompetent.

    Disable all of your sound devices in device manager, and try to replicate the problem again.

    And the times that it does give you an error message, try looking in windows event viewer to see if it gives any information.

    Are you both, by chance, using fraps \ MSI afterburer overlay \ PhysX \ Custom INI file settings \ AMD cpu \ CPU or GPU OC or OV \ Are you both using logitec keyboards + mice?

    If you launch the game through steam, does it launch PS2 launcher or go directly in-game?
  4. VikingVR

    Hi Nogitsune,

    I noticed you mentioned that you are running the latest drivers on your GTX 660ti. By any chance are they version 320.18? They've been known to cause a high number of crash to desktop. If so, revert your drivers to version 314.22. Also disable PhysX as it's be known to cause some crashes.

    Here's the link to the nVidia version 314.22 driver if you're running a modern Windows 64bit OS.

    Also, have you created a ticket with SOE support? You can find the details to opening a ticket in a SOE KB in my signature. Good Luck and keep us posted!
  5. user101

    Got the same problem here... just shut down no error at end, just closes.
  6. Sandzibar

    Same problem. Either crashes with the PhysX3_x86.dll error event.. or no error at all straight CTD.

    I tried using 320.18 drivers to try and fix the physx issue. Hasnt helped and looks like its also causing additional issues too.

    Will try again with 314.22
  7. VikingVR

    Some folks have reported that simply uninstalling the 320.18 drivers and re-installing the 314.22 drivers was not enough. They had to "clean" the system from any driver presence and install 314.22. I'll see if I can dig up that post as it may help some of you out.
  8. VikingVR

    Well seems I can't find the detailed post regarding a way to ensure your system is cleaned out from left over driver fragments. The post I'm referring to used no third party apps and was just a series of processes to ensure you cleaned out the drivers prior to install.

    Anyways, In Control Panel, Programs and Features, uninstall any software references to nVidia. Reboot. Run the 314.22 driver install. During the install there should be a check box for "Perform a clean install". Ensure that box is checked and continue through until the driver is installed. A reboot is suggested, but isn't necessary unless the install requests it.
  9. NaniteSystems

    I will look into doing this after I at least try turning PhysX off and see if that doesn't work.
  10. lords8n

    How do I fix this?
    I run everything ultra LOW and certainly don't have PhysX turned on.

    Faulting application name: PlanetSide2.exe, version:, time stamp: 0x51c4ef6d
    Faulting module name: PhysX3_x86.dll, version:, time stamp: 0x51893f48
    Exception code: 0xc0000005
    Fault offset: 0x001442e7
    Faulting process id: 0x129c
    Faulting application start time: 0x01ce712f9bf953f0
    Faulting application path: C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    Faulting module path: C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PhysX3_x86.dll
    Report Id: 7f77b114-dd24-11e2-a6d2-20cf305e6db5
  11. VikingVR

    Good to hear. Let us know how it goes.

    Kind off quoting myself here because on the way home from work I was mentally walking through some additional steps to ensure a better uninstall. Start by Rebooting the system and press F8 to initiate going into Safe Mode. Go to Device Manager, right click and uninstall the video card. Then follow the rest of the instructions in the quoted text above.

    If these instructions don't make sense, let me know.
  12. VikingVR

    Unfortunately all I can decipher from your terse error log is that it's cause by a access violation on the PhysX Dll. What version of the nVidia drivers are you running? If it's any consolation, I get the same Exception code on PlanetSide2.exe after long gaming sessions. As far as I can tell, I think it's a buffer overflow/overrun and depending on variable conditions it fires when different modules are affected by memory management functions of the faulting application.
  13. NaniteSystems

    Nothing changed. Even with PhysX turned off, the crashes still happen.
  14. VikingVR

    Hi NaniteSystems,

    I've got a few questions for you. Are you experiencing the exact same issue Nogitsune is? What version of the nVidia drivers are you running? Check the application event log, do you notice any entries for Planetside2.exe?
  15. NaniteSystems

    I have the exact same problem, the exact same graphics card, and the drivers are 320 version (I believe). Now where do I go to check the application event log?

    P.S. I sent SOE a support ticket, they responded that they're trying to figure out what the problem is and that they'd report back to me shortly.
  16. VikingVR

    Hi NaniteSystems,

    Ok, to check the log, head to the START button open it. Then right click Computer, and select Manage. The Computer Management MMC should open up and one of the items in there should be the Event Viewer. Expand the Event Viewer, then expand the Windows Logs. In the Windows Logs, there should be a Applications log. Select it to see the list of events that have been reported by applications. Now to easily find events reported by Planetside 2, right click the application log and select find. In the find box, type planetside2.exe and that should take you to the nearest entry in the log.

    I hate to ask, but have you tried reverting your drivers back to version 314.22? Here's the link to the GeForce 314.22 Driver.
  17. NaniteSystems

  18. VikingVR

    It's not hard to revert the drivers, follow the easy process I linked above. Just download them before you uninstall the other ones. On another note; They released new beta drivers yesterday. I haven't checked them out but some people are reporting good things about them with and without PhysX regarding the CTDs. There are instances of no change to the CTDs.
  19. NaniteSystems

    Well the technical group responded to my support ticket and said to revert my NVIDIA Windows Display Drivers. I assume they mean all of them because when I checked, there wasn't one specific card that was called that. which drivers should I uninstall and revert back to the previous version?
  20. NaniteSystems

    I reverted the drivers using the web link that you sent me...however it says that my current driver version now is 311.06 and I do not have a PhysX driver anymore. Help?

Share This Page