Game Error G9 Malfunction

Discussion in 'Player Support' started by taurangaNZ, Oct 22, 2014.

  1. taurangaNZ

    I have uninstalled, and reinstalled, restarted all PC and routers.
    updated all ATI radeon drivers. All antivirus are off, no firewall, and
    Still no difference. I have played this game all year ok. and just
    with the latest round of updates in sept/oct
    launchpad works perfect, planetside_x64 loads perfect, I get to the player menu, my character downloads perfectly.
    I click Briggs character, and click Play. Then it gets to 100% waits 105 seconds then
    crashes out with Game Error G9 to the web browser. I have restarted my PC 25x
    times, tried reinstalling twice, tried logging in to other servers, and
    other account. same thing.. Game Error G9 Malfunction. thanks.

    - I have 38ms ping to Briggs.
    - Been playing for many many many months, I am level65, wonderfully awesome game, silky smooth fps, no lag, no issues.
    - Paying PS2 member.
    since the updates in the last 5 weeks, I started getting a G9 error.

    I heard that G9 Error means this
    "Log out of the game and the LaunchPad, then reopen the LaunchPad and log in again. If the error occurs repeatedly, a full uninstall and reinstall of the game may be required. If the error persists, please contact Technical Support."

    I contacted Technical Support, they can't seem to figure out the problem...
    all my pings to the servers are perfect...
    I uninstalled and reinstalled 2 times.
    I installed on a brand new Laptop with a different account, same error G9

    Zero packet loss. perfect connections...
    ping Packets: Sent = 100, Received = 100, Lost = 0 (0% loss)
    Ping [] Packets: Sent = 100, Received = 100, Lost = 0 (0% loss),
    Tracing route to over a maximum of 30 hops
      1    <1 ms    <1 ms    <1 ms  BoB.Orcon []
      2    15 ms    16 ms    21 ms []
      3    14 ms    14 ms    14 ms []
      4    16 ms    15 ms    15 ms
      5    16 ms    15 ms    14 ms []
      6    43 ms    37 ms    39 ms []
      7    38 ms    38 ms    37 ms []
      8    39 ms    38 ms    38 ms []
      9    39 ms    38 ms    39 ms
    10    39 ms    39 ms    39 ms
    Trace complete.
    Any ideas?
  2. Beastman

    Same issue but with nvidia card. Carried out all the steps you have.
  3. Beastman

    Actually sorry, I sometimes get in game, can see the screen to spawn and everything but can't do anything and then server disconnect followed by G9. Sometimes its the same as the OP. Only happened about 2 weeks ago, been playing for 2 years.
  4. taurangaNZ

    from MixMax October 3:
  5. taurangaNZ

    Pinging [] with 32 bytes of data:
    Reply from bytes=32 time=317ms TTL=108
    Reply from bytes=32 time=316ms TTL=108
    Reply from bytes=32 time=315ms TTL=108
    Reply from bytes=32 time=315ms TTL=108
    Ping statistics for
        Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
    Approximate round trip times in milli-seconds:
        Minimum = 315ms, Maximum = 317ms, Average = 315ms
  6. mixmax

    I have the same problem for almost 1 month now. Also thanks for using my quote :D
    Did you guys come across any solution?
  7. taurangaNZ

    I will start collating some facts, to try and solve this...
  8. taurangaNZ

    I agree with napsterbater... I have observed the same.

    the following IP addresses in use are:
  9. taurangaNZ

    plays planetside2 perfectly with no error message.
    ping 100% ok with zero packet loss.
    follows same Level3 pingpath route.
    when SOE gets a response back from my PC game client, it uses the MAC address of my VPN server's router.

    game Error G9 when trying to connect to any EU, US, AU ps2 server.
    ping 100% ok with zero packet loss.
    follows same Level3 pingpath route.
    when SOE gets a response back from my PC game client, it uses the MAC address of my ADSL router
  10. taurangaNZ

    things I have tried unsuccessfully to resolve g9 error are:
    - tried another PC, (i.e. another hardware id) Hardware ID is made up of network card id, disk drive volume id, video card id <- changing any of these generates another HWID.
    - tried another account (i.e. my friends account)
    - tried editing the MAC address of my router (i.e. under you can edit your adsl routers MAC addresS)
    - tried adding all IP to the hosts file
    - tried ipconfig /flushdns
    - tried netsh winsock reset
    - tried reinstalling PS2 two times from scratch.
    - tried restarting my PC 50 times.
    - tried validating game files from the ps2 launchpad
    - tried deleting folder C:\Users\Hamish\AppData\LocalLow\Sony Online Entertainment\
    - tried deleting folder C:\Users\Hamish\AppData\Local\Sony Online Entertainment\
  11. PeanutMF

  12. taurangaNZ

    ok being a computer fanatic, I kept digging and researching for another 2 weeks straight.

    I traced the problem to larger UDP packets being sent in the later versions of planetside2, I guess its a sign that the game is growing in size and complexity, and the amount of information needed to be exchanged between client and server has grown.

    what happens is UDP IP fragmentation is required in Planetside2 since 2/10 patch. some NAT implementations on ADSL routers can not cope with this advanced form of UDP fragmentation.

    many gamers have found that if you have an iinet or orcon boblite adsl router, that the firmware latest 1423 actually does not support IP fragmentation correctly, even when fully DMZ and port forwarded to your PC the NAT software in the router still fails to correctly parse the IP udp fragmented packets. I'm not sure who's job it is to not exceed UDP packet limits (planetside2_x64.exe), and whos job it is to reassemble them (PC or home router). either way, the fix is simple and in your control...

    Phone Orcon NZ and say you are a GAMER and IT technician, and that you require router firmware 1415. They will log the job with level 2 support, and you will get a firmware upgrade done from their end. The occasional amazingly helpful and outstanding level 1 support can do it on the sly, but its not their job. Wait 20 minutes for the router to update itself. and then try planetside2 again. works perfect!

    If your ISP is not giving you the support you need, you can manually downgrade your router to a better firmware with IP USP NAT fragmentation support.™_Firmware_upgrade

    This is also the logical reason why an L2TP VPN connection was allowing the planetside2 game to work, because L2TP vpn is assembling and reassembling the UDP IP fragmented datagrams for you, therefore does not need the router to do that job.

    This is also the logical reason why ping, pathping, tracert, nslookup, hosts file all worked perfectly.. because these tools all work without any IP fragmentation tests built in.

    Any questions, let me know and I will try and help you to resolve your game issues too...