G21 error crash

Discussion in 'Player Support' started by Avallac, Nov 21, 2012.

  1. Avallac

    I've validated everything through steam and it downloaded 40 mb of files, which upon launch the launcher replaced with previous files, regardless everything else was validated through steam fine and there shouldn't be any corrupted files. The game worked fine during the beta but now its unplayable since it crashes quite often.
  2. TSR-SeanF Customer Service

    The first thing I would suggest you do is completely uninstall the beta client if you still have it installed. Once this has been done go to your PlanetSide 2 directory, delete your UserOptions.ini file, and re-run the PS2 patcher. Once you have done so try logging in again and you should be all set.
  3. Avallac

    Ok I'll try that, the unfortunate part is I have to redownload the whole game at 2 mbps :/
  4. TSR AlexS Customer Service

    Sorry for the inconvenience. Please let us know if it helps!
  5. MiniLink

    I have the same problem. I have installed PlanetSide 2 on Steam but my beta client was installed so i uninstall both , search and dellete all files from planetside 2 on my pc. downloaded and installed PS2 on steam again but still get the Game Error G21. so i tried to delete UserOptions.ini and launch the game again but still get the error.

    EDIT: I checked the game files too no problems
    Checking game installation...
    Found 1 file(s) to update.
    Replacing ClientConfigLiveLaunchpad.ini
    Finished downloading 912 bytes in 0.263 seconds (3,467 bytes per second)
    *Error: Unable to launch ConfigLaunchPath parameter not specified in digest
    Checking game installation...
    All files are up to date
    Checking all game files...
    All files are up to date
    this problem wasnt in the Beta ... i had no crashes but now the game crash after 1-2min playtime. is this a problem with steam ?? or is it a new bug with the game ??

    my drivers are up to date.
    GeForce GTX 470 Driverversion 306.97
    Realtek HD Audio Driverversion R2.70
  6. MiniLink

    Sorry for double post but i can't Edit my last post -.-

    i don't know but this maybe helps. i just logged in and go outside the warpgate building and a vehicle explode nearby. result my game crashed but i don't get an error or a crash-log just the window PlanedSide 2 has stop working.

    this is also a problem that i don't had in beta ...
  7. kensai

    Same problem here. I had the beta installed, and got the G21 after about 1-3 mins of ingame time. I followed the suggested solution and deinstalled, deleted UserOptions.ini, and reinstalled via the PS2 Launcher.
    Still G21.

    How do I proceed from here?
  8. Vérszomj

    I played 113 hour with my NC character on cobalt , I created a new VS char on woodman because i wanna join to a hungarian outfit but my game crashes after few minutes when i am going into the battlefield... why?
  9. Vérszomj

    no matter after 3 error , i can play normaly :O
  10. TheKrogMonster

    If you installed Planetside 2 on Steam and you are getting error G21 then Go on to Steam and into your library and right click on Planetside: 2. Then click on to Properties, then local files on the properties window. Then verify integrity game cache and lets it do its thing. Once it has finished, it will tell you a number of files missing. Close that windows and then Steam will automatically download those files back for you.
    -Hope I helped. Nick

Share This Page