Error G99

Discussion in 'Player Support' started by Maljas23, Feb 25, 2013.

  1. Maljas23

    I've already looked at what this error code means. However, the servers are currently still online and I'm still getting this error regardless. I was able to play completely unhindered until early this morning. Now every time I click "Play" it takes me in-game to the logo screen and the loading bar never goes beyond 15%. After about a minute, the game crashed out to the "Error G99" screen.

    Can anyone please assist me, as I have had no other problems with this game until now.
  2. BenYeeHua

    Delete the UserOptions.ini?
  3. Maljas23

    I tried this but it did not fix the problem sadly.
  4. TSR-Jesse S Customer Service

    There are a few different issues which may be causing this problem for you, so you may need to try a few things to get into the game:

    1. Please ensure that you have added an exception within your Firewall or Anti-Virus software for planetside2.exe, launchpad.exe, awesomiumprocess.exe, and ApplicationUpdaterService.exe.

    The location of these files can vary, but by default they should look like this:


    C:\Users\<your username>\AppData\Local\Sony Online Entertainment\ApplicationUpdater\ApplicationUpdaterService.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    Windows XP

    C:\Documents and Settings\<your username>\Application Data\ Sony Online Entertainment\ApplicationUpdater\ApplicationUpdaterService.exe
    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Program Files\\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    The AppData and Application Data folders are hidden in Windows by default so you may need to enable "View Hidden Files/Folders" before you are able to find these files.

    PS2 & Anti-virus software

    2. You may need to clear the cache settings for the launch pad by going to the launchpad.libs folder in your PlanetSide 2 directory and delete the launchpad.cache folder then try accessing the game once again.

    3. The launcher may have been corrupted and will need to be repaired before it will work correctly. You can repair the launcher with the launcher set up file from the following link:

    Let me know if that helps.
  5. BenYeeHua

    Just follow Jesse S, it can be server or firewall or ISP issues.;)
  6. Maljas23

    I have tried everything you have suggested and even double check the exceptions list on Norton but I have had no success.
  7. TSR-Jesse S Customer Service

    Regrettably this issue can be caused by a variety of different factors so it is hard to definitively say what could be triggering it. To provide you with a more concise answer my best suggestion would be to open a support ticket with us so we can check your system specs and provide you with some solid suggestions to get you back into the game. You can open a ticket with us at the following link:
  8. Maljas23

    Thanks but I just solved the problem. It turns out my Firewall somehow reset all my entered Ports. Thank you for the assistance anyways though.
  9. TSR-Jesse S Customer Service

    Excellent! I'm glad you were able to get your client working again, if you have any other questions, feel free to ask.
  10. grazr

    I seem to be getting this error now too, but certain things worry me. I was on the support ticket list for 4-5 weeks to the advanced sony support team through Febraury-March because the launcher was failing repeatedly and all of those suggestions were made and failed before i was sent to the advanced support after the first week who weren't able to help either.

    The thing is, not only did have all the relavent ports open and exceptions made in my AV, but even after turning them off completely the launcher still wasn't working and the advanced team seemed to think i had a corrupt user on my system. After 5 weeks the launcher suddenly kicked in arbitrarily and i got a windows alert saying PS2 was trying to access the internet, "should i let the firewall allow this". I did and it started working.

    Now i'm getting another error that seems to be firewall related.

    I added PS2 to the firewall exception for a third time and it downloaded an update the launcher missed the first two times i ran it before i did that. I got into the loading screen (which it was allowing me to do prior to the hidden update anyway) and then booted me off and i'm still getting this error.

    I'm worried i'm going to have to wait for windows to notice PS2 so it can remotely/automically add it to an exception again because manually doing it doesn't seem to do anything.
  11. KingOfLuck

    I am also getting this error and had no problem playing last night till 1am.
  12. Aircrafter991

    calm down, the servers are not even up again. wait untill it says : UP instead of MAINT(ENANCE)

    and problems will be fixed.