Crashing when launching

Discussion in 'Player Support' started by IamnotAmazing, Jul 5, 2013.

  1. IamnotAmazing

    I launch the client, I click play, then the game goes to full screen but is just a black screen, then it crashes. Before this started happening my game randomly crashed. I have validated the game files twice, re installed it, and restarted my computer. Really? double xp weekend?
  2. IamnotAmazing

    quick update it worked for a few hours then started crashing agian
  3. TSR-Jesse S Customer Service

    There are a few different issues which may be causing this problem for you, so you may need to try a few things to get into the game:

    1. Please ensure that you have added an exception within your Firewall or Anti-Virus software for planetside2.exe, launchpad.exe, and awesomiumprocess.exe.

    The location of these files can vary, but by default they should look like this:


    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Users\Public\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    Windows XP

    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.exe
    C:\Program Files\\Sony Online Entertainment\Installed Games\PlanetSide 2\PlanetSide2.exe
    C:\Program Files\Sony Online Entertainment\Installed Games\PlanetSide 2\LaunchPad.libs\AwesomiumProcess.exe

    PS2 & Anti-Virus Software

    2. You may need to clear the cache settings for the launch pad by going to the launchpad.libs folder in your PlanetSide 2 directory and delete the launchpad.cache folder then try accessing the game once again.

    3. The launcher may have been corrupted and will need to be repaired before it will work correctly. You can repair the launcher with the launcher set up file from the following link:
  4. IamnotAmazing

    they are all enabled I don't understand, the game has worked since beta, sometimes it works and sometimes it doesn't I am not sure what fixes it. I have validated and completely re-installed the game, clearing the cache folder didn't help and just made the launchpad look really weird. I will try later after I restart my computer and see if that works.
  5. IamnotAmazing

    alright, restarting did nothing. My fix for it is just opening the game 15-20 times and it seems to work :)