Can't purchase anything with SC

Discussion in 'Player Support' started by Endlave, Feb 20, 2015.

  1. Endlave

    I am a bit disappointed to see I can't buy anything with SC, despite having some on my account. The day before yesterday, I wanted to buy a camo that was 50% off and simply couldn't because apparently some zipcode wasn't on file.

    Well, yeah. There wasn't. When I created the account, I didn't feel the need to provide such information because who the hell even cares? But seeing how it was required now, I guessed I would go to my account, add that bit of information and log back into the game to try again. Still the same ****.

    Typing in your zipcode into the provided field ingame will also yield you nothing because it will always tell you that some kind of error occurs. Well, that's just great. So are you telling me the 5 bucks I spent on this game are useless now? Needless to say the sale for the came is already over so yeah...really disappointed.

    Maybe I should add that my account is set to be an American one for some strange reason I don't know. I can't change it to European, though. I am fairly sure I never set it up that way. Maybe that's the issue?

    I already wrote a ticket, but it hasn't been addressed yet. Maybe some of you guys have encountered the same problem and know a workaround? Would really appreciate the help so that I won't miss another sale...
  2. Endlave

    It's still not working and support isn't addressing the ticket I opened last Wednesday. I am really annoyed by now. There is another camo for sale and while not as nice as the first one, I would still like to get it. Isn't there anything I could do?

    this is a screen of the window that pops up. I can write whatever the heck I want in there and it will result in an error:

    http://cloud-4.steamusercontent.com/ugc/538515335685004595/1C1FC9A97709F425DDD1E6241EAB9918FD003A7D/

    good thing I only decided to spend 5 euro on this game...will definitely not get any more SC...what's the point if I can't use it anyway...

Share This Page