Anyone else getting really bad server lag?

Discussion in 'PlanetSide 2 Gameplay Discussion' started by RabidIBM, Apr 26, 2021.

  1. RabidIBM

    For me it started in the last couple days. We've had the server seeming to come up and down while we're playing, I even somehow blasted of a round of fire on sanctuary. People are clipping through floors and walls, all that good stuff.

    How many others is this happening to?
  2. BlackFox

    Happens to me at every prime time on Miller - and it's clearly not a problem on my end (100% fiber connection with 250/mbit volume in a low traffic area)
  3. Grandizer

    After the 24hr maintenance for hardware install or whatever it was, I began to see air vehicles stutter a bit while flying, like hitching and getting micro hitching during gameplay. This happened before after Bastion update which people were putting tickets in for including myself. It went away and now it's back a little. I'm on a good i7 9700k rig with a 1070 TI and get well over 130 FPS in 96+ on a mix of High textures/terrain, Ultra models and Medium lighting and no shadows/bloom/ foliage etc.

    The thing is, this happens in small fights on the way to bases where the area is practically unpopulated. I'm on Comcast 240mbps and 12mbps, I'm over provisioned for the 200mbps and 10mbps I'm paying for. Ping is 38-50 depending on the maps, they're all different pings
  4. JustGotSuspended

    seems to be issues on specific servers. I know connery had a problem where everyone was kicked out the server. It could be a dos attack.

    games been feeling pretty choppy since dx11 tho, and I didn't notice any spectacular differences in performance/lag this week.

Share This Page