Where is my new Blood Rage?

Discussion in 'Berserker' started by ARCHIVED-Haldebaren, Jul 25, 2012.

  1. ARCHIVED-Haldebaren Guest

    In GU64 Update notes:
    "All versions of Blood Rage have been consolidated into one spell."
    Ok, fine. But I have a problem: Where is this spell? I can't find the new version of Blood Rage on my character. It's not in the Knowledge window. It's not in my hot bars.
    Blood rage has poofed. But I still have AA and Focus enhancing it.
    Did I miss something?
  2. ARCHIVED-Kasar Guest

    Parchemin@Storms wrote:
    I found it as a level 21 spell. It mastered in no time using what my research time had already piled up, but it's still a level 21 spell that needs to be up.
  3. ARCHIVED-Kaberu Guest

    I can't believe how many Berserkers have a hard time figuring this out. I spent a good portion of "update day" explaining to far too many berserkers how to solve this apparently dastardy conundrum

    1. Open Knowledge Book ("K" button)
    2. Sort by Alphabet
    3. "B" is for Blood Rage!
    How the heck can people not figure this out?! The sheer amount of Berserkers (including high level ones) that were asking me this seemed absolutely ridiculous to me. I'm almost afraid to ask how many players have abilities that they don't know exist merely because they seemingly don't know about the Knowledge book... I suppose we could blame SOEs lack of intoduction to the sheer amount of interface options thrown at new players, but I think some of it is just people-not-reading-crap syndrome. On that, I blame EULAs.
  4. ARCHIVED-Haldebaren Guest

    As I said in my post, I checked my Knowledge window. The spell was not visible. My combat arts were sorted with the highest version option enabled. This was simply a display bug, but still a bug.
    Anyway, problem solved. Thanks to Kasar for his answer.
  5. ARCHIVED-Kaberu Guest

    Sorting with the highest level option enabled is fine and is in fact how I did it... you just have to force it to re-sort by any method so it can be found. The alphabet is usually the easiest as, if you are reading this sentance, you should know how the alphabet works. Now if they can just make it non-gray...
  6. ARCHIVED-wwd2 Guest

    Kaberu wrote:
    Yep, did all that too, and re-sorted a few times too, and still cannot fine Blood Rage on my TWO Berserkers. I am really getting tired of this crap.
  7. ARCHIVED-Kaberu Guest

    Of the multiple Berserkers I gave the same advice to, they all found it. Why it's not working for you, I have no idea. Statistically speaking, it's likely User error... meaning it might be something on the client side. For instance: Are you using any modded UIs? Is the modded UI updated for the latest EQ2 build? Have you tried scanning your files to see if there was a botched update? You said TWO berserkers... are both of adequate level, aside from the obvious question of: "Why do you have two Berserkers?!" Etc... It might also be an issue of certain servers being botched... it seems to work fine on Crushbone.

Share This Page