Fixed Internally Varsoon Mount speed issue

Discussion in 'Resolved' started by Floekan, Feb 15, 2023.

  1. Floekan New Member

    With the update all mounts including Kelrok, Djinn Nightmare capped at 39% (I though this mount was supposed to stay faster). Tradeskill AA mount speed buff and Vah Shir Mount infusion do not provide any speed buffs. I do not have any purchased items from LoN that provide mount speed buffs but I see people in chat saying that they do not work now.
    Revvix, Unnattural, Momo and 5 others like this.
  2. DENSER Well-Known Member

    I confirm, no item was taken into account apart from the speed of the mount itself. i.e. 39%. journeyman's boots of adventure, crafting AA speed buff are not taken into account
    Sunlei likes this.
  3. DENSER Well-Known Member

    Confirmation of 24 players currently in raid
    Momo and Sunlei like this.
  4. Recognize New Member

    Same. Racial speed bonus is not stacking with mount anymore.
    Sunlei and Jafa like this.
  5. Moolti New Member

    Same with the basic mount speed and the Journeyman's boots of adventure. My run speed is equal to my basic mount speed of 39% for Frostshadow Tyranodon. I tried cancelling both and starting with one then the other and speed will not update past basic 39%.
    Sunlei likes this.
  6. Tieron Member

    Yeah, can confirm that none of the mount speed buffs are currently being applied on Varsoon.
    Sunlei likes this.
  7. Sunlei Active Member

    just to add, this could be a text bug or something borked introduced back into the game. Have seen some discord screenshot 'snips' posted -yesterday- of people with 120/125 speed.
  8. Finnya New Member

    11 days later and still no fix?
  9. Bekkr Well-Known Member

    Still broken after today's patch. If these boots don't work I'm gonna need a refund.
  10. DENSER Well-Known Member

    absolutely, it is one of the items king of the pack .
    Rather unseemly of them not to fix this ASAP
    Bekkr likes this.
  11. Hickenhacken New Member

    When will this bug be fixed??