Unable to download EQ2_setup.exe file from Daybreak

Discussion in 'Players Supporting Players' started by Discoee, Aug 4, 2017.

  1. Allenstergess New Member

    This is driving me nuts, I cannot download the installer from the website, I tried the VPN workaround and downloaded an installer but it will not install the game, I click on it and nothing happens. I used the VPN and installed the game but it will not open. Very frustrating!!
    Amopia and pplnotsointelligent like this.
  2. garcia Member

    this is not right i play to play and im not playing
    pplnotsointelligent likes this.
  3. pplnotsointelligent Active Member

    I tried everything to, it seems that nothing is being fixed either because, you cant even reinstall the game from there site
  4. pplnotsointelligent Active Member

    I feel your pain bud i'm an addict too and tried everything just spent 80 usd on this game its crazy
    garcia likes this.
  5. GrumpyJack New Member

    I been trying for a few hours and same for me it just wont install and it is so Annoying!
  6. Mazboot New Member

    same problem here since patch this AM - I live in Vermont and Comcast
  7. pplnotsointelligent Active Member

    garcia likes this.
  8. pplnotsointelligent Active Member

    I Guess i'll stop trying to log in tonight because this is ticking me off that theses guys aint even giving us any update about this issue, doing all theses maintnances and patches, and boom messing the gameplay up for some of us
  9. Hariken Member

    I just started having this issue also last night. I can't install any daybreak games and get the socket error message.
  10. JohnD212 Member

    After today's patch I am getting the socket error and can't update my client. I sent a ticket into DBG but I assume they've been getting a lot of those today.
    Amopia likes this.
  11. JohnD212 Member

    I should add I'm on Spectrum in New York City.
  12. nayic New Member

    john ik i sent in a ticket before this was even known so yeah now as its known im pretty sure they are working hard to fix this and im in jersey feldon is close 2 us and he dont have an issue so its not every1 just a good bit so im sure its getting talked about and worked on right now
  13. JohnD212 Member

    Just an update for me... I downloaded the two stuck files EverQuest2.exe and clientvdl.bvd from EQ2Wire (early posting with link in this thread). Replaced them in my directory. The launcher still didn't work so I used the EverQuest 2 application directly in the install folder (there are two so I used the one that took me to a sign on screen where I enter my log in information then it asks for my character name and server). After entering that it let me in the game and I played fine.

    Clearly this is a launchpad problem since I can get in without the launchpad.
  14. pplnotsointelligent Active Member

    John yeah we all having issues with this socket error bull, and yes somone did do a temp fix but its not working for some of us, so I guess some of us will have to do something different tonight,, yup it sucks but hell I tried everything even called spectrum and they put me over to road runner nothing is wrong on there part so its something to do with DBG server prob who knows, but I'm wasting 80 bucks this month not doing nothing
  15. Shreik New Member

    The Validate tab on the LaunchPad downloads the files EverQuest2.exe and clientvdl.bvd. Unfortunately, it still does not fix the issue.
  16. ishkabibble New Member

    throw my name into the mix of issue not corrected

    ~east cost
    ~tried all suggestions
  17. Trixwynter Well-Known Member

    Ok I uninstalled and reinstalled it and it did not work. Decided to give one more try tonight before going to bed and it worked finally! I hope everyone else gets theirs to work.
  18. Revel Well-Known Member

    Comcast, Philadelphia PA area.
  19. kacci New Member

    NJ, Comcast
  20. Aranie Member

    Curious, you said you reinstalled. What button/link did you click? Or did you download from another site? I am unable to reinstall using any of DB's links, nothing at all happens when I clicked. Thanks