Unable to buy Premium Pre-order option

Discussion in 'Bug Reports' started by Laughing Owl, Nov 5, 2019.

  1. Laughing Owl New Member

    From eq2 logged in, I go to expansion and I have an option to to pre-order all 4 versions.

    The premium is what I would want to buy; however, when I click buy, it takes my to dbg store front, but shows
    "You are not eligible to purchase the product, please check available products below:

    Where it shows the other three (standard, Collector, and F&F).

    Below that it does show Previously purchased Content and does show the Premium Edition there,, although nothing shows up in my purchase history / credit card charges so believe that is a bug with the link between the eq2 site and the dbg storefront?

    (For Example if my account was flagged as having premium edition... should buying the collectors and standard be greyed out also?)

    Just wanting to make sure the proper 'order' is in place.

    As a related sidenote, really need to adjust/modify the option on contact support, as none of the limited option in the drop down really apply here, and any of them require alot of information that can not be adequately answered, since not relevant to the actual issue.
  2. Majandra New Member

    I am having the exact same issue. Lifetime membership if that is relevant.
  3. Suzze/Barshen/Baratroub Member

    Same issue here.. Lifetime member, Yet not able to Purchase the Premium. All others were available. Purchased the Collector's for now, But would really like to upgraded when possible
  4. Poetic_Justice Member

    You are not eligible to purchase this product. Please check available products below.

    Having the same trouble here.
  5. dreamweaver Community Relations

    There is an issue with purchasing at the moment, it is being investigated.
    Breanna likes this.
  6. Laughing Owl New Member

    Update: Purchased the Collector's for now, But would really like to upgraded when possible
  7. Ananga New Member

    Same thing for me
  8. Majandra New Member

    I checked on my alt account, used 2 diff pcs, and 3 diff browsers, with no luck. Currently all but one guildy who has weighed in has been unable to purchase as well.
  9. Majandra New Member

    Update: It *just* let me purchase it now. I don't know if it made a difference, but I hit buy on the most expensive, then hit back, and selected the premium and it worked.
  10. Sigrdrifa Well-Known Member

    (1) Start from https://www.everquest2.com/expansion-content

    (2) Click the Premium Edition "Buy Now" button (link https://www.everquest2.com/goto?typ...ctedSku=EQ2RE-PO-DD1017-PRMCLC-DWNLD&service=)

    (3) At the top of the page is a red box with text "You are not eligible to purchase this product. Please check available products below". Blood of Luclin Premium Edition Preorder shows up greyed out under the title "Previously Purchased Content"

    (4) Same results in Firefox and MSI.

    (5) I am NOT a Lifetime member.
    Breanna likes this.
  11. Crayons New Member

    same happened to me i closed the website and re logged into it and it let me buy it
  12. Majandra New Member

    Dreamweaver posted on another thread saying it is a known issue (8 min ago), but maybe it is resolved now.
    Breanna likes this.
  13. dreamweaver Community Relations

    It looks like this has been solved. Please let me know if you are continuing to have issues in this thread.
    Breanna, Majandra and Pixistik like this.
  14. Sigrdrifa Well-Known Member

    Yay! I was finally able to purchase.
    Breanna likes this.
  15. Loce New Member

    The question is... do you have to re-pre-order now that it is fixed.
  16. Suzze/Barshen/Baratroub Member

  17. Hellfiren Active Member

    Same Here wanted to buy Premium Edittion and not get any info in Account View or purchased items not listed.
    Retried it once again same issue , wrote a Support ticked, would be nice if get a information via Mail if we bought it now or we need to retry dont want to buy the Expac more times.

    Sovled NOW :) Thanx Dream :)
  18. Rarkevan Active Member

    Still tells me I am ineligible to buy the Premium edition. I guess I will keep trying and report back.
  19. Kuzami New Member

    I'm still having the same problem. Have tried closing out the page and relogging in, and get the same results.
  20. Loce New Member

    Well, there is fixed and fixed. For me, when I go back to the purchase page, the Premium Edition is not listed as an option to buy. However, below that is Previously Purchased Content and the Premium Edition is listed in this box. Stuck?

Share This Page