streaming launcher instantly crashes with a C++ runtime error

Discussion in 'General Tech Support Questions' started by ARCHIVED-Nathdorl, Feb 20, 2010.

  1. ARCHIVED-Nathdorl Guest

    Heya,

    wanted to give the streaming client a shot but found it unusable for me. after running the launcher_setup.exe and selecting a path and version, the program extracts a couple of files and apparently runs launcher.exe which imidiately terminates with the launcher stoping at "updating files for launcher" and i get a "microsoft visual c++ runtime library" runtime error

    Program: (this is empty)
    This application has requested the Runtime to terminate it in an unusual way.
    Please content the applications support yaddayadda

    now... is there some logfile that might contain further information? there apparently is none inside the folder where the launcher.exe resides
  2. ARCHIVED-Autenil Guest

    Nathdorl wrote:
    I'll pass this on to the Launcher team.
    What OS are you running? (Windows Vista 32-bit, Windows 7 64-bit, etc)
  3. ARCHIVED-Nathdorl Guest

  4. ARCHIVED-Nathdorl Guest

    i just out of the blue figured this out by myself, but i have to conclude, this is a software bug, affecting both the station launcher, and the "regular" eq2 streaming client launcher (coming from launcher_setup.exe). the bug #1 is: both launchers use IE's proxy settings without asking the user if they shall do so. bug #2 is: i have IE set up to use a socks proxy and apparently, the launcher doesnt understand this. when i disable the socks proxy in IE, both launchers start and download fine. please forward this as a bugreport, hope the information given is sufficient :)
  5. ARCHIVED-Nathdorl Guest

    aaaand next error. the 'regular' streaming launcher reports this: Error: 2000 id: IDS_MINSPEC_OS param: IDS_OS: 5.1.2600.2 SP0.0 Error code: 2000 that looks like its trying to tell me, that you need at least windows XP ( windows NT 5.1). but im running windows xp 64, which happens to be windows NT 5.2, so it should be fine.... yet above mentioned error
  6. ARCHIVED-DanKinney Guest

    Nathdorl...
    We'll definitely be looking into this in detail. You do need to have at least XP with Service Pack 2.
    -dan
  7. ARCHIVED-Nathdorl Guest

    Nathdorl wrote:
    this could be fixed with a reinstall of the launcher. sorry for the hasty action. bug with the socks proxy remains tho.
  8. ARCHIVED-TigTiger Guest

    I'm not sure if this is related or not and i've posted about this before in a few other places but never got any kind of concrete response. The game and launcher runs fine for me. But when I try to run LON in the game I get the same C++ runtime error. Every time. Sometimes if i've only started the game recently, like within the last half hour it does not do it. But for the most part everytime I try to run /lon in game I get this same error.

    I also found this from Microsoft. http://support.microsoft.com/kb/884538 Not sure if this applies to what /lon is trying to do in game, or if possibly this would help Nathdorl with his problem, but thought it was worth mentioning. :)
  9. ARCHIVED-TSR-DanielH Guest

    TigTiger wrote:
    It seems like some of the LoN files used by the streaming launcher are broken at the moment. If you start the game with the station launcher or the stand-alone client then that should allow you to access LoN, though. I have included links to both of those options below:
    LoN client(scroll down and it's on the left):
    http://legendsofnorrath.station.sony.com/
    Station Launcher:
    http://launcher.station.sony.com/
  10. ARCHIVED-TigTiger Guest

    Ahhh....well I guess that would explain it. And thank you for not trying to get me to update this and that and the other. Heh...belive me i've tried. Video drivers, Sound card drivers, DirectX, IE settings, game files, deleteing game files and letting the game reinstall them, etc...etc...etc... I understand this dosent happen to everyone but only a specific group with specific hardware types I belive as i've had people in the game say "Oh yea that always happens to me too" and others go "I dunno what your talking about I never have problems with it" <Shrug> At least someone SOMEWHERE knows what's going on. :)
  11. ARCHIVED-Sunadune Guest

    I'm getting the same runtime error as Nath did a long time ago, with the exact same message errors coming up. At first the launchpad screen came up, but only with a black background and telling me "Trying to rehash __, please try again in a few minutes," only this lasted for over 12 hours. So, I tried reinstalling the launcher, which got rid of the launcher screen altogether and gave me the runtime message. I work with a windows 7, 32 bit and I'm in need of help :(
  12. ARCHIVED-Vyndycta Guest

    I have the same problem. Haven't been able to log in for a week. I've followed instructions that I saw somewhere about running as Administrator, and setting compatibility to XP, sp 2 which I have done. I've also deleted the whole works and tried downloading again, but still get the same message.
    I have Win 7, it worked like a charm until a couple of weeks ago.

Share This Page