Still can't login

Discussion in 'General Gameplay Discussion' started by oblio, Nov 17, 2020.

  1. oblio New Member

    I'm glad that others are able to login now but both my wife and I still get stuck at 99% and get to watch the little dinosaur strut. We were able to login last night for about an hour and that has been it for the last week. This is getting pretty old. We reupped for 6 months and got the newest expansion and have not been able to play. Hindsight being 20/20 I would have NEVER reupped if I knew how poorly this would be handled.
    WhysperWynde likes this.
  2. Benito Veteran EQ2 Player

    WhysperWynde likes this.
  3. dreamweaver Community Relations

    In addition to the above steps the team has checked the streaming download again so you could try that again now as well.
    Breanna likes this.
  4. Odium New Member

    I want to leave this here as well - while certainly not an official fix, one of my Guild members has been doing this, and it has worked for him every time (multiple occasions):

    Load your game as normal, wait until the 99% walking dino, then, disconnect from the internet (wi-fi in his case) then reconnect. This has reportedly never failed and has worked for him every time he had the 99% dino.

    While I am not a technical guru, if this is indeed a more broadly accepted fix, it may also be a clue as to the underlying problem.
  5. Supervova New Member

    Stuck at 99% like others, uninstalled/reinstalled the game. saw a suggestion to do a full install but do not see an "advanced Tools menu on the launcher window. what version of launcher should be used to get the Advanced Tools pick? thanks
  6. Supervova New Member

    Figured out the launcher full down load... Once it's done we'll check if it helps the situation..

Share This Page