Sir Trodonis not upgrading Lucanic Weapon?

Discussion in 'General TLE Discussion' started by Oldred, Mar 2, 2020.

  1. Oldred New Member

    Has anyone been able to get their upgraded soulfire weapon after defeating Mayong Mistmoore and completing the Sword of Destiny timeline?

    We defeated him last night, I had the lucanic weapon in my bags - yet Trodonis only gives the standard NPC responses when I hail him. I bugged it already.

    Thanks
  2. Somedude Active Member

    No.

    We have defeated all 3 versions of Mayong and none of them are updating SoD.

    This is a known issue, and last I have is they are looking into it, but no indication of timeline on fix and whether or not you will have to repeat the kill.
  3. Zenji Well-Known Member


    This makes you wonder, if not the major sig quest of an expansion, what is actually tested before the expansion is launched.
  4. Somedude Active Member

    The answer is nothing, nothing is tested.

    There is a test server for live, but I doubt anyone bothered to do SoD on the test server =)

    Even if there was a TLE test server, it is unrealistic that players would take the time investment to do this questline on a test server.
  5. Adoninilol Well-Known Member

    To jump off what Somedude said basically it's the principal of the fact.

    If I know this has been working for two TLE's now, the ability to get the weapon; i'm perplexed as to why I would go ahead and test something like this even if we had a beta for the TLE.

    Soulfire isn't a serious time commitment, it's maybe 5-6 hours of sitting down and doing it, but gathering a raid to go clear mayong after, and doing the quest on a toon that will get wiped is a bit silly in my opinion; especially a update that did work on all previous TLE's. I'm just curious as to how this broke.
  6. Oldred New Member

    I'd say it's a bit longer than 5 to 6 hours. It's not as bad as Qeynos Claymore, but the whole thing from start to finish takes longer than 6 hours =P I'd love to see someone complete it in that time frame.

    I agree though, I'm not sure how a quest that has worked on the previous two TLE's some how got broken on Kaladim. Some serious butterfly affect bug fix I'm sure.
  7. Reptoid Member

    I imagine due to them recreating items, for whatever reason they felt they needed to rather than reitemizing like they always have, has created a myriad of problems. This is just one of the problems that it has created. Personally I feel its super messed up because I had 2 of these questlines done by the end of day 2 and still no weapon for me.

Share This Page